Changing landing page in CIBonfire

I am using Bonfire which is built on top of Codeigniter. All I really want to do is bypass the landing page with the continue button on it and go straight to the public facing app. This is how it came in Version .6, but now in .7 there is a cover page first, with a continue button on it. Which is great for installs, age verification, etc. but now that it is installed it is an annoying click for the user to even start looking at the app. I’ve looked into routing and template views but I don’t feel like I’m on the right track… you can view the current attempt at for clarification which still has the documention for Bonfire in the template.

Hi TurtleWolf,

It looks as though you’ve uploaded all of the Bonfire files into your web root (sometimes /public_html or /www on your server).

What you need to do is ensure that only the files from the public folder go into your web root folder, and the other files and folders should go in the parent folder, so you’ll end up with a structure like this one shown in the docs:

/public          // Web Root in here...

Actually… it’s all in a subdirectory, but I don’t see how that should affect it. The documentation and video tutorials would suggest I need to change the default route, but that changes so many other settings indirectly.

The whole idea of keeping the framework files outside of the web root is for security… a visitor can’t browse to any folders outside of it. The way you have things set up at the moment, everything is within your web root. You can see this because clicking past the landing page takes you to

ah… I see the confusion. you are reading the URL literally, Codeigniter uses a mod rewrite to redirect the URLs. What it says in the address bar is not where it is at. I’ve asked the same question in the Bonfire forums…

Could you explain how you currently have the folders arranged on your server?

I am just using the basic template… all I’m doing is renaming the directory, when you first unzip it on the server it is called Bonfire-Master. after that it is the only page drawn straight from an index… everything else is drawn up from a template.

So you unzipped to Bonfire-Master, renamed the folder (Bonfire, or whatever) and now your domain points to that folder?

yes, that is correct… sorry for the delay in responding, I had a shift of delivering pizzas this evening. I’m back on code until I fall asleep now. I guess I can work around it in the mean time, but it’s so frustrating, it doesn’t seem like it should be that complicated… I guess it’s the difference in how it is handled. Everything else is an insertion of the template. but in the public folder it is just the index.php. I know there has to be an easy way of rendering the template as the landing page, but it continues to elude me.

That being the case, instead of pointing your domain to the bonfire folder, point it to bonfire/public folder.

Awesome! Thank you. that seems to be working just fine!