Can't use block editor in a site


A week ago, I’ve noticed that the block editor has automatically changed to the code viewer, and I can’t switch back to the block editor. When I try to enable the block editor, this is what happens:

My site is hosted from What’s worse is that the WordPress official forums is useless, because I didn’t get any response from anyone when I posted there.

When I tried to find solutions to the problem, Google shows me old articles that are unhelpful and don’t have to do anything with my current problem.

How can I enable block editor?

Is there a chance that the theme you are using disabling visual editor? Or any conflict plugin? First you can try to use a default theme. Then de-active plugins.


As for the theme, I’m using “Twenty Twenty-Two” as a theme. There is no chance that it could have disabled the block editor, because I could write blog posts with the block editor until a week ago. This issue randomly happened and I didn’t change themes.

As for the plugins, I can’t install them because my site is on a free plan, so I have no plugins installed.

The weird thing is that I can use the block editor when editing the theme. Just not blog posts.

Profile Settings: As the highlighted option suggests, the Visual Editor might be disabled in your profile settings. To check this:

  • Go to your WordPress dashboard.
  • Click on Users and then Your Profile.
  • Look for the Visual Editor checkbox. If there’s an option that says “Disable the visual editor when writing”, ensure it’s unchecked.
  • Save changes if necessary and try editing a post again.

Thanks! When I click on Users, I only see the following options:

  • All Users
  • Add New
  • Subscribers
  • My Profile
  • Personal Settings

I can’t see Your Profile and when I click on My Profile, it takes me to a screen that only has “Profile” and “Profile Links.” When I go to “Account Settings,” I can’t see Disable the visual editor when writing.

You must be logged in as an admin, @eoflaoevicecity


I’m already an administrator in my blog site and I’m logged in as an administrator. I managed to find a page similar to the picture, but I can’t see “Disable the visual editor”. I can’t upload the picture right now because my Internet connection is unstable right now.

However, I’ve discovered a strange discovery, because the visual editor works on Chrome Android, but not on Opera Android.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.