Call to undefined function mysqli_connect(), Help!

So I’m locally trying to connect to my database and I’m receiving this error.

I know that it means it’s a problem locally but I’ve checked everything,

I’ve deleted the ‘;’ beside the sqli line in php.ini,

Apache sees that PHP is installed and php runs fine locally on my computer for other scripts, it’s just running into this problem when I try and connect to my database.

I’ve copied libmySQL.dll and libmySQLi.dll to system32, and still no luck.

Any suggestions?

Are you running php5 or php4?

I think the “i” functions became available in php5.

I have PHP 5.2.14 installed

(I have also tried simply mysql_connect as well but that fails, the problem seems to be I have made an error somewhere and the command ability hasn’t been added).

Did you restart the server after removing the ; ?


Do you see mysqli listed in the output from that?

You could also run phpinfo() and see if it is installed.

Array ( [0] => bcmath [1] => calendar [2] => com_dotnet [3] => ctype [4] => date [5] => filter [6] => ftp [7] => hash [8] => iconv [9] => json [10] => odbc [11] => pcre [12] => Reflection [13] => session [14] => libxml [15] => standard [16] => tokenizer [17] => zlib [18] => SimpleXML [19] => dom [20] => SPL [21] => wddx [22] => xml [23] => xmlreader [24] => xmlwriter [25] => apache2handler )

Short answer: No, it’s not listed.

Did you edit the correct php.ini file? Servers can sometimes have php.ini files lurking in various places, in the output for phpinfo() look for en entry called “Loaded Configuration File” the value for that will be the php.ini file that is being used.