Bizarre Redirect problem - only 1st time


#1

Hi,

we have created a new directory called: my
under this we have some files, main one of which is: home.php
when people try to goto:
https://www.anoox.com/my/home.php
the 1st time on their visit, and ONLY the 1st time, they get an Error 404 Page not found!
What is causing this bizarre problem?
And I have checked the .htacess file on root directory and there is nothing there about my or home.

BTW, to get to this file that is https://www.anoox.com/my/home.php you need to be logged into
your Anoox account. If not, it will redirect you into login page, but again NOT the 1st time and
instead you are sent to Error 404 Page not found!
Also some other points about this bizarre problem:
1- Problem only happens when you launch your browser the 1st time, any browser
2- It happens only on PCs and not on any Apple Macs

As I said it is Bizarre problem :slight_smile:

Thanks,


#2

< offtopic >

WorldNews-Metric-Black-font.zip (47.0 KB)

< /offtopic >

coothead


#3

Works fine in Chrome on my Android phone


#4

Can you not create a page that doesn’t require someone to create an Anoox account?


#5

Yes, it seems like the problem only occurs on PC/Laptop devices!
As I said it is really bizarre!
My suspension is it has something to do with word home in home.php and PC based Web browsers!
Well it is not so much a suspension as observed facts and cannot figure out why!


#6

Yes, there are pages you can goto which do not require being logged in as member.
Such as: https://www.anoox.com/my/share.php?i=134416

But these pages all load OK. Even though they are in same new my directory.


#7

Thank you for this Font. I shall try it ASAP.


#8

< offtopic >

        No problem, you’re very welcome. :winky:

        coothead

< /offtopic >


#9

Do your error logs show anything?


#10

Hi Gand,
Which Error logs should I look into and what should I be looking for?
Really bizarre this problem is :frowning:


#11

I’m not sure if there would be any errors at all, but it’s worth a look. I was thinking of the PHP and Apache logs…


#12

worked fine for me the first time on my PC. shrug


#13

Same here on PC in any browser. It takes me to the login page.


#14

1st, guys again you would have seen the problem if you had loged into your Anoox account.
2nd, problem is solved :slight_smile:
FYI: Following the tip from Gand I looked at the Php Error log file and after Hours of forensic work and a most nifty Linux command to find a string occurance all over a server, found the cause of the problem which was an include file loading a function that had in it a SESSION variable causing the bad file name and hence Page not found error. Sheeeesh :slight_smile:


#15

< offtopic >

Hi there WorldNews,

did the font come up to your expectations? :winky:

coothead

< /offtopic >