Bash: vagrant: command not found

support
book

#1

I’m reading e-book “PHP & MySQL: Novice to Ninja, 6th Edition” and my question is about ch1 “installation”. I did the following:
installed: 1. Git; 2. VirtualBox; 3. Vagrant
In Git Bash after running command: git clone https://github.com/swader/homestead_improved my_project
[my_project ] folder was created in directory C:\temp
In Git Bash after running command (from \c\temp\my_project): ls
the result is: after.sh* aliases bin/ composer.json composer.lock homestead* Homestead.yaml LICENSE.txt readme.md scripts/ src/ Vagrantfile
In Git Bash after running command (from \c\temp\my_project): vagrant up
the result is: bash: vagrant: command not found

What I should do to start the server successfully?


#2

Put the path where the vagrant executable is into your PATH variable (or whatever the equivalent is on Windows).


#3

Do you mean Vagrantfile (type File)?


#4

What is the exact name of vagrant executable?


#5

On Linux it's vagrant, on Windows it's likely to be vagrant.exe.


#6

You may need to reboot (or log in then out) after installing vagrant before the command is recognised.


#7

HI

I too have obtained the text book the OP has.
As the OP, I am, how should I say, kinda like the episode in the TV show “Fraiser”, were Niles was attempting to play a video game and his nephew says: “Gee…I never saw anyone die in the waiting room before…”, as I am too dying in the first 11 pages of this book. I am frankly going throw it in with the BBQ charchol and go get XMAPP if I do not stop wasting time attempting to get this GIT/VAGRANT et al. going.

The only operation I had any success with is the clone ditty. I have read and re-read the QUICK TIP webpage. I got the my_project folder established. I performed a complete search of my C: hardrive and the vagrant.exe is not found on my windows 8 laptop. I have enabled AMD AMT-V.

The 10,000 hours to “become an expert” is evidently for the attempting to get vagrant up and running.

:face_with_raised_eyebrow:


#8

Hi michael_dunagan welcome to the forum

You didn’t give any information regarding what steps you tried that failed, so this may be totally unhelpful.

One of the problems I had when I first tried to install a project on my Windows 10 is that I put the project folder directly under C:/

It seems that doing that caused all kinds of permissions problems that I did not solve. But after I put the project folder under my documents folder I was able to succeed. It meant slightly longer filesystem paths that I had tried to avoid (my typing skills leave a lot to be desired), but I had much better luck making progress.


#9

Hi Michael,

Did you install vagrant and virtualbox? When you install vagrant you can choose where it is installed.


#10

Hello MIttineague

Thank you for the quick reply.

I did have success establishing the my_project beachhead.

The most common error was the invalid command, internal or external.

I installed GIT, Virtual Box, and Vagrant to the C:\ root directory also as did you claimed you did. The idea was not to have a long file name path and to make this stuff easier to spot. It is very interesting that you were able to get things to work in the my documents folder.

I did rip out my “VIRTUAL_SERVER” folder using windows explorer and then I created and just plagiarized the author’s “My_Project” when re-doing the clone command. I downloaded the zip files to my desktop, but I targeted the C:\ drive upon downloading: at least I believe I have.

Waking up this morning I do have the following new error:

image

This error is a bit more assuring: I believe the book says, if vagrant take a while to upload, I suppose this is the blinking cursor with nothing to the left of it, and then finally pukes out the above message, I have some Virtual Box ah huntin’ to do.

I am begging to see why installers of servers command $100/hr…:expressionless:


#11

I’ve had 300+ students install vagrant and virtualbox over the last couple of years. I’ve never see anyone have this much trouble. Do you have some odd limited windows account? Usually this is a 5 minute job. If it doesn’t work it’s usually because vtx is disabled.

If you haven’t already, reboot after installing vagrant and virtualbox


#12

Hi TomB

Thanks for the reply.

Well, the 300+ students were probably in good with GOD, which I am not so fortunate,

Yes I rebooted the machine multiple times.


ANNOUNCEMENT

I am ripping this time wasting stuff off my computer after I send this reply. I am going to go back to the reliable, to me anyway, XMAPP.

I no longer need to usurp finite expertise when such expertise may be utilized by other worthy forum posters.

Thank you

MPD


#13

image


#14

OKAY!

How about THIS for WHIPLASH! Play the tune from 80s Metallica

Guess why Vagrant could not find the VIrtual Box?

It is because-- IT DID NOT INSTALL! Depsite all the flashing and progress bars were “fake news”, cosequently, Virtual Box did not install, at least not completely, due to a lace of space on my laptop’s hard drive.

The Oralce program, as big as a whale, takes a gigantic 273 GIGs to install; I only have 203GIGs available even after a disk cleanup.

I guess the author was not kidding that this stuff needs to see the ERA of “Terabyte” drive and the Gigabyte drives of yesteryear are evidently now an obsolete specification.

So the moral of the story? DON"T GET A 2017 PHP BOOK IF YOU ONLY HAVE A 2012 LAPTOP!

PROBLEM SOLVED FOR ME

Unfortunately, the same difference in the end: I have to wipe the programs due to a lack of hardware resources which to runs said programs.

MPD


#15

For the record, VirtualBox is not 200gb it’s 200mb (0.2gb).


#16

Under oath, I vividly recall that when I attempted to again install VirtualBox, I did not have unused space on my hard drive as deemed by the Application’s own verbiage.

I cannot believe that my 203GB available hard drive space would puke-out a 200MB application. I am quite sure that VirtualBOx was asking for 237GIGS.

I am sure which universe which your VIrtualBox is in, but in the one which I live, VIrtualBox was too bloated.


#17

The installer is just over 100mb. There is no way it’s 200gb uncompressed. I’m on linux and the package is 103mb installed. It wouldn’t be much different on windows. I guarantee that it’s not 200GB, however.

image


#18

Thank you TomB.

Well–The Whipsawing continues.

In life, if I lose something, I never find it until I purchase a replacement or until I no longer need the item.

Similarly, it appears I cannot make progress with VIrtualBox and Vagrant until I complain that I am not making progress.

BEHOLD! A screen which I have not been able to obtain until now:

This screeeshot appears to show a level of success. When I get done doing the jig from happiness and joy for getting VIrtualBox to cooperate, at least thus far, I will attempt to re-install Vagrant.


#19

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.