Background gif - prints unwanted 2nd page onward

The gif displays as wanted, for a header link bar on any 1st page article:

body {
background-color: #FFFFFF;
background-image: url(i/navbar.gif);
background-repeat: no-repeat;
background-position: left top;
}<span style="position:relative;

Using relative links:
<span style="position:relative;

But when printing, the image shows by itself on on page 2, page 3, etc
Even with ‘no-repeat’. With dimensions of 935 x 65

  • How to eliminate the appearance of the gif after page 1 ?

Don’t set it on the body :). Set it on a wrapping element.

Untested though since I don’t have a printer :slight_smile:

Are you referring to something like?

background:url("i/navbar.gif) no-repeat; 

Any examples you might point to, as I can’t seem to find any?

State it within the span that the links appear on?

By setting the css/background gif in the table tag, this went away ONLY FOR FF. Not IE

.nbar {background-image: url(i/navbar.gif); background-repeat: no-repeat; background-position: left top; line-height:145%; color:#000000; text-decoration: none; font-size: 13px; font-weight: 400; font-family: Arial, Helvetica, sans-serif;}

Wrapping element, table that contains everything. Tomatoe Tomatoe :wink:

We need to be able to see a link or at least full code so we can reproduce this at our end so some of us can debug it :slight_smile:

RyanReese , thanks for the help. That last snippet I posted simply was without the “background-attachment: scroll;”

And applied to the table and not the body, it works for Firefox and IE.

Guess I was looking for a more complicated answer.

background-attachment:scroll is a default property.

If you mean IE6 wasn’t working, then yes you are correct because background-attachment:fixed (the other value for it) doesn’t work in IE6 except on the <body> element.

Glad you fixed it though :slight_smile: