Apache will only load localhost:8080, not localhost

Hi guys, I have just installed apache+php+mysql as per the instructions in ‘build your own database driven website’ - kevin yank.

This works fine on my xp machine and I can go to localhost and it works.

But I have just installed it on my fresh win7 home premium installation and, even when I select ‘install for all users on port 80’ during installation, I can only get to the server if I add :8080.

Any ideas what I could be doing wrong?

portem,

I’ve paid dearly (in time and effort) to get Apache to run on my Win 7/64 box so you’re one up on me there with the 8080 (I won’t tolerate the 8080 and insist on using port 80). Too many install/uninstall cycles to remember exactly what I did but

  1. Make sure IIS is turned off and disallow it from auto start with Windows. That SHOULD leave port 80 open.

  2. Win 7 permission problems mean that it can’t be run from Program Files. Therefore, in the Typical Install, change the installation directory to something which is NOT protected by Win 7, i.e., NOT Windows, NOT Program Files, NOT Users, etc.

  3. #2 will cause you to have to edit the httpd.conf file so Apache knows where it’s located (the installer is not particularly good at this for some reason).

  4. THEN install PHP (via ZIP) and edit the php.ini and the httpd.conf as Kevin specifies.

Apache on Win 7 is a PITA. Guess who wanted it that way. Anyway, if you are persistent, it will work just fine.

Regards,

DK

Beside IIS, Skype is also known to occupy port 80.
So if you have Skype, open it’s main window and go to tools > options > advanced > connection and untick the checkbox for “Use port 80 and 443 as alternatives for incoming connections”

yeah the install/uninstall cycle is getting quite old. I really would rather run XP but was told my laptop (Lenovo T510) would have trouble installing it heh.

I am pretty sure I don’t have IIS installed (don’t see it in services.msc) and I don’t have skype. Running a totally fresh Win7 home prem. 64 install with nothing added except basics like firefox, notepad++.

Uninstalling Apache and reinstalling it directly under c:\ instead of in program files, followed by a reboot, fixed it! I can now use localhost.

How weird is that heh

Thanks so much!

portem,

You have Mr Gates (& Co, i.e., M$) to thank for that!

Regards,

DK