Apache on Windows Vista problem


I have been trying to install Apache 2.2.2 on Windows Vista, but i get 2 errors on install (at the end of the process):
-Failed to open WinNT service manager
-No service installed called “Apache 2.2”

I tried installing by using cmd and running httpd -k install, but the first error re-appears.
Is there any way to fix this?

Yes, don’t use Windows Vista ^_^.

I wish i had another option, but i dont really want to buy XP at this point, and i find linux infuriating.

If it’s your only option, than you are truly SOL

This is a little old, but I just found this post when searching for a solution to the same problem:

Go to Start | All Programs | Accessories, then right-click on “Command Prompt”, and select “Run as administrator”. This will open a command prompt window with admin rights. Navigate to the directory where you saved the apache*.msi install file, and type “msiexec /i apache*.msi” (where apache*.msi is the actual name of the file - hint: type apache and then hit tab, it should fill in the file name automatically). Hit enter, and the rest should work just fine, it did for me. Hope this helps.

What I did to install Apache web server as a service in port 80 on Windows Vista RC1 is disabling user account control.

  1. Uninstall Apache Web server and remove the files from program files folder.
  2. Go to start > control panel > user accounts.
  3. Click on “turn user account control on or off”.
  4. Uncheck “user user account control (UAC) to protect your computer”.
  5. Click “OK”.
  6. Restart Windows Vista.
  7. Reinstall Apache.

Vista just launched in the UK at the end of Jan 07, (a week ago) and I suffered the exact same problem. I couldn’t find the *.msi file so I tried pedro’s method and it worked exactly as he wrote. Thanks very much. To those who are yet to try it, when you launch Apache or start windows (when apache automatically launches itself) you get a little box with a red cross in the middle and an ‘error’ message before you ‘fix’ the Apache install. I would just like to point out that I still get that error message after the ‘fix’ but Apache works fine anyway.

And to those who might be ‘anti-windows’, Vista is a treat, you should try it. :slight_smile:

THANKS to HiVisDiver for this!




I manage to install Apache 2.2 on Vista but I still get that annoying alert message [as noted here by tinram] when window begins… Is there any way to disable it without affecting Apache?

thx in advance,

I had the same problems with installing Apache on Vista.

First of all, I turned off User Account Control:

  1. Start > Control Panel
  2. User Accounts
  3. Click “Turn User Accounts Control on or off” Link.
  4. Uncheck “Use Uer Account Control” Box
  5. Click OK
  6. Restart Windows

I then downloaded the MSI Apache installer version from Apache.org, and saved it to my desktop. I then renamed the file to apache.msi

I then ran the installer through the command prompt running in Administrator mode:

  1. Start > All Programs > Accessories
  2. Right-Click “Command Prompt” and choose “Run as Administrator”
  3. Change to your desktop folder (usually cd desktop)
  4. Type the following: “msiexec /i apache.msi”
  5. Run through the Apache installer as normal.

After Apache had been installed and I had restarted my machine, I wanted to get rid of the annoying red error box that appears. This is due to the “Monitor Apache Services” program trying to load at startup.

Delete it from the startup folder of the start menu (Start > All Programs > Startup)

You should then be able to start and stop Apache using the icons in the start menu under the Apache > Control Apache Server folder. Better still, why not make a shortcut to them on your desktop for easier access.

Also, wanted to point out that I tried everything in this thread and still couldn’t get it to work. It kept saying there was a problem with “ServerAdmin” even though I added an email address during the install. The fix this error, go to Start -> All Programs -> Apache HTTP Server -> Configure Apache Server -> Edit the Apache httpd.conf Configuration

Scroll down till you see:

ServerAdmin admin@localhost

ServerAdmin will probably be blank, so just add an email address right next to it, save the file, close it, and restart Apache.

Thanks again, all! :tup:



Tiago have you resolved your problem yet. I just got Vista on a new notebook in March. Many times I came close to reformatting and doing a fresh install of XP Pro. It was hard to get use to the changes and the complications did not help much.

I wrote a rather detail tutorial of installing Apache, Perl, MySql, and PHP on windows. And I updated last month to include the problems encountered with the new Vista System.

For that annoying alert on startup this is what you need to do:

Go to Start, Run, and type in msconfig and click OK
Select the Startup tab and uncheck the box by the “Apache HTTP Server”
You will then have to restart you computer.

Apache will still run fine. You just won’t have the icon in the System’s Tray to open the Apache Monitor with. But you can do that from the Start Menu with a few more clicks.

This will help:

Apache and Vista Notes


To fix the apache monitor you have to go into the apache directory and find the monitor application. In 2.2 it is in the bin folder. Right click on that and go to properties. Click the compatibility tab and choose to run it as windows xp sp2. That should get you monitor working again and get rid of the annoying error message.

I followed all the steps and I have Apache installed successfully on Vista. But how when I try to edit the httpd.conf file and save, I get the error:

“Cannot create the C:\Program Files\Apache Group\Apache2\conf\httpd.conf
Make sure that the path and file name are correct”

What the heck is going on?!

Vista does have a problem with that. I have since dropped Vista and downgraded to a better OS (Back to XP). However, this is the way I worked around that problem during my short Vista experience:

Vista won’t let you overwrite a file in the Program Files and some other folders. So what I did was saved the file into My Documents. I then used windows explorer to move the file within the Program Files folder and overwrote it. Of course Vista will ask you a dozen times if you are sure you want to replace the file.

That is another good reason to install your Apache and other service files in another folder.


what do you think the chances of my development server (xampp) running right off the bat… on windows vista?

probably renting a laptop soon to take to client meetings… and most of em around have Vista Home Basic now… :frowning:

I had the same sort of problem using Microsoft Vista Ultimate and the Apache HTTP server v2.2.4 using the windows installer program:

I ran the following command from the MS-DOS prompt:

msiexec /i apache_2.2.4-win32-x86-no_ssl.msi

and kept on getting the following error at the end of the installation:

Syntax error on line 133 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf:
ServerAdmin takes one argument, The email address of the server administrator

Thanks to the feedback from the people on this thread I managed to fix the problem as follows:

1) Created directory C:\\Apache HTTP Server
2) Create directory: C:\\ProgramData\\Apache
3) Downloaded the apache_2.2.4-win32-x86-no_ssl.msi file into a directory called C:\\Apache HTTP Server
4) Start->All Programs->Command Prompt->right click->Run as administrator
5) cd \\Apache HTTP Server
6) msiexec /i apache_2.2.4-win32-x86-no_ssl.msi
7) Moved httpd.conf file from: C:\\Program Files\\Apache Software Foundation\\Apache2.2\\conf to: C:\\ProgramData\\Apache
8) cd \\Program Files\\Apache Software Foundation\\Apache2.2\\bin
9) Installed apache: httpd -e debug -f C:\\ProgramData\\Apache\\httpd.conf -k install
	Displays something along the lines:

		Installing the Apache2.2 service
		The Apache2.2 service is successfully installed.
		Testing httpd.conf....
		Errors reported here must be corrected before the service can be started.	
		[Fri Jun 01 11:31:03 2007] [debug] mod_so.c(246): loaded module actions_module
10) Started apache: httpd -e debug -f C:\\ProgramData\\Apache\\httpd.conf -k start
	Displays something along the lines:
		[Fri Jun 01 11:32:04 2007] [debug] mod_so.c(246): loaded module actions_module
11) Test apache by entering the following url in my browser: http://localhost/	
	If all is working your browser should display:
		It works!

To stop the HTTP server:

httpd -e debug -f C:\\ProgramData\\Apache\\httpd.conf -k stop

To uninstall the HTTP server:

httpd -e debug -f C:\\ProgramData\\Apache\\httpd.conf -k uninstall

All these commands can be displayed using:

httpd -h

Thanks for the posts. Very helpful.

I have published the following article, http://anderson-web.blogspot.com/2008/01/install-windows-vista-apache-22-mysql.html where I explain with details how to install apache and php on vista.

Mr. Anderson