Apache 2.2 / Win7 - slow or not responsive

My cnfiguration - Windows 7 x64, Php 5.3, Apache 2.2.15, latest Mysql.

When loading pages from localhost, the response time shown by firebug is more 530ms for the main ‘index.php’ file, sometimes the connection is reset. It’s painfully slow.

I googled the problem and found a workaround - switch off and on again a win service called BFE - base filtering engine. Then everything works like a lightning
but xdebug doesn’t work in netbeans.

Why is this response time so long? Can you think of any other solution than BFE toggling?



Thanks for that update! Surprising but … well, Apache.org must not cater to M$. Perhaps running it in 32 bit mode will resolve that problem.



ok, I tried xampp and all other sugegstion given in forums but finally reverting win7 to 32bit edition solved the problem. Seems Apache is not yet comfortable with 64bit systems.

Wamp is quite slow when I use Firefox because of all the debugging Addons that are installed. The Opera that I have is far quicker because there is no Addons to check the scripts.

A friend of mine has Wamp installed on another hard-drive and reckons that it improves performance dramatically.

I Googled and found numerous users also complaining. I tried a few suggestions and the speed increase was not dramatic although the cache seems to be working fine.

I do not think there is a simple solution because of all the variables in hardware as well as software.

Best of luck and if you do find the solution then please post your results.


Did you “Stop All Services” and then “Start All Services” for WAMP?


Ok, I went through all the steps, with no success… GET response for the main file is 500-600ms:(

I did:
2. set httpd.conf -> Include conf/extra/httpd-mpm.conf
3. php.ini -> realpath_cache_size = 16000k

  1. try turning off Windows Firewall for localhost - I use Eset SS so win firewall is disabled. Disabling SS temporarily should resolve the issue if SS was the reason but it also changes nothing.

On another forum someone suggested that I use xamp - they say it runs smoothly and fast on win 7. I’ll experiment and post about the results - it may be of help to someone who runs into similar issues.


  1. try turning off Windows Firewall for localhost
  2. set httpd.conf -> Include conf/extra/httpd-mpm.conf
  3. php.ini -> realpath_cache_size = 16000k

Go throurgh all your ini files and increase the memory and cache limits


Ouch, that’s annoying. I’m afraid this problem is new to me, so I can’t be of much help. Do post back if you find a better solution.

Yes, of course. I restarted Apache


Sorry, I’ve not switched to WinDoze 7 yet so I’ve no experience with this as yet - nor have I heard of this before. Maybe we can get others to comment?