An unknown FastCGI error has occured

Could anyone who has configured PHP with IIS7 tell me what could be the reason I keep following error? I have Windows 7 SP1 installed.

I tried doing Zip File Installation because it’s not clear to me how Windows Installer works based on the description mentioned here :

Windows Installer
The Windows Installer version can get a complete PHP environment up and running, but the installation of extensions can be confusing. By default, no extensions are installed, and this can adversely affect the usefulness of the PHP installation. Alternately, all of the extensions can be installed; this results in an unstable system because some of the extensions can conflict with others. It is generally easier to use the Zip file installation.

So I followed the Zip File Installation instructions from the above doc.

I am discussing some of the changes that are not very straightforward:

  1. The path of open_basedir I have mentioned is : open_basedir = “C:\inetpub\wwwroot”

Does this looks good?

  1. The document says extension_dir = “./ext” but the php.ini has this part already commented out for windows section. So, I uncommented it.

; Directory in which the loadable extensions (modules) reside.
; extension_dir = “./”
; On windows:
extension_dir = “ext”

But the instructions on the Microsoft docs says : extension_dir = “./ext”. I didin’t use “./” in my case. Do I need to? My php.ini file and ext folder are inside same directory.

  1. For this instruction "Enable the required PHP extension by un-commenting corresponding lines. More information follows in the section, ", I didn’t enable any extension as I am not sure which one I need to run PHP. The one enabled on the screenshot is for mysql and I don’t think that’s needed as I am just configuring IIS with PHP and not using MySQL here. Correct me if I am wrong.

After following all the steps, I don’t see this working : http://localhost/phpinfo.php . I restarted the IIS though.

Can you tell me what else I can do to troubleshoot this problem?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.