After "include" page is empty

Hi there,
first searched for similarities but found nothing.
I get an error/wrong output in my index.php after adding the line

require_once('/english.php');

I also tried without leading /, without () wíth include instead.
I looked up in w3school PHP, that’s where I got it from, in addition I searched several forums.
The page appears empty. If I remove the line,the page appears normal.
i can’t figure out what is wrong.
Any help, please?

Does english.php exist?

What does the error message say?

Hi to both:
english.php exist, and I get no message, only an empty page, as if php-error

Right. So step 1 is to enable viewing errors.

ini_set('display_errors','1');
error_reporting(-1);

And reload the page.
Is english.php in the same directory as your index.php?
Does english.php have errors in it?

Warning : require_once(/english.php): failed to open stream: No such file or directory in /var/www/html/index.php on line 12

Took away leading /, thought I tried that, but now errors in english.php
I think I can handle them.
Thank you very much for the debug-tip, so long ago, I forgot about that.
Both were right :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.