Address sent fails ...list_fid%3Fid%3D5 but this works ...list_fid&id=5 how do I get Apache to accept

Making dependent pull down menus in Yii2 PHP.
Onchange the correct data is sent but gets a 404 not found error.
But if I replace mysite/list_fid%3Fid%3D5 with mysite/list_fid&id=5 I get the desired output.
How do I get apache2 to accept the former?
Mint19/Ubuntu server
I’ve tried AllowEncodedSlashes On in the virtual host with no change and rewrite rules apparently don’t work either because I need reserved characters.
I’ve tried a variety of navigators as well to no avail,

Well for starters, you’re not sending the same string.

%3Fid%3D5 translates as ?id=5 , not &id=5

So what encoding does give & ? I could try that manually and see what happens

& is %26.

Hint: URL encoding is mostly just %<Hex Value>

Thanks but no gold. Still get the 404 error with %26

Is it possible to do a rewrite rule %26 to & and %3D to =?

Or get apache2 to accept them?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.