A warning message that I don't know how to fix

Hello, I am studying the " Build Your Own Database Driven Web Site Using PHP & MySQL, 4th Edition by Kevin Yank. I’ve started chapter 4 and attemtpting to use the mysqli functions. Since I started using this the warning message appears in the output for the assignments from the book and it appears that it is interrupting the entire program from completing. I’ve installed and setup PHP, MySQL, and Apache per the book. Does anyone know what is causing this mismatch and how to fix it?

Warning: mysqli_connect() [function.mysqli-connect]: Headers and client library minor version mismatch. Headers:50051 Library:50148 in E:\Program Files\Apache Software Foundation\Apache2.2\htdocs\addjoke\index.php on line 25

I have this problem too and I am and always have been using PHP 5.2.14
I suspect its just a minor problem and as I am nowhere near publishing to the web I shall ignore it for nor and address it later

As it is said in two forums:

http://forums.mysql.com/read.php?11,273265,273470
It is related to PHP version or so. So which version of PHP you are using now?