How to remove word String from var_dump?

I just tried disabling xdebug locally, with it disabled the paths don’t show.


look for these lines in your php.ini file:


zend_extension ="c:/wamp/bin/php/php7.0.10/zend_ext/php_xdebug-2.4.1-7.0-vc14-x86_64.dll"

xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = Off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir ="c:/wamp/tmp"

The extension line might read a little different. Place a ; at the start of each of them lines to comment them out, save and restart the server

1 Like

Whew! there sure are quite a few ini setting options.

Type: boolean, Default value: 2, Introduced in Xdebug > 2.1
By default Xdebug overloads var_dump() with its own improved version for displaying variables when the html_errors php.ini setting is set to 1 or 2. In case you do not want that, you can set this setting to 0, but check first if it’s not smarter to turn off html_errors.

You can also use 2 as value for this setting. Besides formatting the var_dump() output nicely, it will also add filename and line number to the output. The xdebug.file_link_format setting is also respected. (New in Xdebug 2.3)

Before Xdebug 2.4, the default value of this setting was 1.

1 Like

This is the xdebug line


If I comment out 1st line, then xdebug doesn’t work, the problem is coming from the first line, seems like, I have to go with as it is.

This forum is too servile towards whims that some users express.

This function should be used on purpose only, and for this purpose neither string nor a path do any harm. Any suggestion how to make use this function perverted way is a disservice.


As a noob, I have to clear everything about the basics, so far, I understood that path is only coming from xdebug, this is what I want to clear my doubts.

Thanks everyone for your support…:clap:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.