SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict
    Join Date
    Apr 2010
    0 Post(s)
    0 Thread(s)

    Help on #1045 - Access denied for user 'root'@'localhost'

    Hi I've installed and reinstall xampp few times now but I cannot get access to phpmyadmin I get the following error
    #1045 - Access denied for user 'root'@'localhost' (using password: YES)

    The only thing I've changed was the appache port to use port 82 I can run php but not admin
    #1045 - Access denied for user 'root'@'localhost' (using password: YES)

    I've never set up a password I am not sure if the previous person that was using this computer as set up username and password but is there a way to reset, delete add new password so I can gain access to phpmyadmin.

    I've checked config file and this what I've got

    PHP Code:
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = '';
    $cfg['Servers'][$i]['extension'] = 'mysql';
    $cfg['Servers'][$i]['AllowNoPassword'] = true
    I've tried some cmd command line but I can this

    user_mysql and i get this
    "Access denied for user 'ODBC'@'localhost' (using password: NO)".

    I've tried cmd
    mysql> user_mysql
    "Access denied for user 'root'@'localhost' (using password: NO)".

    help Please

  2. #2
    SitePoint Enthusiast
    Join Date
    Jul 2007
    San Sebastian, Spain
    1 Post(s)
    0 Thread(s)
    I created a screencast which explains the process of resetting the MySQL root password.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts