Anyone used XAMPP?

Hi,

I am trying to run php locally and need to open phpMyAdmin for the backend, but when i try opening it i get an error. I have attached an image of the error i get as it was easier for you to see this way.

Anyway, does anybody know how i can overcome this? I need to access phpMyAdmin you see :confused:

Please see image attached to see error.

Thanks

Can’t see the screenshot yet since it hasn’t been approved, but make sure you have both the PHP and MySQL service running.

Hey,

Screenshot has been approved.

Well i have both running, but as you can see the error says “#1045 Access denied for user…”

I googled this and tried multiple solutions but nothing has worked. I am not using a password either as i thought this may have been the problem, but can’t seem to get anywhere…

Any ideas why this is happening?

Thanks

I think you need to edit the config-inc.php file located in: xampp/phpmyadmin/config.inc.php it needs your password in there somewhere: http://www.apachefriends.org/en/faq-xampp-windows.html#password2

Try reconfiguring the MySQL Instance. Make sure you have cookies enabled in the phpMyAdmin config and that blowfish_secret has something in it.

You haven’t needed to configure it manually for quite some time.

Have you run the “setup_xampp.bat” file as indicated in the setup instructions?

I’ve never used xampp, but you can try wamp if you’re still having trouble. Its very easy to setup…

make sure you have initially run the setup. then make sure that the services like php and mysql are running on xampp’s control panel. hope this helps. :slight_smile:

Billy,
I noticed that your url is all lower case. On my version, it is phpMyAdmin. This may or may not make a difference.

I am trying to access my localhost buy I can’t access the local host. What to do now? I am using xamp.

You should probably start your own thread since your question is different from the original question.

You should try enter the default username and password xampp. The default username is localhost and no password need. If it’s not working, try to use the other PHP host like Apache but atleast you have installed PHP and MySql zip file.