<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'javascript');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var purchs2s = purchs2s||{};
      purchs2s.cmd = purchs2s.cmd || [];
      purchs2s.timeout=500;
      (function() {
        var ps2s = document.createElement('script');
        ps2s.async = true;
        ps2s.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        ps2s.src = (useSSL ? 'https:' : 'http:') + '//ads.servebom.com/purchs2s.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(ps2s, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//cdn-s2s.buysellads.net/pub/sitepoint.js" data-cfasync="false"></script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
    }]);
  </script>
    <!-- BuySellAds PRO Code -->
<script class="SP_stripMobile" type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
<!-- End BuySellAds PRO Ad Code —>
    
<!-- This site is optimized with the Yoast SEO plugin v5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>What Is Wix Code? &mdash; SitePoint</title>
<meta name="description" content="Wix Code turns Wix into an open platform for building robust, content-rich sites and web apps."/>
<link rel="canonical" href="https://www.sitepoint.com/what-is-wix-code/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What Is Wix Code? &mdash; SitePoint" />
<meta property="og:description" content="Wix Code turns Wix into an open platform for building robust, content-rich sites and web apps." />
<meta property="og:url" content="https://www.sitepoint.com/what-is-wix-code/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="joelf" />
<meta property="article:tag" content="sponsored2" />
<meta property="article:tag" content="wix" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2018-01-18T16:57:41-08:00" />
<meta property="fb:admins" content="121300382" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/01/1516161273fabian-grohs-437907.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/01/1516161273fabian-grohs-437907.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="946" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Wix Code turns Wix into an open platform for building robust, content-rich sites and web apps." />
<meta name="twitter:title" content="What Is Wix Code? &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/01/1516161273fabian-grohs-437907.jpg" />
<meta name="twitter:creator" content="@sitepointdotcom" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; What Is Wix Code? Comments Feed" href="https://www.sitepoint.com/what-is-wix-code/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.8.1' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.38ee1907f4c31444acf8.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.38ee1907f4c31444acf8.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=162880' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fwhat-is-wix-code%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fwhat-is-wix-code%2F&#038;format=xml" />
<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="64b8e500e3524000ecfa2000d01e2100033e83009398f000ab804c005e0e4300" async></script><!-- BEGIN wp-parsely Plugin Version 1.10.2 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.10.2' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/what-is-wix-code\/"},"headline":"What Is Wix Code?","url":"http:\/\/www.sitepoint.com\/what-is-wix-code\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2018\/01\/1516161273fabian-grohs-437907-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2018\/01\/1516161273fabian-grohs-437907-150x150.jpg"},"dateCreated":"2018-01-19T00:57:41Z","datePublished":"2018-01-19T00:57:41Z","dateModified":"2004-02-02T01:34:47Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"SitePoint Team"}],"creator":["SitePoint Team"],"publisher":{"@type":"Organization","name":"SitePoint"},"keywords":["joelf","sponsored2","wix"]}   </script>
    <!-- END wp-parsely Plugin Version 1.10.2 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "162880");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
    <header class="main-header u-isSingle" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-premium/l/join">
            <i class="SidebarNav_icon fa fa-user u-premium/l/join"></i>
            
            <a class="f-light" href="/premium/l/join?ref_source=sitepoint&ref_medium=drawer">Sign Up</a>
          </li>      <li class="SidebarNav_link u-premium/sign-in">
            <i class="SidebarNav_icon fa fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      
      <li class="SidebarNav_link u-premium/paths">
            <i class="SidebarNav_icon fa fa-map-marker u-premium/paths"></i>
            
            <a class="f-light" href="/premium/paths?ref_source=sitepoint&ref_medium=drawer">Learning Paths</a>
          </li>
            <li class="SidebarNav_link u-premium/deals/?ref_source=sitepoint&ref_medium=drawer">
            <i class="SidebarNav_icon fa fa-diamond u-premium/deals/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/deals/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer">Deals</a>
          </li>      <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer">Courses</a>
          </li>
    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript u-active">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/?ref_source=sitepoint&ref_medium=drawer" data-channel="woorank">SEO By WooRank</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-developer-center">
            <i class="SidebarNav_icon fa fa-circle u-developer-center"></i>
            <a class="f-light" href="https://www.sitepoint.com/developer-center/?ref_source=sitepoint&ref_medium=drawer" data-channel="developer-center">Microsoft Tech</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer">Community</a>
          </li>      <li class="SidebarNav_link u-versioning">
            
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/?ref_source=sitepoint&ref_medium=drawer">Versioning</a>
          </li>      <li class="SidebarNav_link u-newsletter">
            <i class="SidebarNav_icon fa fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer">Advertise</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
                        <sp-notification-dot
              notification_text="12"
              storage_key="DealsPage"
              url="/premium/deals/?ref_source=sitepoint&ref_medium=topnav"
              icon="diamond"
              link_text="Deals"
              nav_location="topNav"
              class="
                NavBar_item
                f-c-white
                f-light
                f-small
                l-ai-cen
                l-ai-str
                l-d-f--3col
                l-d-n
                l-ml3
                l-ml4--4col
                l-p-rel
                l-ph2
              ">
              <a class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                f-small
                f-light
                f-c-white
                NavBar_item"
                href="/premium/deals/?ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-medium fa fa-diamond"></i>
                Deals
              </a>
            </sp-notification-dot>
            <a
              class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                l-ml3
                l-ml4--4col
                l-pa2
                f-small
                f-light
                f-c-white
                NavBar_item"
              href="/premium/paths?ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-medium fa fa-map-marker"></i>
                Learning Paths
            </a>
                          <a
                class="
                  l-d-n
                  l-d-f--3col
                  l-ai-cen
                  l-ml3
                  l-ml4--4col
                  l-pa2
                  f-small
                  f-light
                  f-c-white
                  NavBar_item"
                href="/premium/topics/all?q=&limit=400&offset=0&page1&ref_source=sitepoint&ref_medium=topnav">
                  <i class="l-mr2 f-medium fa fa-book"></i>
                  Books & Courses
              </a>
            
            <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=topnav" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Sign Up</a></div>
          </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>

      <div class="widget maestro maestro-content-type-html " id="maestro-646"><sp-fixed-countdown-bar button_text="Get All Our Books and Courses for 50% Off" button_url="https://www.sitepoint.com/premium/l/join?ref_source=sitepoint&ref_medium=noticebar&ref_campaign=2-years-for-1" buttonclass="u-red u-white" end="2018-01-19 22:00:00 +1000" end_message="JOIN 35,339 OTHERS LEARNING WEB DEVELOPMENT WITH SITEPOINT PREMIUM" landingpageclass="v3 l-ph3"
ga_event_label="646" countdown_message="Offer Ends In"
></sp-fixed-countdown-bar><script>ga('SitePointPlugin:observeImpressions', 'maestro-646')</script></div>    </header>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-610"><!-- BuySellAds PRO Zone Code (Pushdown Cookie Ad) -->
<div id="bsap_2431" class="bsaPROrocks" data-serve="CVAI5K3N"></div>
<!-- End BuySellAds PRO Zone Code --><script>ga('SitePointPlugin:observeImpressions', 'maestro-610')</script></div><div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                <a href="https://www.sitepoint.com/javascript/" class="f-c-grey-200 f-bold l-pa2 l-d-if l-ai-cen">JavaScript</a>
              <span>-</span>
                <time class="l-d-ib l-pa2" datetime="2018-01-18" pubdate>January 18, 2018</time>
                        <span>-</span>
              <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/sitepointers/" class="f-c-grey-200">
            SitePoint Team        </a>
          </span>
            </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <h1 class="f-lh-title f-larger l-mb4 f-c-white f-xxlarge--2col">
            <span class="f-c-white l-mr3">What Is Wix Code?</span>
          </h1>
                <div class="l-w-1col--3col l-as-cen l-fs0 l-d-n l-d-b--2col l-ml3">
        <div class="f-c-white f-small f-bold l-w-100 l-mb3">Related Topics:</div>
        <div class="l-d-f l-fw-w">
        <a class="f-c-white" href="https://www.sitepoint.com/javascript/npm/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">npm</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/jquery/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">jQuery</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/angularjs/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">AngularJS</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/es6/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">ES6</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/nodejs-javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Node.js</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">More...</div></a>        </div>
      </div>
              </div>
      </div>
    </div>
    
      <div class="l-d-f l-jc-sb l-w-4col--4col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
        <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-659"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["joelf","sponsored2","wix"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-6_123456"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-659')</script></div>      </div>

        <div class="ArticleCopy language-javascript">
      <div class='l-mt3 l-mh5--2col'>
      <p><img src="https://www.wix.com/campaign-tracker/1.gif?utm_campaign=ma_sitepoint.com_wixcode&#038;experiment_id=marketing^article1^impression"/></p>
<p class="wp-special"><em>This article was sponsored by <a href="https://www.wix.com/?utm_campaign=ma_sitepoint.com_wixcode&#038;experiment_id=sitepoint.com^wix_link">Wix</a>. Thank you for supporting the partners who make SitePoint possible.</em></p>
<p>You probably already know that <a href="https://www.wix.com?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^wix_link">Wix</a> is a cloud-based web design platform that lets users create stunning HTML5 websites using its online drag and drop editor. </p>
<p><a href="https://www.wix.com/code/home?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">Wix Code</a> takes Wix to the next level, turning it into an open platform for building robust, content-rich sites and web apps. With Wix Code, Wix becomes a powerful and extensible tool for web developers. </p>
<p>Wix Code adds a bunch of new features and functionality to Wix:</p>
<ul>
<li>Databases</li>
<li>Dynamic pages</li>
<li>Repeating layouts</li>
<li>Custom forms</li>
<li>Built-in online IDE</li>
<li>Custom interactions using our APIs and JavaScript</li>
<li>Access to 3rd party APIs</li>
<li>Call backend code from the front-end with Web Modules</li>
<li>HTTP functions: Exposing your site’s functionality as a service with your own API</li>
</ul>
<p>And, don’t forget, this is still Wix, so everything is hassle-free:</p>
<ul>
<li><strong>It’s serverless</strong>: All this added functionality comes in a serverless environment that lets you get your work done without any of the normal full-stack development headaches. </li>
<li><strong>Just code and go:</strong> Wix Code has a built-in, online IDE and backend so you can just add the code you need to your page or your site, publish, and you’re live. </li>
</ul>
<p>All these new features mean that you can think about the kind of site you want to build on Wix in whole new ways. Let’s consider an example.</p>
<p>Do you want to build a full-fledged real estate site, where users can browse your offerings and search by location or other property features? You probably don’t want to build a separate page for each listing, right? You might also want to let your clients sign up for your newsletter.</p>
<p>How about if, on the same site, you want to give your agents access to special pages with admin permissions so they can add or update listings in a database? Maybe they also need to maintain a database of all their clients? </p>
<p>Maybe you need to connect your site to an existing database? What if you have a dedicated mobile app and you want your site to integrate with it? Of course you want any changes you or your agents make to go live in real-time.</p>
<p>Wix Code makes all this possible. Using a combination of Wix Code features, our APIs, and JavaScript that you add, you can make your Wix site behave exactly the way you need it to. You can even expose your site as a service or use your site exclusively as a backend for an external application.</p>
<p>And it’s all within the Wix ecosystem so it’s hosted, secure, and SEO-compatible, and you never have to worry about scalability.</p>
<p>With Wix Code you can use all the stunning templates and styling options from Wix and add extra functionality and code to make your site even more awesome. This way you can focus on the fun part of making your site work exactly the way you want.</p>
<h2 id="databases">Databases</h2>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/01/1516161128image_0-1024x288.png" alt="Database Collections" width="1024" height="288" class="aligncenter size-large wp-image-162883" /></p>
<p>Imagine our real estate site. You probably want one database for your available properties, one for your agents, and another for your clients. But you’ll need to associate your agents with the properties they’re handling and also to associate potential clients with each property. </p>
<p>Now with Wix Code you can add a <a href="https://www.wix.com/code/home/database?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">database</a> with multiple collections to your site. The Wix Code database is automatically integrated into your Wix site so there’s no need to set anything up—we do all the magic for you. As soon as you create a collection, it’s available for you to use with the elements in your site, to either display or store data, all without writing a line of code. </p>
<p>You can also create complex data structures with reference fields so that one collection can refer to the records, or what we call <em>items</em>, in another collection. The Wix Code database also includes a permissions model that gives you control over which visitors are allowed to interact with your data and what they are allowed to do.</p>
<p>Once your collections are set up, you can use our <a href="https://www.wix.com/code/reference/wix-data.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">wix-data API</a> to manage your data. It lets you query your collection with a long list of functions to control your query results. It even has <a href="https://www.wix.com/code/reference/wix-data.Hooks.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">hook functions</a> so you can add custom code that runs before or after different actions on your data.</p>
<p>One of the most powerful things you can do with a collection is use its content in dynamic pages, so let’s talk about that next.</p>
<h2 id="dynamicpages">Dynamic Pages</h2>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/01/1516161159image_1.png" alt="Dynamic Pages" width="864" height="731" class="aligncenter size-full wp-image-162884" /></p>
<p>Back to real estate. As your users browse your site, you want them to be able to view a dedicated page for each property. Each listing should be displayed using the same layout with the same basic elements. You just need the content of those elements to change and for each page to have a unique URL. That’s what <a href="https://www.wix.com/code/home/dynamic-pages?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">dynamic pages</a> do.</p>
<p>When you create a dynamic page, you design one page layout that’s used each time your site calls that page. And each time it’s called, it displays the content of a different item in your collection with its own URL. </p>
<p>Now you no longer need to create a unique page when you have a lot of data that you want to display in the same way. Just create a dynamic page, connect it to your collection, and you automatically get a unique page with its own URL for each item in your collection. And whenever your collection’s data changes, your page contents change automatically.</p>
<h3 id="dynamicpagesandseo">Dynamic Pages and SEO</h3>
<p>The content in dynamic pages can change each time the page is displayed, and you’re going to want search engines and social networks to index that page for any of the content it could display. The SEO settings for dynamic pages let you control how your pages are indexed, and they let you reference the data in your collections for indexing.</p>
<p>You can control the page’s title, description, keywords, and social images using the data from your collection that’s associated with your page. You can also hide the page from search results if you want. </p>
<h2 id="repeatinglayouts">Repeating Layouts</h2>
<div style='position:relative;padding-bottom:54%'><iframe src='https://gfycat.com/ifr/LimpingCloseLangur' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0' allowfullscreen></iframe></div>
<p></p>
<p>Forcing your users to browse your listings one page at a time isn’t the best user experience. You really want to show a snapshot summary of all your listings on one page that serves as an index. Each snapshot would have the same elements and layout, just with different content. Then your user could click on one to get to that listing’s unique dynamic page. <a href="https://www.wix.com/code/home/repeaters?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">Repeating layouts</a> make this easy.</p>
<p>A repeating layout, or repeater, is an element that displays multiple items using the same layout. You create the layout you like, and then each repeater item uses that same layout to display different content.</p>
<p>Repeater items function like containers and are easy to design. You attach other elements to them, and then any change you make to one repeater item is automatically reflected in all the others. </p>
<p>You can use repeaters to display static content or you can connect the elements in a repeater to your data in a collection. This dynamically displays your content, with the repeater creating one repeated item for each item in your collection.</p>
<p>Once you’ve got your repeater set up you can customize your user experience with some code. Maybe you want to give your user the ability to filter what the repeater displays? Or maybe the repeater should display the results of a search on your data?</p>
<p>You can also use code to control the repeater’s behavior and appearance, based on user activity. Remember, the Wix elements are just your starting point—adding code with our APIs is where your creativity can really come through.</p>
<h2 id="customforms">Custom Forms</h2>
<p>Now you want your customers to sign up for your newsletter. Or maybe you want to create an internal form that makes it easier for your agents to add or modify listings. Your <a href="https://www.wix.com/code/home/user-input?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">custom forms</a> need to have the basic input elements, but you also want to let users upload files or images. You also need different information to go into different collections.</p>
<p>Wix Code adds user input elements to the Wix Editor. These elements let you capture information that your users enter and store it in a collection. You can then use that data in your site.</p>
<p>The new input elements include text inputs, radio buttons, dropdown lists, checkboxes, date pickers, a file upload button, and more.</p>
<p>By using these elements you can create any form you want. You can also display existing data so users can modify content they’ve already submitted. </p>
<p>You can also add code to your form. This lets you customize your form to exactly meet your needs. You can create cascading dropdowns, add custom validation, build a multi-stage form, and collapse and expand form sections based on user input.</p>
<h2 id="builtinide">Built-in IDE</h2>
<div style='position:relative;padding-bottom:54%'><iframe src='https://gfycat.com/ifr/QualifiedVariableDegu' frameborder='0' scrolling='no' width='100%' height='100%' style='position:absolute;top:0;left:0' allowfullscreen></iframe></div>
<p></p>
<p>Wix Code includes a <a href="https://support.wix.com/en/article/working-in-the-code-panel?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">built-in online IDE</a> that makes it easy to add code to your site with zero setup. This IDE works for your front-end files and lets you add page-specific code or code that you want to run on your entire site. You can also use the IDE to add code to backend files like data hooks, custom routers, web modules, and HTTP functions. </p>
<p>The IDE makes coding easy because all your code is automatically integrated with your site. The IDE also includes professional tools to make coding easier. These include code completion, so if you type $ (part of our element identifier syntax) and then press Ctrl + space, a pop-up window opens that lists all the elements on your page. Once you’ve got an element selected, you can use Ctrl + space again to get a list of all the properties and functions associated with that element. Along the way, the IDE also provides JSLint feedback to help you code using best practices. </p>
<p>To make debugging easier, any messages you log to your console in the front-end are displayed when you preview your site in the Developer Console in Wix’s Preview mode. Logs in backend code can be seen in your browser’s developer tools console.</p>
<h2 id="custominteractions">Custom Interactions</h2>
<p><img src="https://www.wix.com/campaign-tracker/1.gif?utm_campaign=ma_sitepoint.com_wixcode&#038;experiment_id=marketing^article1^scroll"/></p>
<p>With all of these new capabilities, there still may be some things you want your site to do that we haven’t provided out-of-the-box. Now it’s time to really dive into the code part of Wix Code.</p>
<p>Wix Code exposes <a href="https://www.wix.com/code/reference/&amp;rel=nofollow?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">APIs</a> that give you control over every aspect of your Wix site. Use <a href="https://www.wix.com/code/reference/$w.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">$w</a> to add <a href="https://www.wix.com/code/home/interactions?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">custom interactions</a> to your site’s elements, <a href="https://www.wix.com/code/reference/wix-dataset.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">wix-dataset</a> to control the content your pages display, <a href="https://www.wix.com/code/reference/wix-users.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">wix-users</a> to identify your current user and their type, and a bunch of other APIs.</p>
<p>All of this means that you have total control over the user experience for your site. All you need to do is add a little JavaScript and you can increase your user engagement in new and exciting ways. </p>
<h2 id="accessthirdpartyapis">Access Third-Party APIs</h2>
<p>We mentioned connecting your site to an existing external database. If that database has its own API, you can use code to get it done.</p>
<p>Wix Code lets you <a href="https://support.wix.com/en/article/accessing-3rd-party-services?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">access 3rd party web services</a>. You can use our <a href="https://www.wix.com/code/reference/wix-fetch.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">wix-fetch</a> module to call a service, or you can use the Node.js http, https, and net modules.</p>
<p>You can call 3rd party services in the front-end, or if you need to be secure, just add it to your backend code. Then you can use our web modules to call your backend code from the front-end.</p>
<h2 id="webmodules">Web Modules</h2>
<p>Accessing an external service using its API probably means using your own private API key in the request. That’s not something you want to put in your front-end code, though you may want to trigger that call from the front-end.</p>
<p>You might also have other code that you need to run server-side due to security concerns, or because it calls other web services. <a href="https://support.wix.com/en/article/calling-server-side-code-from-the-front-end-with-web-modules?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">Wix web modules</a> make your front-end and backend communication easier.</p>
<p>Web modules enable you to write functions that run server-side in the backend, which you can then easily call in your front-end code. Wix Code handles all the client-server communication required to enable this access.</p>
<p>You’re wondering, can I debug these functions? Yup. Even though your code is running server-side, you can still log messages to the console in web module code. These logs are displayed in the browser’s console.</p>
<p>Do you worry that maybe your site design has a security flaw and someone could still get into your backend code? Web modules also have permission settings, so you can be extra sure that no one can access or use your backend code in ways that you didn&#8217;t intend, either through your site&#8217;s functionality or using a browser&#8217;s developer tools. </p>
<p>In case you’re curious, here’s what’s going on behind the scenes. When you import a web module on the client-side, you get a proxy function to the web module function. This proxy function uses an XMLHttpRequest to invoke the function in the backend. The runtime listens to those invocations and calls the appropriate function. The arguments and return value are serialized using JSON.</p>
<h2 id="httpfunctions">HTTP Functions</h2>
<p>Your real estate agents aren’t walking around all day with their laptops. They’re working from their smartphones, and you’ve already got a dedicated mobile app that lets them manage their caseload.</p>
<p>How do you give that app access to your site’s functionality? What about sharing your backend? Integrating your site with automation tools? To do that, you’ll need to expose your site’s functionality as a service. You do this using <a href="https://www.wix.com/code/reference/wix-http-functions.html?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">Wix HTTP functions</a>.</p>
<p>With HTTP functions you define an API for your site that other people or services can use to access your site’s functionality. You can create get, post, put, delete, and use functions, which are the requests that your site can receive from an outside resource. </p>
<p>You then add the code to your functions to customize what they do, and use the <a href="https://www.wix.com/code/reference/wix-http-functions.html#?utm_campaign=ma_sitepoint.com_wixcode&amp;experiment_id=sitepoint.com^article1^inlink">wix-http-functions API</a> to customize what they return as a response.</p>
<h2 id="wrapup">Wrap-up</h2>
<p>By now you can see why we’re so excited about Wix Code. Wix Code is the first serverless platform that is specifically tailored for websites and web apps. It allows you to create robust, SEO-friendly, content-rich sites in an open platform that you can code and extend. And because it’s Wix, it’s hassle-free, hosted, and secure so you can focus on what you love.</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/sitepointers/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1507698696SitePoint@2x-96x96.png" width="96" height="96" alt="SitePoint Team" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/sitepointers/">
                SitePoint Team              </a>
                          </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3"></div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
            <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <div class="l-as-fs l-mv0 l-pv1 l-ph3 f-light f-larger f-uppercase f-c-white t-bg-grey-500">Sponsors</div>
    <div class="l-w-100 l-mv3 t-bg-white m-border"></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-662"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["joelf","sponsored2","wix"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-3_123456" style="height:250px; width:300px;"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-662')</script></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-661"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["joelf","sponsored2","wix"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-4_123456"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-661')</script></div>        <ads-weighted widget='21' data='{"NL":[{"id":"585","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":50},{"id":"584","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":100}]}' fallback='' url='what-is-wix-code' channelSlug='javascript'></ads-weighted></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
          </div>

      <div class="u-accordion-end"></div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span><script>ga('SitePointPlugin:observeImpressions', 'maestro-649')</script></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                <div id="sp_comments_signin">
      <div class="f-larger f-bold l-mb3">Login or Create Account to Comment</div>
      <a href="/premium/sign-in?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fwhat-is-wix-code%2F%23commentsSection" class="Button u-grey u-outline">Login</a>
      <a href="/premium/sign-up?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fwhat-is-wix-code%2F%23commentsSection" class="Button l-ml3">Create Account</a>
    </div>
        <div data-spotim-module="recirculation" data-spot-id="sp_hAStREiw"></div>
    <script src="https://recirculation.spot.im/spot/sp_hAStREiw"></script>
    <script async
      src="https://launcher.spot.im/spot/sp_hAStREiw"
      data-spotim-module="spotim-launcher"
      data-spot-id="sp_hAStREiw"
      data-post-id="162880"
      data-disqus-url="https://www.sitepoint.com/what-is-wix-code/"
      data-disqus-identifier="162880 https://www.sitepoint.com/?p=162880"></script>
    <script>
      if (window.SPOTIM && window.SPOTIM.startSSO) {
        startSSO();
      } else {
        document.addEventListener("spot-im-api-ready", startSSO, false);
      }

      function startSSO() {
        var callback = function(codeA, completeSSOCallback) {
          $.ajax({
            method: "GET",
            url: "/premium/api/v1/users/spot_im_sso/" + codeA,
            success : function(response){
              completeSSOCallback(response.code_b);
            }
        });
        };

        window.SPOTIM.startSSO(callback).then(function(result) {
          var button = document.getElementById("sp_comments_signin");
          button && button.remove();
        })
        .catch(function(reason){
          console.log(reason)
        });
      }
    </script>
                <a id="comments"></a>
                      </div>
        </div>
      </div>

    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          javascript: 'javascript',
        });
      });
    </script>
      </div>
    </div>
    <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-555"><script type="text/html" class=" ModalOnce" data-activate-delay=30 data-tracking="channelspecific" data-min-height="650" data-min-width="900" data-tracking-days="14">

<div id="channelspecific-modal" class="reveal-modal" data-reveal aria-labelledby="10 free SitePoint ebooks" aria-hidden="true" role="dialog">

<purchase-form
product="Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvOTQ" 
title="10 free SitePoint ebooks"
 subtitle="Downloaded by more than 100,000 developers!" 
cta="Get Your Free Ebooks Now!" 
subtext="No credit card required. Completely free."
ga_event_label="maestro-555"
>

</purchase-form>
<a  data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-555" data-ga-event-action="close" class="close-reveal-modal" aria-label="Close">&#215;</a>
</script>
<style>
#channelspecific-modal {
  width: 60%;
  margin-left: -30%;
}
.reveal-modal-bg {
  background: rgba(0,0,0,.65);
}
</style><script>ga('SitePointPlugin:observeImpressions', 'maestro-555')</script></div>    <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/themes/">Themes</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/#privacy">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fa fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fa fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fa fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2018 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
  <div class="l-w-100 l-d-f t-bg-white l-jc-cen">
    <div class="l-mv5 l-d-f l-fw-w l-jc-cen">
      <span class="f-bold l-as-cen f-large f-c-grey-300 l-mr3 l-mb3 l-mb0--2col">Recommended Hosting Partner:</span>
      <a href="https://www.siteground.com/go/sitepoint-siteground-promo">
        <img class="l-ml5--2col" src="//www.sitepoint.com/wp-content/themes/sitepoint/assets/images/siteground.png" />
      </a>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "https://www.sitepoint.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'sitepointproduction';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.setAttribute('data-cfasync', 'false'); e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-dfb2dddf3e07e06b11282e3f2248e361.js?ver=4.8.1'></script>
<script type="text/javascript" src="/dist/js/compiled.38ee1907f4c31444acf8.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
    <script>
    jQuery(document).ready(function() {
      jQuery('.lazyYT').each(function() {
        var id = jQuery(this).data('youtube-id'),
            url = 'https://www.youtube.com/watch?v=' + id;
        jQuery(this).replaceWith('<a href="' + url + '">' + url + '</a>');
      });
    });
    </script>
  
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 1129/1159 objects using memcached
Page Caching using memcached (SSL caching disabled)
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

 Served from: www.sitepoint.com @ 2018-01-19 00:08:28 by W3 Total Cache -->