<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.web.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.2.0/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    <meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KL8PMMW');</script>

    <script class="SP_stripMobile" type="text/javascript">
      var propertag = propertag || {};
      propertag.cmd = propertag.cmd || [];
      (function() {
      var pm = document.createElement('script');
      pm.async = true; pm.type = 'text/javascript';
      var is_ssl = 'https:' == document.location.protocol;
      pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/sitepoint.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(pm, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();

      var oSpP;
    </script>
    <script charset="UTF-8" src="//cdn.sendpulse.com/js/push/ee9a890c7a9d2a9236648c25e40bd03e_1.js" async></script>

        <script type="application/ld+json">
    // <![JSON-LD Schema data[
      {"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.sitepoint.com\/web\/","name":"Web"}},{"@type":"ListItem","position":2,"item":{"@id":"www.sitepoint.dev\/author\/gshachar","name":"Gal Shachar"}}]}      // ]]
        </script>

    
<!-- This site is optimized with the Yoast SEO plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>The Strategic Advantages of Headless Web Design &mdash; SitePoint</title>
<meta name="description" content="Gal Shachar explains what the headless CMS trend is all about, and how using this API-powered approach to design and deploy your company’s website can help you get ahead."/>
<link rel="canonical" href="https://www.sitepoint.com/headless-web-design-strategic-advantage/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Strategic Advantages of Headless Web Design &mdash; SitePoint" />
<meta property="og:description" content="Gal Shachar explains what the headless CMS trend is all about, and how using this API-powered approach to design and deploy your company’s website can help you get ahead." />
<meta property="og:url" content="https://www.sitepoint.com/headless-web-design-strategic-advantage/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="cms" />
<meta property="article:tag" content="decoupled cms" />
<meta property="article:tag" content="headless CMS" />
<meta property="article:section" content="Web" />
<meta property="article:published_time" content="2019-07-29T17:00:07+00:00" />
<meta property="article:modified_time" content="2019-07-29T02:14:28+00:00" />
<meta property="og:updated_time" content="2019-07-29T02:14:28+00:00" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564315347headless-cms-feature.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564315347headless-cms-feature.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="378" />
<meta property="og:image:alt" content="How Your Agency Can Use Headless Web Design as a Strategic Advantage" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Gal Shachar explains what the headless CMS trend is all about, and how using this API-powered approach to design and deploy your company’s website can help you get ahead." />
<meta name="twitter:title" content="The Strategic Advantages of Headless Web Design &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564315347headless-cms-feature.jpg" />
<meta name="twitter:creator" content="@sitepointdotcom" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; The Strategic Advantages of Headless Web Design Comments Feed" href="https://www.sitepoint.com/headless-web-design-strategic-advantage/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://www.sitepoint.com/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1563924940' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.sitepoint.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-151a38e87e68fbad6a7c4527ed1a5fba.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-dynamic-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/bundle-9ec8478d82343eb00f887dfc7dfc1ea3.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-article-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/article-35a91ee329370f5244ffecd2a6c2e8ca.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-302ae967a92241deb24be6e2a54eeefd.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=173132' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fheadless-web-design-strategic-advantage%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fheadless-web-design-strategic-advantage%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 2.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0"/>
			<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/headless-web-design-strategic-advantage\/"},"headline":"The Strategic Advantages of Headless Web Design","url":"http:\/\/www.sitepoint.com\/headless-web-design-strategic-advantage\/","thumbnailUrl":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2019\/07\/1564315347headless-cms-feature-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2019\/07\/1564315347headless-cms-feature-150x150.jpg"},"dateCreated":"2019-07-29T17:00:07Z","datePublished":"2019-07-29T17:00:07Z","dateModified":"2019-07-29T17:00:07Z","articleSection":"Web","author":[{"@type":"Person","name":"Gal Shachar"}],"creator":["Gal Shachar"],"keywords":["cms","decoupled cms","headless cms"],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":"http:\/\/www.sitepoint.com\/wp-content\/themes\/sitepoint\/assets\/images\/icon.sitepoint.png"}}}
		</script>

			<!-- END wp-parsely Plugin Version 2.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "web");
		googletag.pubads().setTargeting("post_id", "173132");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #1C94C6 }
  a.t-color:hover,
  button.t-color:hover { color: #1779A2 }

  .t-bg { background-color: #1C94C6 }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #1779A2}

  .t-border { border-color: #1C94C6 }
  a.t-border:hover,
  button.t-border:hover { border-color: #1779A2 }

  .t-bg-dark { background-color: #1779A2 }

  .t-list li:before { background-color: #1C94C6; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>

    <!-- Nativo Ads -->
    <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
     <!-- Tapfiliate code here-->
    <script src="https://script.tapfiliate.com/tapfiliate.js" type="text/javascript" async></script>
    <script type="text/javascript">
      (function(t,a,p){t.TapfiliateObject=a;t[a]=t[a]||function(){
      (t[a].q=t[a].q||[]).push(arguments)}})(window,'tap');

      tap('create', '10694-267423');
      tap('detect');
    </script>
  </head>
<body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
    <header class="main-header u-isSingle" role="banner">
    <nav id="navigation-bar" class="l-d-f l-p-fix l-w-100">
      <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto">
        <section class="l-d-f l-ai-str l-jc-sta l-gs-ph2 l-gs-ph1--2col">
          <a class="l-d-f" href="https://www.sitepoint.com/">
            <div class="l-d-f l-as-cen l-b-n">
              <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
            </div>
          </a>
        </section>
        <section id="hamburger-container" class="l-ai-cen l-d-f l-gs-ph1">
          <div class="hamburger">
            <div class="hamburger-box">
              <div class="hamburger-inner"></div>
            </div>
          </div>
        </section>

        <section id="nav-container" class="l-ai-cen">
          <ul id="nav" class="l-d-f l-w-100 l-ma0 l-fd-col">
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a id="nav-blog" href="/blog" data-text="Blog">Blog</a>
            </li>
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a href="/community" data-text="Community">Community</a>
            </li>
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a href="/premium/library/" data-text="Library">Library</a>
            </li>
                          <nav-bar-actions is_member="" slug="headless-web-design-strategic-advantage" categories="web"></nav-bar-actions>
                      </ul>
        </section>
      </div>
    </nav>

    <div class="NavBar_offsetSpacer"></div>
    <script>
              var current_category = ['web'];
        if (localStorage.getItem('SP_categories') !== null) {
          if (localStorage.getItem('SP_categories').includes(current_category) === false) {
            var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
            var temp = current_category.concat(sp_categories);
            var filtered_categories = Array.from(new Set(temp));
            localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
          }
        } else {
          localStorage.setItem('SP_categories', JSON.stringify('web'));
        }
        // campaign
        localStorage.setItem('SP_slug', 'headless-web-design-strategic-advantage');

      
      /* Toggle mobile navigation */
      var toggleMobileNav = function(event) {
        var target = event.target;
        if (target.className.includes("hamburger")) {
          document.getElementById("hamburger-container").classList.toggle("open");
        }
      }
      var isTouchSupported = 'ontouchstart' in window;
      var startEvent = isTouchSupported ? 'touchstart' : 'click';
      document.addEventListener(startEvent, toggleMobileNav);

      /* Set active navigation item  */
      var current_url = window.location.href;
      if (current_url.indexOf("/blog") > -1) {
        document.getElementById("nav-blog").classList.add("youarehere");
      }
    </script>
    <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-744"><script>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</script>
<style>
  .sp-smartbar {
    all: initial;
    -webkit-box-sizing: border-box;
            box-sizing: border-box;
    position: fixed;
    top: 0;
    width: 100%;
    font-size: 18px;
    font-family: "Roboto", "Helvetica Neue", "Helvetica", Helvetica, Arial, sans-serif;
  }
  .sp-smartbar__body {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    min-height: 0px;
    padding: .5em 1.5em;
    -webkit-box-align: center;
        -ms-flex-align: center;
            align-items: center;
    -webkit-box-pack: center;
        -ms-flex-pack: center;
            justify-content: center;
    -ms-flex-wrap: wrap;
        flex-wrap: wrap;
    background-color:#2c2c2c;
    color: #fff;
  }
  .sp-smartbar__body > * {
    margin: 0.25em 0.5em;
  }
  .sp-smartbar__close {
    all: initial;
    padding: .25em;
    display: -webkit-inline-box;
    display: -ms-inline-flexbox;
    display: inline-flex;
    cursor: pointer;
    position: absolute;
    top: 50%;
    right: 1em;
    -webkit-transform: translateY(-50%);
            transform: translateY(-50%);
    background: transparent;
    border: 0;
    color: #9b9b9b;
    font-size: 20px;
  }
  .sp-smartbar__close rect {
    fill: currentcolor;
    stroke: currentcolor;
  }
  .sp-smartbar__text {
    text-align: center;
    font-size: 26px;
    font-weight: 800;
    letter-spacing: .02em;
  }
  .sp-smartbar__countdown {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    font-size: 1.5em;
    font-weight: 800;
    color: #fd6767;
  }
  .sp-smartbar__button a {
    display: inline-block;
    text-decoration: none;
    color: #fff;
    background: #3ec9cb;
    padding: .5em 1.5em;
    border-radius: 3px;
    font-weight: 500;
  }
</style></div>  </header><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-776"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_billboard"> <script> propertag.cmd.push(function() { proper_display('sitepoint_billboard'); }); </script> </div>
</div></div>  <div class="l-p-rel t-bg-white sp-article" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
        <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-ph4--2col l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              >
              <a
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/web/">
                  web              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
            >
              July 29, 2019            </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/gshachar/">
                      Gal Shachar                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">The Strategic Advantages of Headless Web Design</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
            <div class="l-d-f l-jc-sb l-mt3 l-w-4col--4col l-mh-auto" data-hellobar="content">
      <div class="l-w-100 l-fg1 l-mh3--2col l-mh0--4col l-o-h">
                    <div class="l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-">
      <sp-social-share></sp-social-share>
      <div class='l-mt3 l-mh5--2col'>
        <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p><em>This article was created in partnership with <a href="https://www.duda.co/" rel="nofollow">Duda</a>. Thank you for supporting the partners who make SitePoint possible.</em></p>
<p><strong>Kentico&rsquo;s most recent <em>State of the Headless CMS</em> report <a href="https://kenticocloud.com/state-of-headless-cms-2018" rel="nofollow" style="font-weight:bold;">claims that</a> the concept of the headless content management system is &ldquo;becoming the industry standard for future-proofing and streamlining content creation.&rdquo; In fact, the report estimates that by this summer, headless CMS use will have doubled.</strong></p>
<p>But what does that even mean?</p>
<p>If you&rsquo;re currently using a traditional CMS such as WordPress, Drupal or Joomla for your web development needs, chances are you may have never heard of a headless CMS. But what you might know is that you want to <a href="https://www.sitepoint.com/the-best-7-tools-for-building-websites-and-pages/" rel="nofollow">build a one-of-a-kind website</a> for your growing agency that can scale with ease, and that marketing your brand across multiple channels is a must if you want to beat the competition.</p>
<p>In this article, we&rsquo;re going to share with you what the headless CMS trend is all about and how using this API-powered approach to design and deploy your company&rsquo;s website can help you get ahead, no matter how competitive your industry is.</p>
<p>So, let&rsquo;s get started.</p>
<h2 id="whatisaheadlesscms">What Is a Headless CMS?</h2>
<p>To better understand what a headless CMS is, let&rsquo;s compare a traditional CMS (or &ldquo;monolithic&rdquo;, as <a href="https://medium.com/@bretcameron/building-my-first-headless-cms-what-i-wish-i-knew-at-the-start-1f3ef3a00bb8" rel="nofollow">developer Bret Cameron likes to call it</a>), a decoupled CMS, and a headless CMS.</p>
<div style="margin-bottom: 1.5em;">
<img style="margin-bottom: 0.5em;" src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564316399cms-types.jpg" alt="" width="1000" height="569" class="alignnone size-full wp-image-173140"><span style="display:block; font-size:0.8em; text-align:center; margin: 0;"><a href="https://medium.com/@bretcameron/building-my-first-headless-cms-what-i-wish-i-knew-at-the-start-1f3ef3a00bb8" rel="nofollow">Image source</a></span>
</div>
<h3 id="traditionalcms">Traditional CMS</h3>
<p>Traditional CMS platforms like WordPress link the front end of your website, called the <strong>head</strong>, to the back end of your site, where all your content files and databases are stored. The head of the CMS is strictly responsible for presenting your website to site visitors when they click on your site. The back end, on the other hand, not only stores content, but is where website design and customization applications are stored, where content is created, and where management of site functionality occurs.</p>
<p>Paired together, as they traditionally are, the back-end portion of the website relies on the head of the CMS to display the stored content on devices to users.</p>
<h3 id="decoupledcms">Decoupled CMS</h3>
<p>With a decoupled CMS architecture, the head portion and the back end of the site are split into two separate systems. One system is responsible for content creation and storage, and the other is responsible for presenting the data to users on an interface, such as a website, mobile app, smartwatch, etc.</p>
<p>When content is created on your website using a headless CMS, a RESTful API helps connect the back end to the head, so that the content can be delivered to users on any device or channel with ease.</p>
<p>A RESTful API is a type of application interface using HTTP requests to GET, POST, PUT, and DELETE data that&rsquo;s requested by users. It allows for multiple data formats such as JSON, HTML, XML, and plain text. It&rsquo;s ultimately what links the client and server in a decoupled CMS, allowing your site to infinitely scale and deliver content to anyone on any device.</p>
<h3 id="headlesscms">Headless CMS</h3>
<p>A truly <a href="https://www.sitepoint.com/build-web-apps-with-a-headless-cms/" rel="nofollow">headless CMS</a> eliminates the head portion altogether, leaving just the back end. In other words, there&rsquo;s no dedicated system for front-end presentation. And while you might initially wonder if this type of structure might be to your disadvantage, it&rsquo;s actually the best way to display content to your site visitors on all devices and interfaces, putting your agency in the best possible position to scale.</p>
<p>Here&rsquo;s a simple breakdown of how it works:<div class="proper-ad-unit">
          <div id="proper-ad-sitepoint_content_1">
            <script>
              window.propertag.cmd.push(function() {
                proper_display('sitepoint_content_1');
              });
            </script></div>
        </div></p>
<ul><li>Website owners create content (<em>often in small blocks</em>) in the headless CMS, with no regard for how it will display to users. They also store and manage this content here.</li>
<li>An API connects the back end to many different channels and the various engines that power their front ends.</li>
<li>The channel or device displays your site&rsquo;s content.</li>
</ul><p>The way your content will display on the different channels and devices will depend on the frameworks and tools your front-end developers use to act as the &ldquo;head&rdquo; portion of your headless CMS.</p>
<p>So it&rsquo;s more freedom to integrate with more front ends, more scalably and without the risk of breaking anything. How, exactly? Let&rsquo;s dive a little deeper.</p>
<h2 id="theadvantagesofaheadlesscms">The Advantages of a Headless CMS</h2>
<p>APIs work with a headless CMS to do the following:</p>
<ul><li><strong>Reduce Strain</strong>. Using a headless CMS, which stores content in a cloud repository as opposed to a server, will leverage less bandwidth, save resources, and reduce the strain your clients&rsquo; websites experience.&#8232;</li>
<li><strong>Manage and Store Content&#8232;</strong>.&#8232;With a headless CMS, all content, including written text and images, are stored in the back end of the database. With a traditional CMS, not only is content stored and managed here, but so are front-end templates, CSS, and plugins for front-end functionality. Separating the back end from the front end means you can upgrade and customize your website without compromising site speed or performance &mdash; since all your client needs to worry about is managing and storing content.</li>
<li><strong>Third-party Integrations</strong>.&#8232;&#8232;A headless CMS gives you the chance to use third-party systems to trigger, write and read content for you, making development less disruptive. It also gives developers the flexibility to use the front-end framework they prefer to display their site content, focusing more on content creation and less on content management.</li>
</ul><p>Lastly, a headless CMS protects you, your company and your website&rsquo;s content from future technological advances. After all, platforms and technology are always evolving, making it challenging to keep up.</p>
<p>For example, think about all the problems that those of us who didn&rsquo;t build responsive websites had when mobile-friendliness became a necessity. People all over, regardless of how well-established and successful they were at the time, had to change everything to ensure a seamless mobile experience.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564316525alexa.jpg" alt="" width="1000" height="655" class="alignnone size-full wp-image-173141"></p>
<p>And there&rsquo;s no end in sight to the trends &mdash; from artificial intelligence to augmented reality to voice assistants &mdash; that have the power to change the way you build and deliver digital content experiences. Traditional CMS platforms were designed with website publishing in mind. They were not built with social media product listings, smartwatch apps or talking speakers in mind.</p>
<div class="widget maestro maestro-content-type-html " id="maestro-787"><div class="l-mv3" id="nativo">

</div></div><p>So when the build is decoupled from the delivery, you&rsquo;re in the best possible position to experiment with new channels and formats on an agile basis. And this is a key aspect to any agency&rsquo;s value proposition.</p>
<p>If you take advantage of the headless CMS approach and use APIs to deliver your content to where it needs to surface, it won&rsquo;t matter what changes. That&rsquo;s because as long as an API-fed front end can be built, your client&rsquo;s content can be configured to render properly.</p>
<h2 id="headlesscmslimitations">Headless CMS Limitations</h2>
<p>Though it might seem as though a headless CMS is the answer to all your website problems, be aware that there are some downsides preventing traditional CMS users from making the switch:</p>
<ul><li><strong>Limited Editing UI</strong>.&#8232;&#8232;When compared to traditional CMSs, headless CMSs usually lack the flexibility that content managers generally rely on to optimize the content for specific front end uses. If you need to use your CMS for creating landing pages or even article page layouts, the lack of a &ldquo;Preview&rdquo; button might be an issue. There is no WYSIWYG page editor on these platforms, since the whole point of going headless is that it won&rsquo;t render HTML, which makes designing medium-specific content experiences more difficult.&#8232;</li>
<li><strong>Lack of Built-in Features</strong>&#8232;.&#8232; Boris Kraft, CTO and co-founder of Magnolia CMS, <a href="https://www.cmswire.com/web-cms/a-headless-cms-wont-solve-all-your-woes/" rel="nofollow">reminds people</a> that a traditional CMS will generally come with features like &ldquo;asset management, navigation, security, workflow, access control, caching, categorization and link management.&rdquo; In fact, he goes on to say that while a headless CMS does provide companies with more flexibility, many often get lost in the hype and forget that &ldquo;I have to write, debug and maintain everything I need myself&rdquo; with a headless CMS solution.</li>
</ul><p>While there is no CMS solution that satisfies <em>all needs</em>, it&rsquo;s worth noting that the headless CMS approach can be beneficial when used in a hybrid situation.</p>
<p>In fact, if you use a solution such as <a href="https://www.duda.co/" rel="nofollow">Duda</a>, a leading web design platform for companies providing web design services to others, and take advantage of APIs to deliver content and handle your site&rsquo;s structure and layouts on multiple channels, you can get the best of both worlds.</p>
<h2 id="usingdudaforapipoweredsitebuilds">Using Duda for API-powered Site Builds</h2>
<p>Nowadays, Duda is known as a powerful drag and drop website builder, complete with team collaboration and client management tools, enabling agency designers and developers to build feature-rich, responsive websites that scale for their clients.<div class="proper-ad-unit">
          <div id="proper-ad-sitepoint_content_2">
            <script>
              window.propertag.cmd.push(function() {
                proper_display('sitepoint_content_2');
              });
            </script></div>
        </div></p>
<p>It was built to load with lighting fast speed (meeting Google PageSpeed best practices), is SEO-friendly out of the box, and comes with secure cloud hosting using the reputable infrastructure of Amazon Web Services.</p>
<p>But more than that, Duda gives agency pros customizable, responsive, pre-designed templates for faster website development, the ability to deliver dynamic content on all device types instantly using a global CDN, and help with white-labeling, sales materials, and landing page creation, all of which are crucial to building a successful agency.</p>
<p>That said, the feature to focus on when it comes to an API-powered site build is Duda&rsquo;s Content Library.</p>
<p>Duda&rsquo;s Content Library is a central hub for storing all your client&rsquo;s information: name, email, address, phone number, company hours, images, text blocks, and more. You can manually input client information or import it using the exclusive Duda Content Importer tool, which makes pulling client information from existing websites a cinch.</p>
<p>But more than that, the Content Library lets you map and connect to site elements such as widgets footers, meta titles and even articles, so that any changes made within the Content Library automatically update globally and dynamically on your clients&rsquo; sites. This relieves the burden of having to manually edit all elements site when a change needs to be made.</p>
<p><iframe src="https://player.vimeo.com/video/294897421" width="640" height="360" frameborder="0" allow="autoplay; fullscreen" allowfullscreen></iframe></p>
<p style="text-align:center; font-size:.8em;"><a href="https://vimeo.com/294897421">Advanced Content Library</a> from <a href="https://vimeo.com/dudamobile" rel="nofollow">Duda</a> on <a href="https://vimeo.com" rel="nofollow">Vimeo</a>.</p>
<p>With the Content Library, you can also connect to external structured data sets such as CRMs or databases using Duda&rsquo;s API, and take advantage of the same push functionality.</p>
<p>For instance, if you use a CRM such as Salesforce to store all your clients&rsquo; business information &mdash; company name, store hours, contact info and more &mdash; then manually updating the CRM and all of the the client&rsquo;s web pages is going to be very time-consuming. With Duda&rsquo;s Content Library, you can easily connect to your CRM so you only have to make the client update once. When the Content Library notices a change in client information, it will automatically push those changes to any content blocks or widgets on your client&rsquo;s site so you don&rsquo;t have to.</p>
<p>Another game-changing use case is when your client participates in a website redesign. Since the Content Library stores not only written information about your clients, but imagery as well, then if you need to change a logo sitewide on a website, there&rsquo;s nothing more to it than making the change in your Content Library, whether it&rsquo;s connected to an external data set through an API or not.</p>
<p>All you have to do is update the client&rsquo;s logo once, and it will be updated everywhere on their site instantly.</p>
<h2 id="growingyouragencysbusinesswithconnecteddata">Growing Your Agency&rsquo;s Business With Connected Data</h2>
<p>This process of separating content and design is similar to what a headless CMS does for website owners. The act of adding, editing, or removing content data relies not on the CMS (or in this case, the Duda development platform) but the API calls made.</p>
<div style="margin-bottom: 1.5em;">
<img style="margin-bottom: 0.5em;" src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564316598duda.jpg" alt="" width="1000" height="450" class="alignnone size-full wp-image-173142"><span style="display:block; font-size:0.8em; text-align:center; margin: 0;"><a href="https://connected-data.duda.co/" rel="nofollow">Image source</a><br></span>
</div>
<p>Not sure all of this mapping, connecting and syncing is necessary? Check out some of the most compelling use cases of these tech capabilities for driving agency growth:</p>
<ul><li><strong>Instant Websites at Scale&#8232;&#8232;</strong>. Design agencies know all about the time investment requirements for building websites from the ground up for each client. Using the Content Library, and the connected data you input about your client, makes creating instant sites a reality. Choose a few Duda templates or create your own, select site elements and widgets to include, and push your client&rsquo;s data to the website in minutes. Of course, you can make other design changes once this is done &mdash; even to the CSS and Javascript &mdash; but creating a starting point from API-powered content pushes can save you a lot of time.&#8232;</li>
<li><strong>Pitch Mockups of Unpublished Websites&#8232;&#8232;</strong>. If your organization offers a DIY site design option for clients, you know there are times when people fail to push their sites live. Part of this is because building a site on your own is tough. And despite the appeal of DIY among clients, finishing the project can involve a lot of friction. Instead of offering templates with placeholder content that your clients will need to fill in on their own, consider the power of presenting them with mockups of sites pre-populated with their content and business details. If your organization has access to a large trove of data relating to scores of businesses, then you can even send people cold emails with links to pre-designed sites that they can &ldquo;claim&rdquo; for a modest fee and publish on their own.&#8232;</li>
<li><strong>Easy Redesign Upsells</strong>.&#8232;&#8232;The ease with which the Content Library updates information site-wide gives you the ability to offer website redesigns to older clients. If your client has an outdated site and wants something fresh and new, save time and money (while generating revenue) by using the Content Library and its syncing ability to generate instant mockups of your client&rsquo;s websites rebooted. You can send them links to these prototypes and tell them that you&rsquo;ll gladly make any necessary tweaks and bring the whole thing live within hours. And the entire customer re-engagement initiative can happen on a fully automated basis.</li>
</ul><h2 id="pushthatcontent">Push That Content</h2>
<p>As you can see, creating, maintaining, updating, and editing a website using an API-based approach can make site builds and updates much easier than relying fully on a traditional CMS like WordPress.</p>
<p>And while the creativity to build a website using a live preview page editor is missing in a truly headless CMS, using a solution such as Duda that combines a WYSIWYG editor with rich APIs puts agencies in great position to scale up rapidly on both sales and project turnaround.</p></body></html>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/gshachar/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/07/1564316935gal-shachar-150x150.jpg" width="96" height="96" alt="Gal Shachar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/gshachar/">
                Gal Shachar              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/gal-shachar/"><i class="fab fa-linkedin-in"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Gal Shachar is a designer based in Tel Aviv who specializes in digital UX, ad media and branding. He has been active in the industry since 2017, following his studies at Ruppin College. Since then, Gal has been working with many well-known brands and businesses on web design, logo creation, user experience and branding campaigns. You can visit his website <a href="https://www.creativo-studio.com/">here</a>.</div>
      </div>
            </div>
    </div>
        </div>
          </div>
              <div class="article-ads">
              <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <sp-heading content="Sponsors"></sp-heading>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-765"><div class="proper-ad-unit">
  <div id="proper-ad-sitepoint_sponsor_1">
    <script>
        propertag.cmd.push(function() { 
          proper_display('sitepoint_sponsor_1');
        }); 
    </script>
  </div>
</div></div></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-763"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_side_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_1'); }); </script> 

</div>
</div></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html " id="maestro-728"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_side_2"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_2'); }); </script> </div>
</div></div><div class="widget maestro maestro-content-type-html " id="maestro-785"><div class="proper-ad-unit Sticky">

    <div id="proper-ad-sitepoint_side_3"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_3'); }); </script> </div>

</div></div></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
            </div>
          </div>

    <div class="u-accordion-end"></div>

    <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
      <div class="u-showseriesx l-w-100 l-fg1 l-mh3--2col l-mh0--4col">

        <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span></div>
                <div id="commentsSection" class="l-pa3 t-bg-white">
              <div id="comments" class="discourse-comments-area">
      <div class="respond comment-respond">
        <div class="my-wrapper l-d-f l-jc-cen l-gs-mb3">
          <a href="https://www.sitepoint.com/community/t/the-strategic-advantages-of-headless-web-design/334416" class="Button u-outline u-blue">Start a discussion</a>
        </div>
      </div>
    </div>
          </div>
      </div>
    </div>

    
    <script>
      var data = 'web';
      if (localStorage && localStorage.SP_categories) {
        data = JSON.parse(localStorage.SP_categories).toString();
        data = data ? data.replace('-', '') : 'web'
      }

      oSpP && oSpP.push('channel', data);
    </script>
    </div>

    <script>
    window.dataLayer = window.dataLayer || []
    window.dataLayer.push({
      post_id: 173132,
      title: "The Strategic Advantages of Headless Web Design",
      category: "Web",
      tags: ["cms","decoupled cms","headless CMS"],
      authors: ["Gal Shachar"],
      permalink: "https:\/\/www.sitepoint.com\/headless-web-design-strategic-advantage\/",
      published: "20190729",
      sponsored: false    })
  </script>

    <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite classic"  data-alm-id="" data-canonical-url="https://www.sitepoint.com/headless-web-design-strategic-advantage/" data-slug="headless-web-design-strategic-advantage" data-post-id="173132"  data-localized="ajax_load_more_vars"><div aria-live="polite" class="alm-listing alm-ajax" data-container-type="div" data-repeater="default" data-post-type="post" data-category="web" data-post-not-in="173132" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-2000" data-max-pages="0" data-pause-override="true" data-pause="true" data-button-label="Older Posts" data-transition="fade" data-transition-container-classes=" next-article l-o-h" data-images-loaded="true"></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div>  </div>
    <div class="widget maestro maestro-content-type-html " id="maestro-777"><script type="text/html" class="ModalOnce" data-activate-delay="15" data-tracking="free-book" data-min-height="1" data-min-width="1">
  <div id="free-book-modal" class="reveal-modal medium l-b-n l-br" data-reveal aria-labelledby="Free Book" aria-hidden="true" role="dialog">
    <free-book-content book_cover="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/04/1556241655bootstraptools.png" heading="Free Book. All Yours." book_title="Bootstrap: Related Tools & Skills">
      <p class="f-small l-mb3">Since its launch in 2011, a rich and diverse ecosystem has grown up around the core Bootstrap framework. In this book, we'll look at Bootstrap tools and playgrounds, Grid systems, Bootstrap UI libraries for React, Angular, and Vue, Sass installation and much more.</p>
      <p class="f-small l-mb0">Worth $11.71 on Amazon. Yours FREE!</p>
    </free-book-content>
    <a class="close-reveal-modal" aria-label="Close">&#215;</a>
    <free-book-form slug="bootstrap-tools-skills-reader" />
  </div>
</script></div>    <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.typeform.com/to/fNY7XG">Corporate Memberships</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/l/developer-jobs">Jobs</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/deals">Deals</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.typeform.com/to/HtAXVN">Publish With Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2019 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function() {
    window.adblocked = false;
    var onAdblock = function() {
      if (adblocked) return;

      window.adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {
        'nonInteraction': true
      });

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function() {
      if (document.readyState && !/loaded|complete/.test(document.readyState)) {
        setTimeout(_onload, 10);
        return
      }
      if (!window.__adroll_loaded) {
        __adroll_loaded = true;
        setTimeout(_onload, 50);
        return
      }
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
        document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {
      window.addEventListener('load', _onload, false);
    } else {
      window.attachEvent('onload', _onload)
    }
  }());
</script>    <sp-cookie-warning></sp-cookie-warning>
    

<!-- START Parse.ly Include: Standard -->

<script data-cfasync="false" id="parsely-cfg" data-parsely-site="sitepoint.com" src="//cdn.parsely.com/keys/sitepoint.com/p.js"></script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<div class="widget maestro maestro-content-type-html " id="maestro-758"><script id="spout-tag-7c887d1e-c4ea-4682-bad8-216a89ce74e5">
  (function() {
    var r = encodeURIComponent(top.document.referrer.substring(0,250)),
        p = encodeURIComponent(top.document.location.href.substring(0,250)),
        t = Date.now(),
        u = '7c887d1e-c4ea-4682-bad8-216a89ce74e5',
        e = document.createElement('script'),
        s = sessionStorage.getItem('spoutable-' + u);
    if (!s) {
      var m = Math.random.bind(Math);
      s = JSON.stringify({ sessionId: [ t, m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m() ]});
      sessionStorage.setItem('spoutable-' + u, s);
    }
    e.async = true;
    e.src='//s.spoutable.com/s?u='+u+'&s='+encodeURIComponent(s)+'&t='+t+'&r='+r+'&p='+p;
    document.head.appendChild(e);
  })();
</script></div><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-746"><div class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_main_1'); }); </script> </div>
</div></div><script type='text/javascript'>
/* <![CDATA[ */
var discourse = {"url":"https:\/\/www.sitepoint.com\/community"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/wp-discourse/js/comments.js?ver=1.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-610c13fa167100c6e08a3df6828a2270.js?ver=4.9.8'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/bundle-9e8499f68c7ce98d177441c207d9e8a6.js'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/article-ba6b0e32b94bc8805a429662be25e5e6.js'></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","alm_nonce":"16ea568030","pluginurl":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/ajax-load-more","scrolltop":"false","speed":"250","results_text":"Displaying page {num} of {total}.","no_results_text":"No results found."};
var ajax_load_more_vars = {"id":"ajax-load-more"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.1.2'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 39/54 objects using memcached
Page Caching using memcached (Requested URI contains query) 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2019-07-29 11:06:42 by W3 Total Cache
-->