SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Member
    Join Date
    May 2008
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    MySQL - ERROR 2003 (HY000) - please help!!

    I am getting the following error when I try to connect to mysql from command prompt. I am getting the same error when I try 127.0.0.1 (but in this case "localhost" is replaced with "127.0.0.1")

    ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)


    I am not trying to do anything remotely yet. I just need the normal local connection to learn PHP and MySql.

    I installed PHP, MySQL and IIS as described in the first chapter of Sitepoint's "Build your own database driven websites using PHP and MySQL"

    Somebody please help. I just need to connect locally
    Last edited by maximus_xps; May 9, 2008 at 04:47. Reason: Summary was not understandable

  2. #2
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    you usually get that error when mysql is not running.
    Check out our new Industry News forum!
    Keep up-to-date with the latest SP news in the Community Crier

    I edit the SitePoint Podcast

  3. #3
    SitePoint Member
    Join Date
    May 2008
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by longneck View Post
    you usually get that error when mysql is not running.
    I did check the processes running and mysql-nt was one of them and I also tried to connect after restarting mysql using "net stop mysql" and "net start mysql".

  4. #4
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    make sure skip-networking is not in your my.ini or my.cnf file. also make sure you don't have multiple my.ini and my.cnf files on your computer.
    Check out our new Industry News forum!
    Keep up-to-date with the latest SP news in the Community Crier

    I edit the SitePoint Podcast

  5. #5
    SitePoint Member
    Join Date
    May 2008
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I do not have multiple my.ini files and i do not have skip-networking in the file. I moved the other my*.ini files. I do not have any .cnf files either.

    I do have a line "skip-innodb" which i tried disabling and then restarting mysql but it does not do the trick. I enabled it again.

    Please help!! I have hit a wall with this.
    Last edited by maximus_xps; May 12, 2008 at 07:45. Reason: missed out information

  6. #6
    SitePoint Member
    Join Date
    May 2008
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Please!! Is there any way to fix this? I have no use for the book if I can't install and start using MySQL!!

  7. #7
    reads the ********* Crier silver trophybronze trophy longneck's Avatar
    Join Date
    Feb 2004
    Location
    Tampa, FL (US)
    Posts
    9,854
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    download tcpview from sysinternals. run it and look for mysqld-nt in the list. what does "local address" say?
    Check out our new Industry News forum!
    Keep up-to-date with the latest SP news in the Community Crier

    I edit the SitePoint Podcast

  8. #8
    SitePoint Member
    Join Date
    May 2008
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I fixed it!! The problem was that I had a firewall "COMODO" installed a long time ago and completely forgot about it. It was disabled but I think it had processes running in the background or something that still was working to protect my pc. I just enabled COMODO and tried connecting to MySQL. COMODO generated messages to allow/block the communication and I allowed it. Now it's working fine. Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •