<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.2.0/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    <meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KL8PMMW');</script>

    <script class="SP_stripMobile" type="text/javascript">
      var propertag = propertag || {};
      propertag.cmd = propertag.cmd || [];
      (function() {
      var pm = document.createElement('script');
      pm.async = true; pm.type = 'text/javascript';
      var is_ssl = 'https:' == document.location.protocol;
      pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/sitepoint.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(pm, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();

      var oSpP;
    </script>
    <script charset="UTF-8" src="//cdn.sendpulse.com/js/push/ee9a890c7a9d2a9236648c25e40bd03e_1.js" async></script>


    <!-- [JSON-LD Schema data[ -->
        <script type="application/ld+json">
      {"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.sitepoint.com\/javascript\/","name":"JavaScript"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.sitepoint.com\/author\/amahmoud","name":"Ahmed Mahmoud"}}]}    </script>
    <script type="application/ld+json">
      {"@context":"http:\/\/schema.org","@type":"Article","headline":"React Native End-to-end Testing and Automation with Detox","url":"https:\/\/www.sitepoint.com\/detox-react-native-testing-automation\/","articleSection":"JavaScript","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.sitepoint.com\/detox-react-native-testing-automation\/"},"author":[{"@type":"Person","name":"Ahmed Mahmoud"}],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/themes\/sitepoint\/assets\/images\/icon.javascript.png"}},"dateCreated":"2019-11-06T18:00:58Z","datePublished":"2019-11-06T18:00:58Z","dateModified":"2019-11-06T18:00:58Z","thumbnailUrl":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2019\/11\/1572848286detox-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2019\/11\/1572848286detox-150x150.jpg"},"keywords":["automation","Detox","end-to-end testing","React native","Testing"]}    </script>
    <!-- ]] -->

    
<!-- This site is optimized with the Yoast SEO plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>React Native End-to-end Testing and Automation with Detox &mdash; SitePoint</title>
<meta name="description" content="Learn how to use Detox to implement end-to-end testing in your React Native app, covering configuration, writing selectors, common challenges, and more."/>
<link rel="canonical" href="https://www.sitepoint.com/detox-react-native-testing-automation/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="React Native End-to-end Testing and Automation with Detox &mdash; SitePoint" />
<meta property="og:description" content="Learn how to use Detox to implement end-to-end testing in your React Native app, covering configuration, writing selectors, common challenges, and more." />
<meta property="og:url" content="https://www.sitepoint.com/detox-react-native-testing-automation/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="automation" />
<meta property="article:tag" content="Detox" />
<meta property="article:tag" content="end-to-end testing" />
<meta property="article:tag" content="React native" />
<meta property="article:tag" content="Testing" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2019-11-06T18:00:58+00:00" />
<meta property="article:modified_time" content="2019-11-05T01:39:09+00:00" />
<meta property="og:updated_time" content="2019-11-05T01:39:09+00:00" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572848286detox.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572848286detox.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="344" />
<meta property="og:image:alt" content="Introducing Detox, a React Native End-to-end Testing and Automation Framework" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Learn how to use Detox to implement end-to-end testing in your React Native app, covering configuration, writing selectors, common challenges, and more." />
<meta name="twitter:title" content="React Native End-to-end Testing and Automation with Detox &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572848286detox.jpg" />
<meta name="twitter:creator" content="@ahmed_am55" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; React Native End-to-end Testing and Automation with Detox Comments Feed" href="https://www.sitepoint.com/detox-react-native-testing-automation/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.sitepoint.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-151a38e87e68fbad6a7c4527ed1a5fba.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-dynamic-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/bundle-b16627d3e392afec34db158ec09e56d2.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-article-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/article-35a91ee329370f5244ffecd2a6c2e8ca.css?ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-d486959b95b4547afeeb1b5d8e5cf97f.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=174094' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fdetox-react-native-testing-automation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fdetox-react-native-testing-automation%2F&#038;format=xml" />
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "174094");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>

    <!-- Nativo Ads -->
    <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
     <!-- Tapfiliate code here-->
    <script src="https://script.tapfiliate.com/tapfiliate.js" type="text/javascript" async></script>
    <script type="text/javascript">
      (function(t,a,p){t.TapfiliateObject=a;t[a]=t[a]||function(){
      (t[a].q=t[a].q||[]).push(arguments)}})(window,'tap');

      tap('create', '10694-267423');
      tap('detect');
    </script>

    <!-- reCAPTCHA v3 code here-->
          <script src="https://www.google.com/recaptcha/api.js?render=6LfEw7cUAAAAABIV8YABIbOzqBJ3zr4BpjVbDXDK"></script>
      <script>
        grecaptcha.ready(function(){
          document.querySelector('.grecaptcha-badge').style.visibility = 'hidden';
        });
      </script>
      </head>
<body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
    <header class="main-header u-isSingle" role="banner">
    <nav id="navigation-bar" class="l-d-f l-p-fix l-w-100">
      <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto">
        <section class="l-d-f l-ai-str l-jc-sta l-gs-ph2 l-gs-ph1--2col">
          <a class="l-d-f" href="https://www.sitepoint.com/">
            <div class="l-d-f l-as-cen l-b-n">
              <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
            </div>
          </a>
        </section>
        <section id="hamburger-container" class="l-ai-cen l-d-f l-gs-ph1">
          <div class="hamburger">
            <div class="hamburger-box">
              <div class="hamburger-inner"></div>
            </div>
          </div>
        </section>

        <section id="nav-container" class="l-ai-cen">
          <ul id="nav" class="l-d-f l-w-100 l-ma0 l-fd-col">
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a id="nav-blog" href="/blog" data-text="Blog">Blog</a>
            </li>
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a href="/community" data-text="Community">Community</a>
            </li>
            <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
              <a href="/premium/library/" data-text="Library">Library</a>
            </li>
                          <nav-bar-actions is_member="" slug="detox-react-native-testing-automation" categories="javascript"></nav-bar-actions>
                      </ul>
        </section>
      </div>
    </nav>

    <div class="NavBar_offsetSpacer"></div>
    <script>
              var current_category = ['javascript'];
        if (localStorage.getItem('SP_categories') !== null) {
          if (localStorage.getItem('SP_categories').includes(current_category) === false) {
            var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
            var temp = current_category.concat(sp_categories);
            var filtered_categories = Array.from(new Set(temp));
            localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
          }
        } else {
          localStorage.setItem('SP_categories', JSON.stringify('javascript'));
        }
        // campaign
        localStorage.setItem('SP_slug', 'detox-react-native-testing-automation');

      
      /* Toggle mobile navigation */
      var toggleMobileNav = function(event) {
        var target = event.target;
        if (target.className.includes("hamburger")) {
          document.getElementById("hamburger-container").classList.toggle("open");
        }
      }
      var isTouchSupported = 'ontouchstart' in window;
      var startEvent = isTouchSupported ? 'touchstart' : 'click';
      document.addEventListener(startEvent, toggleMobileNav);

      /* Set active navigation item  */
      var current_url = window.location.href;
      if (current_url.indexOf("/blog") > -1) {
        document.getElementById("nav-blog").classList.add("youarehere");
      }
    </script>
    <div class="widget maestro maestro-content-type-html " id="maestro-744"><script type="text/javascript">
  (function() {
    document.addEventListener("DOMContentLoaded", function() {
      var ssConfig = {
        searchBar: {
          placeholder: "Search hundreds of developer books and courses"
        }
      };
      var ss = new SmartSearch(ssConfig);
      
      function ownKeys(e,t){var n=Object.keys(e);if(Object.getOwnPropertySymbols){var r=Object.getOwnPropertySymbols(e);t&&(r=r.filter(function(t){return Object.getOwnPropertyDescriptor(e,t).enumerable})),n.push.apply(n,r)}return n}function _objectSpread(e){for(var t=1;t<arguments.length;t++){var n=null!=arguments[t]?arguments[t]:{};t%2?ownKeys(n,!0).forEach(function(t){_defineProperty(e,t,n[t])}):Object.getOwnPropertyDescriptors?Object.defineProperties(e,Object.getOwnPropertyDescriptors(n)):ownKeys(n).forEach(function(t){Object.defineProperty(e,t,Object.getOwnPropertyDescriptor(n,t))})}return e}function _defineProperty(e,t,n){return t in e?Object.defineProperty(e,t,{value:n,enumerable:!0,configurable:!0,writable:!0}):e[t]=n,e}function SmartSearch(){var e=this,t=arguments.length>0&&void 0!==arguments[0]?arguments[0]:{};function n(e){var t=arguments.length>1&&void 0!==arguments[1]?arguments[1]:100,n=!1;return function(){n||(e.apply(this,arguments),n=!0,setTimeout(function(){n=!1},t))}}function r(e){return e.getBoundingClientRect().height}function i(e){var t=r(e);e.style.top=-t+"px"}this.init=function(){e.buildSearchBar(),e.buildButton(),e.render()},this.defaults={searchBar:{placeholder:"What do you want to learn?"},button:{text:"Search",icon:"fa-search"},overlayTarget:"#navigation-bar"},this.config=_objectSpread({},this.defaults,{},t),this.container=document.createElement("div"),this.body=document.createElement("div"),this.children={form:document.createElement("form"),searchBar:document.createElement("input"),button:document.createElement("button")},this.buildOverlay=function(){var t=document.querySelector(e.config.overlayTarget);t&&(e.container.style.minHeight=r(t)+"px")},this.buildSearchBar=function(){e.children.searchBar.placeholder=e.config.searchBar.placeholder},this.buildButton=function(){var t=e.children.button;if(t.type="submit",document.querySelector("link[href^='https://pro.fontawesome.com']")&&e.config.button.icon){var n=document.createElement("i");n.classList.add("fas",e.config.button.icon),e.children.button.classList.add("icon-btn"),e.children.button.appendChild(n)}else t.innerHTML=e.config.button.text||e.defaults.button.text},this.render=function(){e.body.innerHTML="",e.container.setAttribute("class","sp-smartsearch"),e.body.setAttribute("class","sp-smartsearch__body"),e.children.form.setAttribute("action",window.location.origin+"/premium/search"),e.children.form.setAttribute("method","get"),e.children.form.setAttribute("id","sp-smart-search"),e.children.form.setAttribute("name","sp-smart-search"),e.children.searchBar.setAttribute("type","text"),e.children.searchBar.setAttribute("name","q"),e.config.overlayTarget&&e.buildOverlay(),e.children.form.appendChild(e.children.searchBar),e.children.form.appendChild(e.children.button),e.body.appendChild(e.children.form),e.container.appendChild(e.body),document.body.appendChild(e.container),i(e.container);var t=0,o=n(function(e,n){var i=window.pageYOffset,o=document.querySelector(".sp-smartsearch input[type='text']");document.activeElement!=o&&(n.style.top=t>=i||i<=0?-r(n)+"px":0,t=i)},150);window.addEventListener("resize",function(t){var r=e.container;n(function(){i(r)},150)}),window.addEventListener("scroll",function(t){o(t,e.container)})},this.init()}
    });
  })();
</script>
<style>
  .sp-smartsearch {
    all: initial;
    -webkit-box-sizing: border-box;
            box-sizing: border-box;
    position: fixed;
    top: -150px;
    left: 0;
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    width: 100%;
    font-size: 18px;
    font-family: "Roboto", "Helvetica Neue", "Helvetica", Helvetica, Arial, sans-serif;
    z-index: 1000;
    -webkit-transition: all 0.3s ease-out;
    -o-transition: all 0.3s ease-out;
    transition: all 0.3s ease-out;
  }

  .sp-smartsearch__body {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    min-height: 0px;
    width: 100%;
    -webkit-box-align: center;
        -ms-flex-align: center;
            align-items: center;
    -webkit-box-pack: center;
        -ms-flex-pack: center;
            justify-content: center;
    -ms-flex-wrap: wrap;
        flex-wrap: wrap;
    padding: 1em;
    background-color: #232023;
    color: #fff;
  }

  .sp-smartsearch__body form {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    -webkit-box-pack: space-evenly;
        -ms-flex-pack: space-evenly;
            justify-content: space-evenly;
    width: 100%;
    margin: 0;
  }

  .sp-smartsearch__body form {
    border: none;
    border-radius: 3px;
    background-color: #4d4d4d;
  }

  .sp-smartsearch__body input[type="text"] {
    -webkit-box-flex: 1;
        -ms-flex-positive: 1;
            flex-grow: 1;
    margin: 0;
    padding: 10px;
    background: transparent;
    border: none;
    font-size: 14px;
    color: #fff;
    -o-text-overflow: ellipsis;
       text-overflow: ellipsis;
  }

  .sp-smartsearch__body input[type="text"]::-webkit-input-placeholder {
    color: #a9a9a9;
    opacity: 1;
  }

  .sp-smartsearch__body input[type="text"]::-moz-placeholder {
    color: #a9a9a9;
    opacity: 1;
  }

  .sp-smartsearch__body input[type="text"]:-ms-input-placeholder {
    color: #a9a9a9;
    opacity: 1;
  }

  .sp-smartsearch__body input[type="text"]::-ms-input-placeholder {
    color: #a9a9a9;
    opacity: 1;
  }

  .sp-smartsearch__body input[type="text"]::placeholder {
    color: #a9a9a9;
    opacity: 1;
  }

  .sp-smartsearch__body input[type="text"]:-ms-input-placeholder {
    /* Internet Explorer 10-11 */
    color: #a9a9a9;
  }

  .sp-smartsearch__body input[type="text"]::-ms-input-placeholder {
    /* Microsoft Edge */
    color: #a9a9a9;
  }

  .sp-smartsearch__body input[type="text"]:focus {
    outline: none;
  }

  .sp-smartsearch__body button {
    display: inline-block;
    text-decoration: none;
    text-transform: uppercase;
    background: #3ec9cb;
    color: #fff;
    margin: 0;
    padding: 1em;
    border-radius: 3px;
    font-weight: 700;
    font-size: 14px;
    border: none;
    cursor: pointer;
  }

  .sp-smartsearch__body .icon-btn {
    background: transparent;
    color: #a9a9a9;
  }

  @media (min-width: 936px) {
    .sp-smartsearch__body form {
      max-width: 936px;
    }
  }

  @media (min-width: 1280px) {
    .sp-smartsearch__body form {
      max-width: 1248px;
    }
  }
</style></div>  </header><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-776"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_billboard"> <script> propertag.cmd.push(function() { proper_display('sitepoint_billboard'); }); </script> </div>
</div></div>  <div class="l-p-rel t-bg-white sp-article" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
        <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-ph4--2col l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              >
              <a
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/javascript/">
                  javascript              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
            >
              November 06, 2019            </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/amahmoud/">
                      Ahmed Mahmoud                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">React Native End-to-end Testing and Automation with Detox</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
            <div class="l-d-f l-jc-sb l-mt3 l-w-4col--4col l-mh-auto" data-hellobar="content">
      <div class="l-w-100 l-fg1 l-mh3--2col l-mh0--4col l-o-h">
                    <div class="l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-javascript">
      <sp-social-share></sp-social-share>
      <div class='l-mt3 l-mh5--2col'>
        <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p><strong><a style="font-weight:bold" href="https://github.com/wix/Detox">Detox</a> is an end-to-end testing and automation framework that runs on a device or a simulator, just like an actual end user.</strong></p>
<p>Software development demands fast responses to user and/or market needs. This fast development cycle can result (sooner or later) in parts of a project being broken, especially when the project grows so large. Developers get overwhelmed with all the technical complexities of the project, and even the business people start to find it hard to keep track of all scenarios the product caters for.</p>
<p>In this scenario, there&rsquo;s a need for software to keep on top of the project and allow us to deploy with confidence. But why end-to-end testing? Aren&rsquo;t unit testing and integration testing enough? And why bother with the complexity that comes with end-to-end testing?</p>
<p>First of all, the complexity issue has been tackled by most of the end-to-end frameworks, to the extent that some tools (whether free, paid or limited) allow us to record the test as a user, then replay it and generate the necessary code. Of course, that doesn&rsquo;t cover the full range of scenarios that you&rsquo;d be able to address programmatically, but it&rsquo;s still a very handy feature.</p>
<p class="wp-special"><em>Want to learn React Native from the ground up? This article is an extract from our Premium library. Get an entire collection of React Native books covering fundamentals, projects, tips and tools &amp; more with SitePoint Premium. <a href="https://www.sitepoint.com/premium/products/Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvMzA3?utm_source=blog&amp;utm_medium=articles">Join now for just $9/month</a>.</em></p>
<h2 id="end-to-end-integration-and-unit-testing">End-to-end Integration and Unit Testing</h2>
<p>End-to-end testing versus integration testing versus unit testing: I always find the word &ldquo;versus&rdquo; drives people to take camps &mdash; as if it&rsquo;s a war between good and evil. That drives us to take camps instead of learning from each other and understanding the why instead of the how. The examples are countless: Angular versus React, React versus Angular versus Vue, and even more, React versus Angular versus Vue versus Svelte. Each camp trash talks the other.</p>
<p>jQuery made me a better developer by taking advantage of the facade pattern <code>$('')</code> to tame the wild DOM beast and keep my mind on the task at hand. Angular made me a better developer by taking advantage of componentizing the reusable parts into directives that can be composed (v1). React made me a better developer by taking advantage of functional programming, immutability, identity reference comparison, and the level of composability that I don&rsquo;t find in other frameworks. Vue made me a better developer by taking advantage of reactive programming and the push model. I could go on and on, but I&rsquo;m just trying to demonstrate the point that we need to concentrate more on the why: why this tool was created in the first place, what problems it solves, and whether there are other ways of solving the same problems.</p>
<h3 id="as-you-go-up-you-gain-more-confidence">As You Go Up, You Gain More Confidence</h3>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572846431chart-end-to-end-1024x632.jpg" alt="end-to-end testing graph that demonstrates the benefit of end-to-end testing and the confidence it brings" width="1024" height="632" class="alignnone size-large wp-image-174096"></p>
<p>As you go more on the spectrum of simulating the user journey, you have to do more work to simulate the user interaction with the product. But on the other hand, you get the most confidence because you&rsquo;re testing the real product that the user interacts with. So, you catch all the issues&mdash;whether it&rsquo;s a styling issue that could cause a whole section or a whole interaction process to be invisible or non interactive, a content issue, a UI issue, an API issue, a server issue, or a database issue. You get all of this covered, which gives you the most confidence.</p>
<h2 id="why-detox-">Why Detox?</h2>
<p>We discussed the benefit of end-to-end testing to begin with and its value in providing the most confidence when deploying new features or fixing issues. But why Detox in particular? At the time of writing, it&rsquo;s the most popular library for end-to-end testing in React Native and the one that has the most active community. On top of that, it&rsquo;s the one React Native recommends in its <a href="https://github.com/facebook/react-native/wiki/Tests#end-to-end-tests">documentation</a>.</p>
<p>The Detox testing philosophy is &ldquo;gray-box testing&rdquo;. <strong>Gray-box testing</strong> is testing where the framework knows about the internals of the product it&rsquo;s testing.In other words, it knows it&rsquo;s in React Native and knows how to start up the application as a child of the Detox process and how to reload it if needed after each test. So each test result is independent of the others.</p>
<h2 id="prerequisites">Prerequisites</h2>
<ol><li>macOS High Sierra 10.13 or above</li>
<li>Xcode 10.1 or above</li>
<li>
<p>Homebrew:</p>
<pre><code class="lang-bash"> /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
</code></pre>
</li>
<li>
<p>Node 8.3.0 or above:</p>
<pre><code class="lang-bash"> brew update &amp;&amp; brew install node
</code></pre>
</li>
<li>
<p>Apple Simulator Utilities: <code>brew tap wix/brew</code> and <code>brew install applesimutils</code><div class="proper-ad-unit">
          <div id="proper-ad-sitepoint_content_1">
            <script>
              window.propertag.cmd.push(function() {
                proper_display('sitepoint_content_1');
              });
            </script></div>
        </div></p>
</li>
<li>
<p>Detox CLI 10.0.7 or above:</p>
<pre><code class="lang-bash"> npm install -g detox-cli
</code></pre>
</li>
</ol><h2 id="see-the-result-in-action">See the Result in Action</h2>
<p>First, let&rsquo;s clone a very interesting <a href="https://github.com/ahmedam55/movie-swiper-detox-testing">open-source React Native project</a> for the sake of learning, then add Detox to it:</p>
<pre><code class="lang-bash">git clone https://github.com/ahmedam55/movie-swiper-detox-testing.git
cd movie-swiper-detox-testing
npm install
react-native run-ios
</code></pre>
<p>Create an account on <a href="https://www.themoviedb.org/account/signup">The Movie DB website</a> to be able to test all the application scenarios. Then add your username and password in <code>.env</code> file with <code>usernamePlaceholder</code> and <code>passwordPlaceholder</code> respectively:</p>
<pre><code class="lang-javascript">isTesting=true
username=usernamePlaceholder
password=passwordPlaceholder
</code></pre>
<p>After that, you can now run the tests:</p>
<pre><code class="lang-bash">detox test
</code></pre>
<p>Note that I had to fork this repo from the <a href="https://github.com/azhavrid/movie-swiper">original one</a> as there were a lot of breaking changes between detox-cli, detox, and the project libraries. Use the following steps as a basis for what to do:</p>
<ol><li>Migrate it completely to latest React Native project.</li>
<li>Update all the libraries to fix issues faced by Detox when testing.</li>
<li>Toggle animations and infinite timers if the environment is testing.</li>
<li>Add the test suite package.</li>
</ol><h2 id="set-up-for-new-projects">Setup for New Projects</h2>
<h3 id="add-detox-to-our-dependencies">Add Detox to Our Dependencies</h3>
<p>Go to your project&rsquo;s root directory and add Detox:</p>
<pre><code class="lang-bash">npm install detox --save-dev
</code></pre>
<h3 id="configure-detox">Configure Detox</h3>
<p>Open the <code>package.json</code> file and add the following right after the project name config. Be sure to replace <code>movieSwiper</code> in the iOS config with the name of your app. Here we&rsquo;re telling Detox where to find the binary app and the command to build it. (This is optional. We can always execute <code>react-native run-ios</code> instead.) Also choose which type of simulator: <code>ios.simulator</code>, <code>ios.none</code>, <code>android.emulator</code>, or <code>android.attached</code>. And choose which device to test on:</p>
<pre><code class="lang-javascript">{
  "name": "movie-swiper-detox-testing",

  // add these:
  "detox": {
    "configurations": {
      "ios.sim.debug": {
        "binaryPath": "ios/build/movieSwiper/Build/Products/Debug-iphonesimulator/movieSwiper.app",
        "build": "xcodebuild -project ios/movieSwiper.xcodeproj -scheme movieSwiper -configuration Debug -sdk iphonesimulator -derivedDataPath ios/build",
        "type": "ios.simulator",
        "name": "iPhone 7 Plus"
      }
    }
  }
}
</code></pre>
<p>Here&rsquo;s a breakdown of what the config above does:</p>
<ul><li>Execute <code>react-native run-ios</code> to create the binary app.</li>
<li>Search for the binary app at the root of the project: <code>find . -name "*.app"</code>.</li>
<li>Put the result in the <code>build</code> directory.</li>
</ul><p>Before firing up the test suite, make sure the device <code>name</code> you specified is available (for example, iPhone 7). You can do that from the terminal by executing the following:</p>
<pre><code class="lang-bash">xcrun simctl list
</code></pre>
<p>Here&rsquo;s what it looks like:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572846473device-list.png" alt="device-list" width="760" height="436" class="alignnone size-full wp-image-174097"></p>
<p>Now that weve added Detox to our project and told it which simulator to start the application with, we need a test runner to manage the assertions and the reporting&mdash;whether it&rsquo;s on the terminal or otherwise.</p>
<p>Detox supports both <a href="https://jestjs.io/">Jest</a> and <a href="https://mochajs.org/">Mocha</a>. We&rsquo;ll go with Jest, as it has bigger community and bigger feature set. In addition to that, it supports parallel test execution, which could be handy to speed up the end-to-end tests as they grow in number.<div class="proper-ad-unit">
          <div id="proper-ad-sitepoint_content_2">
            <script>
              window.propertag.cmd.push(function() {
                proper_display('sitepoint_content_2');
              });
            </script></div>
        </div></p>
<h3 id="adding-jest-to-dev-dependencies">Adding Jest to Dev Dependencies</h3>
<p>Execute the following to install Jest:</p>
<pre><code class="lang-bash">npm install jest jest-cli --save-dev
</code></pre>
<h3 id="generate-test-suite-files">Generate Test Suite Files</h3>
<p>To initialize Detox to use Jest, execute the following:</p>
<pre><code class="lang-bash">detox init -r jest
</code></pre>
<p>This will create an <code>e2e</code> folder at the root of the project and the following inside of it:</p>
<ul><li>
<p><strong>e2e/config.json</strong> contains the global config for the test runner:</p>
<pre><code class="lang-javascript">  {
      "setupFilesAfterEnv": ["./init.js"],
      "testEnvironment": "node",
      "reporters": ["detox/runners/jest/streamlineReporter"],
      "verbose": true
  }
</code></pre>
</li>
<li>
<p><strong>e2e/init.js</strong> contains the initialization code that runs before any of your tests are executed:</p>
<pre><code class="lang-javascript">const detox = require('detox');
  const config = require('../package.json').detox;
  const adapter = require('detox/runners/jest/adapter');
  const specReporter = require('detox/runners/jest/specReporter');

  // Set the default timeout
  jest.setTimeout(25000);
  jasmine.getEnv().addReporter(adapter);

  // This takes care of generating status logs on a per-spec basis. By default, jest only reports at file-level.
  // This is strictly optional.
  jasmine.getEnv().addReporter(specReporter);

  beforeAll(async () =&gt; {
    await detox.init(config);
  });

  beforeEach(async () =&gt; {
    await adapter.beforeEach();
  });

  afterAll(async () =&gt; {
    await adapter.afterAll();
    await detox.cleanup();
  });
</code></pre>
</li>
<li>
<p><strong>e2e/firstTest.spec.js</strong> is the default Detox test file. This is where we will put all of the tests for the app. We&rsquo;ll talk in details about the <code>describe</code> and <code>it</code> blocks, as well as the test suites that we&rsquo;re going to create later.</p>
</li>
</ul><h3 id="finally-we-run-the-tests">Finally, We Run the Tests</h3>
<p>To run the tests, navigate to your project&rsquo;s root directory and execute the following:</p>
<pre><code class="lang-bash">detox test
</code></pre>
<p>Congratulations! We have everything ready for us to write our awesome tests. You can create and manage as many <code>e2e/*spec.js</code> files as you want and the test runner will execute them one by one. The spec file represents an independent set of features that you want to test. For example, checkout, guest checkout, user authentication, or sign up.</p>
<p>Inside the spec file you&rsquo;ll have <code>describe</code>. This contains the smallest testing blocks&mdash;<code>it</code> block&mdash;which is created for reading. For example: <code>it should reject creating an account if name already exits</code>. And inside that <code>it</code> block, you add the assertions necessary to make sure that this is true. Ideally, we should reload React Native after each <code>it</code> block. This is as long as they don&rsquo;t depend on each other. That prevents false positives, and makes debugging easier. Knowing that this test failed on clean slate, you don&rsquo;t have to worry about all the other scenarios.</p>
<h2 id="a-dive-deep-into-our-test-suite">A Dive Deep into Our Test Suite</h2>
<p>We&rsquo;ll check the app caters for the following scenarios.</p>
<ul><li><strong>It should disallow logging in with wrong credentials</strong>. This one seems obvious, but it&rsquo;s critical to the app workflow, so it needs to be tested with each change and/or deployment.</li>
<li><strong>It should authenticate users with valid credentials</strong>&mdash;testing that the authentication functionality works properly.</li>
<li><strong>It should kick out users when they sign out</strong>&mdash;testing whether signing out navigates users aways from the Browse, Explore, and Library screens.</li>
<li><strong>It should allow guests to browse screen only</strong>. Users can log in or continue as guests, and in this case they would only be able to access the Browse screen and the features it has.</li>
<li><strong>It should fetch movies that match the query</strong>&mdash;testing if the movies rendered are the ones that match the search query.</li>
<li><strong>It should add to favorites</strong>&mdash;testing the add to favorite movies functionality, and making sure that the added movie appears in the favorite movies list.</li>
<li><strong>It should add to watch list</strong>&mdash;similar to testing adding to favorite movies, but for watch-list functionality.</li>
<li><strong>It should show all when more is clicked</strong>&mdash;testing the <strong>more</strong> button functionality of the Browse sections:
<ul><li>Trending Daily</li>
<li>Trending Weekly</li>
<li>Popular</li>
<li>Top Rated</li>
<li>Make sure it navigates to the movies list view with all movies that match the selected criteria.</li>
</ul></li>
</ul><h2 id="walking-through-the-code-of-the-test-suite">Walking Through the Code of the Test Suite</h2>
<p>Now it&rsquo;s time for us to go over the code for testing the app. Before doing so, though, I recommend that you run the app on your device or simulator first. This is to familiarize yourself with the different screens and UI components within the app.</p>
<p>The first thing we need to do is define the functions we&rsquo;ll be using to perform various tests. As I found myself matching the same set of UI elements and performing a specific set of actions, I&rsquo;d abstract it to its own function, so I could reuse it in other tests and centralize fixes and changes in one place. Here are some examples on the abstraction I found helpful:</p>
<ul><li><code>loginWithWrongCredentials()</code></li>
<li><code>loginWithRightCredentials()</code></li>
<li><code>goToLibrary()</code></li>
<li><code>signOut()</code></li>
<li><code>searchForMovie(title)</code></li>
</ul><p>Detox&rsquo;s API should easily make sense to you even if you haven&rsquo;t used it previously. Here&rsquo;s the code:<div class="proper-ad-unit">
          <div id="proper-ad-sitepoint_content_3">
            <script>
              window.propertag.cmd.push(function() {
                proper_display('sitepoint_content_3');
              });
            </script></div>
        </div></p>
<pre><code class="lang-javascript">// e2e/firstTestSuite.spec.js

// fetch the username and password from the .env file
const username = process.env.username;
const password = process.env.password;

const sleep = duration =&gt;
  new Promise(resolve =&gt; setTimeout(() =&gt; resolve(), duration)); // function for pausing the execution of the test. Mainly used for waiting for a specific UI component to appear on the screen

const loginWith = async (username, password) =&gt; {
  try {
    // click on login btn to navigate to the username, password screen
    const navigateToLoginBtn = await element(by.id("navigate-login-btn"));
    await navigateToLoginBtn.tap();

    const usernameInput = await element(by.id("username-input"));
    const passwordInput = await element(by.id("password-input"));

    await usernameInput.tap();
    await usernameInput.typeText(username);
    await passwordInput.typeText(password);

    const loginBtn = await element(by.id("login-btn"));

    await loginBtn.tap(); // to close the keyboard
    await loginBtn.tap(); // to start the authentication process

    const errorMessage = await element(
      by.text("Invalid username and/or password")
    );

    return { errorMessage, usernameInput, passwordInput };
  } catch (e) {
    console.log(
      "A sign out has not been done, which made the `navigate-login-btn` not found"
    );
  }
};

const loginWithWrongCredentials = async () =&gt;
  await loginWith("alex339", "9sdfhsakjf"); // log in with some random incorrect credentials
const loginWithRightCredentials = async () =&gt;
  await loginWith(username, password); // log in with the correct credentials

const goToLibrary = async () =&gt; {
  const libraryBtn = await element(by.id("navigation-btn-Library"));
  await libraryBtn.tap();
};

const goToExplore = async () =&gt; {
  const exploreBtn = await element(by.id("navigation-btn-Explore"));
  await exploreBtn.tap();
};

const signOut = async () =&gt; {
  await goToLibrary();

  const settingsBtn = await element(by.id("settings-btn"));
  await settingsBtn.tap();

  const signOutBtn = await element(by.id("sign-out-btn"));
  await signOutBtn.tap();
};

const continueAsGuest = async () =&gt; {
  const continueAsGuestBtn = await element(by.id("continue-as-guest"));
  await continueAsGuestBtn.tap();
};

const searchForMovie = async movieTitle =&gt; {
  const searchMoviesInput = await element(by.id("search-input-input"));
  await searchMoviesInput.tap();
  await searchMoviesInput.clearText();
  await searchMoviesInput.typeText(movieTitle);
};

const goBack = async () =&gt; {
  const goBackBtn = await element(by.id("go-back-btn"));
  goBackBtn.tap();
};

const goToWatchListMovies = async () =&gt; {
  const watchListBtn = await element(by.id("my-watchlist"));
  await watchListBtn.tap();
};

const goToFavoriteMovies = async () =&gt; {
  const favoriteMoviesBtn = await element(by.id("my-favorite-movies"));
  await favoriteMoviesBtn.tap();
};

const clickFavoriteButton = async () =&gt; {
  const addToWatchListBtn = await element(by.id("add-to-favorite-btn"));
  await addToWatchListBtn.tap();
};

const clickWatchListButton = async () =&gt; {
  const addToWatchListBtn = await element(by.id("add-to-watch-list-btn"));
  await addToWatchListBtn.tap();
};

const removeTestMoviesFromLists = async () =&gt; {
  try {
    await loginWithRightCredentials();
    await goToLibrary();
    await goToWatchListMovies();

    const movieItemInWatchList = await element(
      by.text("Crazy Rich Asians").withAncestor(by.id("watch-list"))
    );

    await movieItemInWatchList.tap();
    await clickWatchListButton();
    await goToLibrary();
    await goToFavoriteMovies();

    const movieItemInFavorites = await element(
      by.text("Avengers: Endgame").withAncestor(by.id("favorite-list"))
    );

    await movieItemInFavorites.tap();
    await clickFavoriteButton();
  } catch (e) {}
  await signOut();
};

// next: add function for asserting movie items
</code></pre>
<p>Next, we add the function for asserting the movie items. Unlike all the other functions we&rsquo;ve defined above, this one is actually running an individual test&mdash;to assert that a specific movie item is visible on the screen:</p>
<pre><code class="lang-javascript">const assertMovieItems = async (moviesTitles = []) =&gt; {
  for (let i = 0; i &lt; moviesTitles.length; i++) {
    const moviesItem = await element(by.text(moviesTitles[i]));
    await expect(moviesItem).toBeVisible();
  }
};

// next: create the test suite
</code></pre>
<p>At this point, we&rsquo;re now ready to create the test suite. This should be wrapped within a <code>describe</code> block. In order for each test to have a &ldquo;clean&rdquo; starting point, we use the following lifecycle methods:</p>
<ul><li><code>beforeAll</code>: executed once before this test suite runs. In this case, we call the <code>removeTestMoviesFromLists()</code> function. As you&rsquo;ve seen earlier, this is the equivalent of a startup check sequence where the user logs in and visits various pages and clicks on the various buttons that will be used in the tests. This ensures that the app is in a minimum functional state before it starts running the tests.</li>
<li><code>beforeEach</code>: executed before each test in this test suite runs. In this case, we want to reload React Native. Note that this has the same effect as pressing <kbd>&#8984;</kbd> + <kbd>r</kbd>, <kbd>rr</kbd>, or <kbd>Ctrl</kbd> + <kbd>r</kbd> on your keyboard.</li>
<li><code>afterEach</code>: executed after each test in this test suite runs. In this case, we want to sign the user out, which means that in each of our test, we need to log the user back in. Again, this is a good practice to get into when writing tests: each test has to have the same starting point. This ensures that they can run in any order and still produce the same results:
<pre><code class="lang-javascript">describe("Project Test Suite", () =&gt; {
    beforeAll(async () =&gt; {
      await removeTestMoviesFromLists();
    });

    beforeEach(async () =&gt; {
      await device.reloadReactNative();
    });

    afterEach(async () =&gt; {
      try {
        await signOut();
      } catch (e) {}
    });

    // next: run the individual tests
  });
  </code></pre>
</li>
</ul><p>Now let&rsquo;s walk through the individual tests. These can be defined inside an <code>it</code> block. Each <code>it</code> block starts from clean slate and asserts a specific, well-defined scenario (the ones we&rsquo;ve covered in the previous section). Each test has a predictable output, which is what we need to assert:</p>
<pre><code class="lang-javascript">it("should disallow login with wrong credentials", async () =&gt; {
  const {
    errorMessage,
    usernameInput,
    passwordInput
  } = await loginWithWrongCredentials();

  await expect(errorMessage).toBeVisible();
  await expect(usernameInput).toBeVisible();
  await expect(passwordInput).toBeVisible();
});

it("should login with right credentials", async () =&gt; {
  await loginWithRightCredentials();

  await goToLibrary();

  const watchListBtn = element(by.id("my-watchlist"));
  const favoriteMoviesBtn = element(by.id("my-favorite-movies"));

  await expect(watchListBtn).toBeVisible();
  await expect(favoriteMoviesBtn).toBeVisible();
});

it("should kick user out when sign out is clicked", async () =&gt; {
  await loginWithRightCredentials();
  await goToLibrary();
  await signOut();

  const loginBtn = await element(by.id("navigate-login-btn"));
  await expect(loginBtn).toBeVisible();
});

it("should allow guest in for Browse only", async () =&gt; {
  await continueAsGuest();
  await goToLibrary();

  const watchListBtn = element(by.id("my-watchlist"));
  const favoriteMoviesBtn = element(by.id("my-favorite-movies"));

  await expect(watchListBtn).toBeNotVisible();
  await expect(favoriteMoviesBtn).toBeNotVisible();

  await goToExplore();

  const moviesSwipingView = element(by.id("movies-swiping-view"));

  await expect(moviesSwipingView).toBeNotVisible();
});

it("should fetch and render the searches properly", async () =&gt; {
  await loginWithRightCredentials();

  const searches = [
    {
      query: "xmen",
      results: ["X-Men: Apocalypse", "X-Men: Days of Future Past"]
    },
    {
      query: "avengers",
      results: ["Avengers: Endgame", "Avengers: Age of Ultron"]
    },
    { query: "wolverine", results: ["Logan", "The Wolverine"] }
  ];

  for (let i = 0; i &lt; searches.length; i++) {
    const currentSearch = searches[i];

    await searchForMovie(currentSearch.query);
    await assertMovieItems(currentSearch.results);
  }
});

it("should add to favorite", async () =&gt; {
  await loginWithRightCredentials();

  await searchForMovie("avengers");
  await element(by.text("Avengers: Endgame")).tap();

  await clickFavoriteButton();
  await goBack();
  await goToLibrary();
  await goToFavoriteMovies();

  await sleep(3000);

  var movieItemInFavorites = await element(
    by.id("favorite-list").withDescendant(by.text("Avengers: Endgame"))
  );

  await expect(movieItemInFavorites).toBeVisible();
});

it("should add to watchlist", async () =&gt; {
  await loginWithRightCredentials();

  await searchForMovie("crazy rich");
  await element(by.text("Crazy Rich Asians")).tap();

  await clickWatchListButton();

  await goBack();
  await goToLibrary();
  await goToWatchListMovies();

  await sleep(3000);

  const movieItemInFavorites = await element(
    by.id("watch-list").withDescendant(by.text("Crazy Rich Asians"))
  );

  await expect(movieItemInFavorites).toBeVisible();
});

it("should show all lists more is clicked", async () =&gt; {
  await loginWithRightCredentials();

  const trendingDailyMoreBtn = await element(by.id("trending-daily-more"));
  await trendingDailyMoreBtn.tap();

  await goBack();
  await sleep(300);

  const trendingWeeklyMoreBtn = await element(by.id("trending-weekly-more"));
  await trendingWeeklyMoreBtn.tap();

  await goBack();
  await sleep(300);

  const popularMoreBtn = await element(by.id("popular-more"));
  await popularMoreBtn.tap();

  await goBack();
  await sleep(300);

  const browseSectionsView = await element(by.id("browse-sections-view"));
  await browseSectionsView.scrollTo("bottom");

  const topRatedMoreBtn = await element(by.id("top-rated-more"));
  await topRatedMoreBtn.tap();
});
</code></pre>
<p>From the code above, you can see that the workflow for each test can be summarized in four steps:</p>
<ol><li><strong>Initialize the state</strong>. This is where we log in the user so each test have the same starting point.</li>
<li><strong>Select the UI component</strong>. This is where we use <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.Matchers.md">matchers</a> to target specific UI components.</li>
<li><strong>Trigger the action</strong>. This is where we <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.ActionsOnElement.md">trigger the action</a> on the UI component that we selected.</li>
<li><strong>Assert that the expected output exists or doesn&rsquo;t exist</strong>. This is where we use the <code>expect()</code> <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.Expect.md">method</a> to test whether the action has triggered another UI component to be shown or hidden from the screen. If the assertion returns <code>true</code>, the test passed.</li>
</ol><p><em>Note: because of the constant changing nature of the app, the movie items that we&rsquo;re asserting can change very frequently. If you&rsquo;re reading this some time after this piece was published, be sure to manually verify first if specific items are visible in the screen. This helps avoid the test from failing unnecessarily and will save you headaches in getting the demo to work.</em></p>
<h3 id="matchers">Matchers</h3>
<p>You can match or select any UI element by ID, text, label, parent, child (at any level), or traits. Here are a couple of examples:</p>
<pre><code class="lang-javascript">const usernameInput = await element(by.id("username-input"));
</code></pre>
<pre><code class="lang-javascript">const errorMessage = await element(by.text("Invalid username and/or password"));
</code></pre>
<h3 id="actions-to-be-performed">Actions To Be Performed</h3>
<p>Detox can perform a huge set of actions on UI elements: <code>tap</code>, <code>longPress</code>, <code>multiTap</code>, <code>tapAtPoint</code>, <code>swipe</code>, <code>typeText</code>, <code>clearText</code>, <code>scroll</code>, <code>scrollTo</code>, <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.ActionsOnElement.md#methods">and others</a>.</p>
<p>Here are a few examples:</p>
<pre><code class="lang-javascript">await usernameInput.tap();

await usernameInput.typeText(username);

await passwordInput.clearText();

const browseSectionsView = await element(by.id("browse-sections-view"));

await browseSectionsView.scrollTo("bottom");
</code></pre>
<h3 id="assertions-to-test">Assertions to Test</h3>
<p>Detox has a <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.Expect.md#methods">set of assertions</a> that can be performed against matched UI elements: <code>toBeVisible</code>, <code>toNotBeVisible</code>, <code>toExist</code>, <code>toNotExist</code>, <code>toHaveText</code>, <code>toHaveLabel</code>, <code>toHaveId</code>, <code>toHaveValue</code>. Here are couple of examples:</p>
<pre><code class="lang-javascript">const assertMovieItems = async (moviesTitles = []) =&gt; {
  for (let i = 0; i &lt; moviesTitles.length; i++) {
    const moviesItem = await element(by.text(moviesTitles[i]));
    await expect(moviesItem).toBeVisible();
  }
};

await assertMovieItems(["Avengers: Endgame", "Avengers: Age of Ultron"]);
</code></pre>
<pre><code class="lang-javascript">const watchListBtn = element(by.id("my-watchlist"));
await expect(watchListBtn).toBeNotVisible();
</code></pre>
<h2 id="challenges-and-recipes">Challenges and Recipes</h2>
<h3 id="endless-looping-animations-or-timers">Endless Looping Animations or Timers</h3>
<p>One of the issues I have faced is that Detox halts if there is a timer looping or animation that never ends. I had to do the following to debug such issues:</p>
<ol><li>Search and debug parts in the app tree and imports by modifying and eliminating them.</li>
<li>Run the test suite again to check whether the issue persists.</li>
<li>After that and most of the time, the issue is an animation that starts itself right after it finishes. So I imported <code>react-native-config</code>, which is a very handy tool to set some environment variables for toggling some behaviors or features depending on the environment. In my case, it was adding <code>isTesting=true</code> in the <code>.env</code> file, checking for it in the codebase and disabling the animation loop or making the duration a lot less, so it speeds up the test suite.</li>
</ol><p>As you can see, it&rsquo;s mostly a matter of playing around with the animation settings in your app. For more information on troubleshooting Detox, you can check out the following documentation:</p>
<ul><li><a href="https://github.com/wix/Detox/blob/master/docs/Troubleshooting.Installation.md">Troubleshooting Installation</a></li>
<li><a href="https://github.com/wix/Detox/blob/master/docs/Troubleshooting.Synchronization.md">Troubleshooting Synchronization</a></li>
<li><a href="https://github.com/wix/Detox/blob/master/docs/Troubleshooting.RunningTests.md">Troubleshooting Failing Tests</a></li>
<li><a href="https://github.com/wix/Detox/blob/master/docs/Troubleshooting.Flakiness.md">Troubleshooting Flakiness</a></li>
</ul><h3 id="adding-testid-to-the-proper-ui-element">Adding TestID to the Proper UI Element</h3>
<p>Another challenge is digging down the component to pass the <code>testID</code> to, as Detox doesn&rsquo;t support it for custom components. Sometimes you&rsquo;d need to wrap the component with a built-in component&mdash;such as the <code>View</code> component&mdash;in order to match and then interact with it. This is especially true if the code of inner built-in component is an imported library inside the <code>node_modules</code> folder.</p>
<h3 id="compose-testid-with-contextual-data">Compose TestID with Contextual Data</h3>
<p>Another scenario that I had to handle is components that are being rendered in multiple places with different event handlers and titles. So, I had to create a composite <code>testID</code> with the title, lowered case and hyphened, and the <code>testID</code> identifier for the component.</p>
<p>For example, the <strong>more</strong> button of all browse sections: as it&rsquo;s the same component being rendered for each one of them:</p>
<pre><code class="lang-javascript"> const testID = `${(this.props.title||'').toLowerCase().replace(/\s/g, '-')}-more`

 return (
  ...
    &lt;AppButton
       onlyText
       style={styles.moreButton}
       textStyle={styles.moreButtonText}
       onPress={this.onMorePress}
       testID={testID}
    &gt;
       MORE
    &lt;/AppButton&gt;
 }
</code></pre>
<p>Sometimes, it&rsquo;s not a single prop, but rather children, so you&rsquo;d end up filtering them and mapping them to get the text node and its value.</p>
<h3 id="narrowing-down-selectors">Narrowing Down Selectors</h3>
<p>As some navigators tend to keep the previous screens in the tree, Detox would find two items with the same identifier (text, ID, label) and throw an exception. Thus, we need to filter out the items from a specific screen to get what we need. You can do that by using the <code>withAncestor()</code> <a href="https://github.com/wix/Detox/blob/master/docs/APIRef.Matchers.md#match-by-id-and-by-parent-id">matcher</a>, which matches by a specific ancestor ID:</p>
<pre><code class="lang-javascript">const movieItemInWatchList = await element(
  by.text("Crazy Rich Asians").withAncestor(by.id("watch-list"))
);

await movieItemInWatchList.tap();
</code></pre>
<h3 id="let-s-see-the-result-in-a-more-engaging-way">Let&rsquo;s See the Result in a More Engaging Way</h3>
<p>You can check out a screen recording of the tests running below. You should get similar results when you run the tests for the app.</p>
<div style="position: relative; padding-bottom: 56.25%; overflow: hidden; margin: 32px 0;">
	<iframe style="width: 100%; height: 100%; position: absolute; top: 0; left: 0;" src="https://www.youtube.com/embed/LgL7ftmTV6A?rel=0" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen><br></iframe>
</div>
<p><em>To simulate text typing, the <strong>keyboard</strong> has to appear when an input is selected. To enable that, go to <strong>Simulator &gt; Keyboard &gt; Toggle Software Keyboard</strong>. You should do this step before start running the tests.</em></p>
<h2 id="conclusion">Conclusion</h2>
<p>In this tutorial, you learned how to use Detox to implement end-to-end testing in your React Native app.</p>
<p>Specifically, you learned how to add the Detox configuration for running the tests on iOS, write selectors for interacting with the UI components, and asserting that specific content exists in screen after interacting with the UI. Lastly, you learned some of the most common challenges that you might encounter and how to solve them.</p>
<p>We&rsquo;ve only tested for iOS in this tutorial, but you should be able to run the tests on Android as well. Do note that you may have to downgrade your app to a lower version of React Native and Detox in order for it to work on Android. This is because iOS support is better in Detox.</p>
<p>You can view the source code on this <a href="https://github.com/ahmedam55/movie-swiper-detox-testing">GitHub repo</a>.</p></body></html>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/amahmoud/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/11/1572845455mahmoud-150x150.jpg" width="96" height="96" alt="Ahmed Mahmoud" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/amahmoud/">
                Ahmed Mahmoud              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/ahmed_am55"><i class="fab fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/ahmedam55"><i class="fab fa-github"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3"></div>
      </div>
            </div>
    </div>
        </div>
          </div>
              <div class="article-ads">
              <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <sp-heading content="Sponsors"></sp-heading>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-765"><div class="proper-ad-unit">
  <div id="proper-ad-sitepoint_sponsor_1">
    <script>
        propertag.cmd.push(function() { 
          proper_display('sitepoint_sponsor_1');
        }); 
    </script>
  </div>
</div></div></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-763"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_side_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_1'); }); </script> 

</div>
</div></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html " id="maestro-728"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_side_2"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_2'); }); </script> </div>
</div></div><div class="widget maestro maestro-content-type-html " id="maestro-785"><div class="proper-ad-unit Sticky">

    <div id="proper-ad-sitepoint_side_3"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_3'); }); </script> </div>

</div></div>        <ads-weighted widget='21' data='{"NL":[{"id":"584","weight":"50","randMax":50},{"id":"585","weight":"50","randMax":100}]}' fallback='' url='detox-react-native-testing-automation' channelSlug='javascript'></ads-weighted></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
            </div>
          </div>

    <div class="u-accordion-end"></div>

    <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
      <div class="u-showseriesx l-w-100 l-fg1 l-mh3--2col l-mh0--4col">

        <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span></div>
                <div id="commentsSection" class="l-pa3 t-bg-white">
                  </div>
      </div>
    </div>

    
    <script>
      var data = 'javascript';
      if (localStorage && localStorage.SP_categories) {
        data = JSON.parse(localStorage.SP_categories).toString();
        data = data ? data.replace('-', '') : 'javascript'
      }

      oSpP && oSpP.push('channel', data);
    </script>
    </div>

    <script>
    window.dataLayer = window.dataLayer || []
    window.dataLayer.push({
      post_id: 174094,
      title: "React Native End-to-end Testing and Automation with Detox",
      category: "JavaScript",
      tags: ["automation","Detox","end-to-end testing","React native","Testing"],
      authors: ["Ahmed Mahmoud"],
      permalink: "https:\/\/www.sitepoint.com\/detox-react-native-testing-automation\/",
      published: "20191106",
      sponsored: false    })
  </script>

    <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite classic"  data-alm-id="" data-canonical-url="https://www.sitepoint.com/detox-react-native-testing-automation/" data-slug="detox-react-native-testing-automation" data-post-id="174094"  data-localized="ajax_load_more_vars"><div aria-live="polite" class="alm-listing alm-ajax" data-container-type="div" data-repeater="default" data-post-type="post" data-category="javascript,react" data-post-not-in="174094" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-2000" data-max-pages="0" data-pause-override="true" data-pause="true" data-button-label="Older Posts" data-transition="fade" data-transition-container-classes=" next-article l-o-h" data-images-loaded="true"></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div>  </div>
    <div class="widget maestro maestro-content-type-html " id="maestro-775"><script type="text/html" class="ModalOnce" data-activate-delay="10" data-tracking="free-book" data-min-height="1" data-min-width="1">
  <div id="free-book-modal" class="reveal-modal medium l-b-n l-br" data-reveal aria-labelledby="Free Book" aria-hidden="true" role="dialog">
    <free-book-content book_cover="https://d2sis3lil8ndrq.cloudfront.net/books/4c7f6303-60e8-45dc-a95b-aae08a4f32a3_medium.png" heading="Free Book. All Yours." book_title="JavaScript Best Practice">
      <p class="f-small l-mb3">Write powerful, clean and maintainable JavaScript with clear, practical lessons in application architecture, package management, tools, shorthands, callbacks, classes, flow control and much more.</p>
      <p class="f-small l-mb0">Worth $11.95 on Amazon. Yours FREE!</p>
    </free-book-content>
    <a class="close-reveal-modal" aria-label="Close">&#215;</a>
    <free-book-form slug="js-best-practice-reader" />
  </div>
</script></div>    <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff we do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.typeform.com/to/fNY7XG">Corporate memberships</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.tapfiliate.com/">Become an affiliate</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.typeform.com/to/HtAXVN">Publish your book with us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.typeform.com/to/DMmYfn">Write an article for us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2019 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
        <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-746"><div class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_main_1'); }); </script> </div>
</div></div><script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-6e8feb0d357d51d669d194de6aae4530.js?ver=4.9.8'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/bundle-a0cb1b525ae3fe5bf6a6034c7d53046c.js'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/article-b639cd02f93f327e4cefa0157d9c06b3.js'></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","alm_nonce":"8d71b8b1fe","pluginurl":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/ajax-load-more","scrolltop":"false","speed":"250","results_text":"Displaying page {num} of {total}.","no_results_text":"No results found."};
var ajax_load_more_vars = {"id":"ajax-load-more"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.1.2'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 40/60 objects using memcached
Page Caching using memcached (Requested URI contains query) 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2019-11-06 10:47:23 by W3 Total Cache
-->