Zenframework 2 help trying to create zftools with PHAR

hi everyone.

i am not sure if this is the correct place to put this but hope that somebody with similar experince in this area will lend me a hand.

i am trying to get to grips with zend framwork 2 and want to install the ZFtools onto my computer. i have tried following the example of octramus


i am trying to download ZFTool for zendframework 2 as a PHAR into my system-i basically want to be able to use the ZF tool from anywhere in my command lines to create projects.

i was able to to do the following:

 git clone git://github.com/zendframework/ZFTool.git

this gave me the following message;

Cloning into 'ZFTool'...

i then did this:

cd ZFTools

that command took me to the folder for ZF tools i.e:

 Andreea@Andreea-HP ~/ZFTool

however i then ran into problems when i tried to install composer with it ( please note that composer is actually already installed on my system).

$ curl -s https://getcomposer.org/installer | php
-bash: curl: command not found

i even tried this:

Error: to compile the PHAR file you need to execute composer install inside the         ZFTool module          

i would really appreciate any help or advice.

please note that i have already installed composer on my system and had previously installed the ZFtool for Framework 1 (so, i was wondering if any of these previously installed tools might be causing problems)

warm regards