Zend Instalation - Making library available

Hello all,

Windows Vista 64
WAMP 2.0i
Apache Version : 2.2.11
PHP Version : 5.3.0

I really have seen and re-seen the include_path and the php.ini file, I don’t know why this doesn’t work.

I intend to do a simple zf show version command, but I always getting an error telling that my include_path is wrong.

I have this: the path as been copy pasted. On that path I have a Zend folder with all zend stuff inside.

I have restarted the servers, I don’t know how many times.


;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"
;
; Windows: "\\path1;\\path2"
;include_path = ".;c:\\php\\includes"

;Path para Zend Library
include_path = ".;C:\\wamp\\bin\\php\\php5.3.0\\includes\\library"

I have rechecked again, the path, copy pasted, and it’s ok.

What am I missing here?

Thanks,
Márcio:sick:

What errors are you getting and when?

when I do “zf show version” from the command line, I get:

***ZEND ERROR
In order to run the zf command, you need to ensure that Zend Framework is inside your include_path (…) etc etc…

<Update>
When I go to phpinfo() I can see this on the info.

include_path .;c:\wamp\bin\php\php5.3.0\includes\library .;c:\wamp\bin\php\php5.3.0\includes\library

I have copy paste this path (without the . and the ; on the beginning, and I have entered a directory so, the path is ok.
Inside library, I have a folder, called zend. Nothing more.
Inside that folder, I have several folders and files.

I have NOT installed any project.
I have restarted the PC.
I have Xdebug installed.
I have no Virtual Hosts configured
Php and Apache error logs shows nothing relevant.
Apache: Notices for the startup;
Php: empty.

The apache on WAMP 2.0i doesn’t come with mod_rewrite enabled. So I ask, could it be something that should be enabled and it isn’t?
</update>

Thanks,
Márcio

Zend is 1.10.3 btw.

Solved. I followed the instructions on the ZEND ERROR message, and, with no reference on any book I know, and any tutorial I have met on the internet world, I’ve just follow what this black box with white letters told me.

Created a new Environment Variable.

Variable Name:
ZEND_TOOL_INCLUDE_PATH

Variable Value:
c:\wamp\bin\php\php5.3.0\includes\library

It worked.

Regards,
Márcio