XAMPP is not starting Apache server anymore

Hi There

I installed XAMPP a few weeks ago and had a php website working on my localhost – all worked fine no probs. To do this I had to stop my IIS server as this was also using port:80 which is what XAMPP is set to use as default. Now for some reason when I started IIS again a few days ago to do some asp development work and then stopped it again, the apache server would not start even though I’ve definitely stopped IIS. I have tried uninstalling and re-installing XAMPP, but it still won’t start. I tried running the apache_start.bat from the command line and I got the following error message:

“An attempt was made to access a socket in a way forbidden by its
access permissions”: make_sock: unable to listen for connections on address no listening sockets available, shutting down
Apache could not be started

If I try and start Apache from the XAMPP control panel it just says Apache:stopped and the message in the bottom window is ERROR: Apache service not started [-1]

I was just wondering if you had come across this problem before? If yes, how did you resolve it? Someone mentioned changing the port, but being a bit new to apache and XAMPP I’m not really sure what would need to change in what config files. Any ideas or suggestions would be greatly appreciated.


Run “netstat -an” at the command prompt. See if something has already bound port 80.

Another option would be to switch the apache instance to listen to a port other than 80, allowing you to run both side-by-side.

I’ll ask why Apache is trying to listen to (IMHO, it should be localhost’s Dan is probably correct and I would advise against changing Apache’s port (as suggested by wwb_99) but that’s a personal preference from one who does not develop for M$ (.net, .asp, .yadda.yadda) and so doesn’t have to worry about using IIS.