Wordpress HELP: Critical Canonical Issue!

Hello Sitepoint Programmers

I think this section will have people who are experienced in Wordpress and who could solve my probe!

Here’s the issue:

A wordpress site I got to work has canonical issue. So I tried below things to find solution:

  1. In the setting->general, the URL path in both WordPress address and Site address was set to non www version of the website
  2. Tried to upload .htaccess file in all folders of Root Folder by log in to host server.
  3. Cleared cache numerous times when I did the efforts explained in the above two steps.
  4. Used canonical plugin)download version).
  5. Submitted the issue in wordpress forum 3days ago.

But I couldn’t solve this issue!

The site runs on both paths: www and non www!
Later I had found that there is an inbuilt canonical.php file in the root folder, so deleted the .htaccess files that was installed in the second attempt(as in point 2). I think here should be some probe for this solution but I don’t know how to workout the code, so I couldn’t find a solution!

So guys please help me find solution to solve canonical issue of this wordpress website.

FYI: here is the website with canonical probe:

homefitnessfreak (.com is the domain extension, to check website info please try with www and now www with .com extension)

The website is hosted on Godaddy.There is All in One SEO pack plugin with canonical option enabled.

Look forward hearing your suggestions
Thanks in advance!