Wordpress + Cloudflare = Website times out way too often. Help


I’ve installed Cloudflare for my Wordpress blog (kpopfever.com) about a week ago and I’m experiencing some strange issues. Btw, all the problems started happening after installing Cloudflare, the website was working without problems before the installation. I already contacted CF but they don’t have any answers and it generally takes about 3 days for them to get back to you, so I come to Sitepoint where I always seem to get the answers to my problems.

First, let me explain what went okay;

  1. The website loads faster by half a second on average according to pingdom tools.

  2. Google Page Speed also upped my website’s performance rating from 86 to 90.

  3. CPU load decreased. I used to experience crazy CPU load spikes due to attacks a couple of times a day, rendering my website inoperable for half an hour to an hour a day, after CF the CPU load spikes just as disappeared.

Now let me explain what has been bad;

  1. Wordpress Dashboard is slow. Adding custom page rules to turn off everything on kpopfever.com/wp-admin/* did not fix this issue. The fix was suggested by Cloudflare tech. (This problem is probably related to problem #3)

  2. Posting new articles works okay, but whenever updating an existing post the browser status bar reads “Uploading 100%…” and it either times out or it takes about a minute to finish the update. (This is probably related to problem #3 too)

  3. Can’t access my website from multiple browsers. I always have Wordpress Dashboard open on one web browser and I have another web browser open (with a different user profile) and I have new articles open. The reason that I do this is because I have two Twit and FB accounts where I post new articles. Having two windows open allows me to sign in to two different Twit and FB accounts. So anyways, if I surf my website on one web browser it’s usually problem free. However, once I click away to the other browser and click on any other articles on my website I see the browser status bar read, ‘Sending request’ or ‘Uploading 100%…’ and it either times out or it loads after a long while. It’s important to note that I’m not having any of these issues with other websites. I don’t have problems surfing yahoo, cnn, nytimes, espn, or even secure websites such as my bank website, credit card, or paypal, so I seriously doubt it’s my network setting. I tried changing router and modem. Tried wireless and wired connections, none fixed the issue. I should also mention my web hosting company, tmzvps also uses CF and I have trouble accessing their website too. I experience the same problem on tmz that I do on my website. Once I click away from tmz (for example) by opening a new tab browsing another website, when I go back to tmz the website does the same ‘Sending request’ and it either times out or it loads eventually. Could there be some sort of setting from my network that’s interfering with CF enabled websites? I tried different browsers Chrome, Firefox, Safari, IE, and they all basically take their sweet time loading whenever you visit another website or move from one browser to the other.

I’m sorry for the long post, but my question needs a long explanation. Btw, could you please try surfing my website using multiple browsers and see if you experience the same problem. You won’t have the WP dash open so it won’t be the same test, but it’s an approximation. Thanks for your time and please help.

P.S. - I uninstalled Dos Deflate from my VPS and all CF IPs were whitelisted. I also tried deleting browsing data. Added vps on CF DNS setting to bypass CF, suggested by CF techs.

You should try www.yottaa.com, a similar service but actually works. CloudFlare has a general bad reputation of not working and not reliable, for example, see http://blog.appboy.com/2012/02/why-were-canceling-our-cloudflare-pro-account-and-leaving-the-service/.