Wordpress blog crash

After having added WP blog to my site, it worked nicely for 2 weeks, and my blogs were indexed on Google minutes after I uploaded them.
Disaster has struck, and after I tried to adjust the settings on Tuesday, new blogs don’t get indexed any more, and when I click on any blog title, it gets me to a page on my website, not to the blog.
To make things worse, I can log into the WP forum, but my posts appear as “anonymus”, and get closed immediately so nobody can reply. :frowning:
Is there a way to reset to factory default settings?

Are you using wordpress.org (ie. hosting your wordpress blog yourself), or wordpress.com?

What do you mean by “disaster has struck”?
Which WP forum are you talking about?

What is your the URL of your site? PM me if you’d prefer.

We need a little more information to go on…

I am hosting the blog myself on: http://boiler-breakdown-repair-london.co.uk/wp/

Until two days ago, my blogs were indexed on Google in a matter of minutes; now they don’t get indexed at all. The problem seems to be in the permalinks somehow as I also noticed that when I click on any of the blog titles, it doesn’t go to that blog, but always to the same page on my website. The page is unrelated to the blogs, other than being part of the same website.

Have you tried changing the permalinks to be associated with customised links for each post? At the moment they are all pointing to your website page

Also make sure that you didn’t deactivate the option to get indexed/not indexed. True, it is just a little option at the top of the general settings… but of course it makes a lot of difference! :lol:

I have looked at that a couple of times, but every article refers to another article without actually giving me the format to use when I want to have the “title” on the general/front page to point to a single page post.
Where do I find the instructions to alter that and/or example of the format/structure to use?

Addition to last post:
I have looked at the permalink settings is what I meant to say.

I don’t quite understand what you want to say with this.

When I go to my blog section http://boiler-breakdown-repair-london.co.uk/wp/, it shows all the posts with the blog-title. When I then click on the titles, they all link to the homepage in stead of that blog post. I must have changed something accidentally in the settings, because initially they would link to single pages that showed the blog that was in the title. In other words: if I clicked on the title e.g. IKON 23T COMBI REPAIR, it would change to the page of that post in stead of the homepage.

Change the permalink settings to something else, and then back again to what you want it to be.
Wordpress should recreate the .htaccess file when you change the setting. That way maybe the error will be fixed.

When I change it on the dashboard/settings/permalink to another choice than “default”, it can’t the main blog page isn’t found at all. I changed it back, and the links pointed to the home page again.

Can you post the content of the .htaccess file?


IndexIgnore .htaccess /.?? *~ *# /HEADER /README /_vti

<Limit GET POST>
order deny,allow
deny from all
allow from all
order deny,allow
deny from all
AuthName boiler-breakdown-repair-london.co.uk
AuthUserFile xxxxxxxxxxxx
AuthGroupFile xxxxxxxxxxxxxx

BEGIN WordPress

END WordPress

I deleted some of the data (no idea if it is sensitive info, but better be sure than sorry).

So no WP rewrite rules? Well, I guess that’s normal when you use the default setting. I really have no idea why WP refuses to display the single post page.

Do you think it will work better if I replace the htaccess file with the version you made it to?

Do you have any suggestions in that respect?
Are there any “a-z of rewrite rules”? I am moderately experienced with html at best, and a complete novice to the WP-blog world. I have looked at reference files and explanations, but the way it is set up with links to links to links etc, makes it very confusing for me.

There is no “index/not indexed” option in general settings on the dashboard in my version ( 3.3 ), and I didn’t see it in any of the other sections of settings either.

Sorry. My mistake for not being quite correct. I don’t know if this exists in version 3.3 (can’t upgrade right now because my server MySQL version doesn’t allow it and need to move to a new one) but I’d be surprised if it didn’t.

This particular option is under “Privacy Settings” and it allows you to specify if you want bots to see you or not.

I found it under privacy settings, and I am sure it has not been changed at any point; it always was on allow index.


No, no suggestions. It makes sense that there are no rewrite rules if you use WP’s default setting. But it means the problem is not the .htaccess file.

Ah well, it seems that I will have to find some extensive WP manuals that are easier to digest than the WP help files, and learn the whole malarkey. By the time I have figured out how to keep my site and blog at #1, I may even be able to follow my dream and leave London and earn a living as a full time webdesigner/seo pro.