Why doesn't phpMyAdmin recognize line breaks?

In phpMyAdmin, I have:

  • Improved cell efficiency results in less energy lost as heat and greater power output
  • Battery can be charged well in advance of use with no loss in performance
  • Reduced maintenance
  • Longer lifespan (up to 10 times!) reduces battery costs

Specifications:

Length: 138.5mm
Width: 46.0mm
Height: 25.0mm
Weight: 295g
Discharge: 175A continuous, 200A-225A burst
Passes UN T1-T8 testing

But the browser shows:

  • Improved cell efficiency results in less energy lost as heat and greater power output * Battery can be charged well in advance of use with no loss in performance * Reduced maintenance * Longer lifespan (up to 10 times!) reduces battery costs Specifications: Length: 138.5mm Width: 46.0mm Height: 25.0mm Weight: 295g Discharge: 175A continuous, 200A-225A burst Passes UN T1-T8 testing

The text was copied from Window’s Notepad right into the phpMyAdmin window. Table collation is utf8_unicode_ci.

I tried setting the line breaks in phpMA via Enter and Shift+Enter, to no avail.

Any help would be appreciated.

Thanks!
Steve

Browsers don’t render new line characters in html. You can use the <br> tag to render a line break.

right click > view html source and you will see the new lines are there.

You are right! It worked. I thought the <br> would show up on the browser screen, so I had rejected putting them in before.

Thanks again,
Steve

echo nl2br($string);

http://www.php.net/manual/en/function.nl2br.php

What a great idea! Unfortunately, there are no
breaks in the text field.

Thanks,
Steve

Just to make sure you know, I’ve met people who don’t:

means line break in most cases. Not literally “backslash n.”

Thanks. I am currently going through the fields and adding <br /> to the appropriate places.