Which version of Ruby should I be using?

I have vanilla Mac OS X Leopard which comes with 1.8.6.

I am new to RoR so will be following tutorials on the net. Am I likely to find problems following them when using later versions of Ruby?

I am currently looking at this one which mentions 1.8.6 and 1.8.7 - http://www.railstutorial.org/book

I’m relatively new to RoR so I have problems even when the versions match. It seems to me the language changes so often, and not always in trivial ways, that you should use the versions specified in the tutorials to make sure the problems are “learning” problems and not version incompatability problems.

I know installations can be a real pain, but it is possible to install multiple versions.

Actually the versions of Ruby shouldn’t cause too many problems at all. I’m using 1.8.7 on my servers, 1.8.6 on my work machine (because getting the rights to upgrade is too much of a hassle) and I’ve been trying out 1.9 on my home machine for a few months. I’ve only had two issues with 1.9, both to do with old third party plugins and not Rails.

Rails has changed quite a bit over the years. A tutorial for 1.2 will be almost entirely different than a tutorial for 2.3, so its a good idea to make sure those match. You can install multiple version of Rails so it’s not much of an issue.

It shouldn’t matter but for minimum stress Use 1.8.6 for now, most of the tutorials out there will be written for it. 1.8.7 was a backport of 1.9 so you might as well just go with 1.9.1 instead of using it.

1.9.1 is the newest version and everyone is moving to it (Rails 2.3 and 3.0 beta support it), so it might not be a bad idea to get on that right off the bat as well.

Its really up to you.