Weird printer problem

We have an Epson XP-960 printer, which we’ve had for a couple of years, and which has always worked fine with various versions of Ubuntu, using the Linux drivers downloaded from Epson.

A few weeks ago, I created a new user account on the desktop computer (running Ubuntu 19.04) and the printer will only print single copies of anything on that account. It will print multi-page documents OK, but only a single copy of any one document, irrespective of how many copies I request.

On my user account on the same computer, it prints multiple copies no problem. upsidedown

I’ve tried reinstalling the drivers (from the new account), but no change.

Does anyone have any idea how to fix this?

1 Like

I’ve never used Ubuntu but could there be some sort of permissions issue?

Is it all applications, or just one? I could find an issue about OpenOffice, but didn’t know what you were trying to print from.

I can’t see how. And both accounts have admin. privileges.

Good question. It certainly happens in LibreOffice, which is pretty much the only thing I’m using on that account. I can’t remember if I’ve tried to print from any other application there or not. I’ll test that and report back.

I had the same bug on a Debian linux machine years ago. Debugged for days, and never found the culprit :frowning:

I wrote it off as “one of those things” and just pressed print multiple times when I wanted something printed, which was pretty rare anyway.

1 Like

I’ve just been testing to see if it’s only LibreOffice which is affected, and discovered I have a much bigger problem. frown

From my own account, I can print correctly from LibreOffice - multiple copies of any document.

From the second account on the same computer, I can print from LibreOffice, but only single copies of anything.

However, I’ve now discovered I can’t print .txt files from the text editor on either account (although I can open and print them from LibreOffice), and I can’t print .pdf, .png or .jpg files on either account, using any application. frown The information is sent to the printer, the “printing X” message shows on the desktop - then I get a “printing cancelled” message.

I can’t remember when I last printed any of the above, so I can’t pinpoint when that issue occurred. It can only have arisen in the last few weeks (so not because of an OS upgrade).