Web crawl errors

I am getting a huge number of crawl errors from Google Webmaster tools, for example,

Error: http://www.berkshiredentist.com/yoast-ga/outbound-article/www.usa.philips.com

[Favorite Links | Berkshire Dentist](http://www.berkshiredentist.com/favorite-links/)
[Favorite Links | Berkshire Dentist](http://berkshiredentist.com/?page_id=61)
[Favorite Links | Berkshire Dentist](http://berkshiredentist.com/favorite-links/)

Furthermore, my favorite link checker Link Sleuth, only crawls the first page.

The site seems to have generated errors from the beginning.

Here is my .htaccess file:

#suPHP_ConfigPath /home/berkshi1
DirectoryIndex index.php

#to redirect urls from old to new urls
Redirect 301 /pages/services.htm http://berkshiredentist.com/patient-services/
Redirect 301 /pages/home.htm http://berkshiredentist.com/
Redirect 301 /pages/library.htm http://berkshiredentist.com/patient-library/
Redirect 301 /pages/contact.htm http://berkshiredentist.com/contact-us/
Redirect 301 /pages/about.htm http://berkshiredentist.com/about-us/
Redirect 301 /pages/links.htm http://berkshiredentist.com/61-2/
Redirect 301 /pages/gallery.htm http://berkshiredentist.com/photo-gallery/
Redirect 301 /pages/forms.htm http://berkshiredentist.com/new-patient-forms/
Redirect 301 /pages/patient_library/veneers.htm http://berkshiredentist.com/porcelain-veneers/
Redirect 301 /pages/patient_library/gumdisease.htm http://berkshiredentist.com/gum-disease-serious-but-treatable/
Redirect 301 /pages/patient_library/diagnodent.htm http://berkshiredentist.com/diagnodent-laser-reflection-finds-imperfection-aids-in-correction/
Redirect 301 /pages/patient_library/airabrasion.htm http://berkshiredentist.com/patient-library/
Redirect 301 /pages/patient_library/implants.htm http://berkshiredentist.com/implants-permanent-secure-tooth-replacements/
Redirect 301 /pages/patient_library/digitalxray.htm http://berkshiredentist.com/digital-x-rays/
Redirect 301 /pages/special.htm http://berkshiredentist.com/
Redirect 301 /pages/services.htm http://berkshiredentist.com/
Redirect 301 /pages/faqs.htm http://berkshiredentist.com/

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress

What am I missing?

The links in your source looks fine (although your source code does look a bit crowded). Which type of crawl errors are you getting?

Jesus wept … and that was before he looked at the source code of a Wordpress page.

For some reason, there’s a bunch of Javascript that seems to be screwing up your outbound links:

<a title="About Cosmetic Dentistry" href="http://www.aboutcosmeticdentistry.com/" onclick="javascript:_gaq.push(['_trackPageview','/yoast-ga/outbound-article/www.aboutcosmeticdentistry.com']);">About Cosmetic Dentistry</a>

It looks like bots are trying to follow the link in the script snippet as well as, or instead of, the actual link destination. As that link is only there to track what people have clicked on, and doesn’t actually resolve to the correct page but instead to a 404 error, it looks like that’s why Googlebot is having trouble.

Very interesting about the Javascript code. It is not in the content HTML.

<strong><a title="About Cosmetic Dentistry" href="http://www.aboutcosmeticdentistry.com/">About Cosmetic Dentistry</a></strong> - Learn about procedures, view photos and find out how you can beautify your smile with cosmetic dentistry.

Turns out the Wordpress Google Analytics program was set to track outbound links. I disabled that, and now the Javascript is gone in the source view.

Many thanks for pointing me in the right direction.

How do you find the Wordpress Google Analytics program setting to disable it? I am having the same problem.

Frankly, it’s been so long, I don’t remember. I googled on

google analytics event tracking outbound links
and found a whole bunch of articles including this one.

Hope that helps.

A Ha! I remember now. The setting is in the WordPress plugin “Google Analytics for WordPress” configuration. See attached screen shot.

We had an issue that also added a redirect between where the user clicked and the end destination, caused by some google tracking stuff. The client noticed it when clicking on links lead to blank pages (it seems the intermediate google server was down for an hour or so and the client (understandably) freaked out).

BTW wonder if you can remove this in your htaccess file:
<IfModule mod_rewrite.c>

If you know you have mod_rewrite, get rid of that. It’s a silly-expensive check that I believe happens at every request. For some reason it seems default with some hosting setups as a safety feature, but it’s only meant as safety when you’re first setting up and might not have mod_rewrite.

my be the link is broken. try to fix the link.