Waypoint JS Issue

OK I am just doing a very very basic animation thingy with WayPoint JS.

When I include the latest version 4.0.1, the animation don’t work.

And when I include the version 2.0.5, the animation works.

What’s wrong?


It’s hard to be able to help you figure out what is wrong if you don’t post your code for us to see.

1 Like

OK here is the one which works… Using 2.0.5

This one don’t work. Using 4.0.1

To see code please view source code. All CSS, HTML, JS in same file. Just scroll and beside the blue box you will see the red box animate.

Waypoints CDN

Thank you for help :slight_smile:

1 Like

I think, but I am not sure that in the second version (4.0.1) you use waypoint.js that is depending on jQuery library


While you dont’t init the jQuery library

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.0/jquery.min.js"></script>

Yes I am using JQuery
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>

I didn’t used and also didn’t tried with JQuery 3.1.0 because with JQuery 3.1.0, Stellar JS Parallax didn’t worked. Stellar JS worked with Jquery 2.2.4

OK I have been trying a few things. Try to change

$(this).addClass('animated fadeInLeft');


$(this.element).addClass('animated fadeInLeft');

Wow Donboe, that worked. Thank you :slight_smile:

@littlebirdy. I am happy it is working. Coincidentally enough did I nearly had the same problem last week, only the other way arround. @PaulOB pointed me to that so I thought maybe this would work for you as well.


Haha very nice :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.