WampServer config question


I’m working from “Build Your Own Database Driven Web Site Using PHP & MySQL.” I’ve just installed the WampServer. There is a section that talks about “Post-Installation Set-Up Tasks.” When I enter the specific string (mysqladmin -u root status) into the Command Prompt (I’m working with Windows XP), a command line window opens and I see text racing by much too fast to read. I don’t know it the text is the basic statistics talked about in the book or ???

Is this step necessary for the WampServer installation? Is there another command I should use to stop the rapid scrolling of the text? Or, something else I’m doing wrong?



Hi pixeljoy, welcome to the forums,

I’ve never worked with MySQL from mysqladmin, but I have worked with the command line in MS-DOS, Ruby and Java. I believe what you’re seeing is the “help” information scrolling by. If you can post whatever tail-end of it you can see it would help. If it is that, it usually is because you used the wrong syntax and it shows the different correct syntax options.

In any case, for the MS-DOS command line, there’s the /p switch to “page” the information one screen at a time, where hitting enter goes to the next screen full.

So maybe if you added a /p or -p to your command it might do the same. If you check the mysqladmin documentation for “page switch” or similar you should be able to find the correct syntax for it.


Thanks for the suggestion. When I add “/p” to the string I described in my earlier post, the window prompts me for my password. When I enter it and hit return some text flashes by, my PC beeps, and the window closes. When I use “-p”, I’m asked again for the pass word. After entering the password and hitting the return key the window closes again. No text, no beep, it just goes away.

By the way, without adding either the -p or the /p, the window closes almost immediately so I cannot read the text in the box.

Suggestions? Thanks.


Well, as I said, Im unfamilliar with mysqladmin, but it sounds like an exe file that isn’t meant to be opened that way. Is there a “start.bat” (or similar) file in the same folder as the mysqladmin file?


I’ve tried different things, including opening a “bin” directory in MySQL that contains a number of .exe files. Running any of them always results in the same effect: box opens and closes quickly. Sometimes I see some text fly through the box, more often it is just a black screen.

I’ve reviewed the steps I took to install the WampServer. As far as I can tell, I followed the instructions in the book accurately. (usual story, I know). Unfortunately there are no trouble shooting steps in the Sitepoint book I’m working from. The author assumes a trouble-free install and carry’s on with various activities. I’ve attempted to follow those activities without success.

Any other suggestions Mittingague?

Or, anyone out there with insight into setting up and running WampServer?