Wamp Server & Wordpress


I tried installing the wamp server to start with a local version of a new web design. I followed the steps like here: http://sixrevisions.com/web-development/install-wordpress-on-your-computer-using-wampserver/

Now when I came to the step where I need to install WordPress, so I did. I created a new database in phpMyAdmin and then installed WordPress. I never get the “Success” message like this, I only get the logo at the top:

When I go to the website, It shows me the WordPress Twentyeleven layout, but it says: Nothing found. No posts or pages can be found. I can see the tables in the database I’ve created in phpMyAdmin though.

What went wrong and how can I fix this? Thanks in advance.

You will need to add posts or pages through the admin page.

As far as the technical configuration and setup goes, it sounds like everything is up and running.

Hi, thanks for you reply.
Unfortunatly I can’t even log in. And I’m quite sure I’m using the correct login name and password. It looks like the WordPress installation can’t find the data in the database.
It should have the first blog post and comments, so the “Nothing found” isn’t normal at all.

Just a wild shot, did you edit your wp-config file to match?

I didn’t edit anything. I opened my local website and it created a wp config file for me. I gave it the same name as the database I created in phpMyAdmin, user is root and password left empty…

Ah that’s it. The form enters the values into the database but the wp-config sets CONSTANTS

If you look for a top level file called wp-config-sample.php you’ll see

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define('DB_NAME', 'database_name_here');

/** MySQL database username */
define('DB_USER', 'username_here');

/** MySQL database password */
define('DB_PASSWORD', 'password_here');

/** MySQL hostname */
define('DB_HOST', 'localhost');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

change the values to match what you set them for then save as wp-config.php in the same folder. (don’t just rename the “sample” file, you may want it later for reference)

Well it actually did create a wp-config file locally.
The values are the ones I entered in the install fields. It automatically set a salt key too.

Hmmm. I’ve never had it actually create the file, maybe because I reuse my old one and it doesn’t if there’s one already there?

Maybe one of your files got corrupted somehow? Or you have plugins enabled that are messing things? Or your theme?

I guess I’d try deleting the files (except the wp-config.php file :wink: ) replacing them - using the default theme for now, and see if that helps.

Well since this is a fresh install, I haven’t got any themes or plugins installed yet. It’s just the regular WordPress install, I even downloaded a new zip file for this.
It’s not my first WordPress website, but it is my first install with the Wamp server… The wp-config file was the first file I looked at when the Nothing found message came up.
To be honest, at first I created the wp config file myself, but as this obviously didn’t work, I followed the steps in the tutorial I mentioned before, but this gives me the exact same result. No success message after install either, this is very odd! And when Googling this problem I can’t find anything like it.

Would it help if I turned off the Windows firewall? Or won’t that be a problem?

Or is skype causing problems again??

I’ve searched for solutions:

  • Firewall (can’t figure that one out)
  • Skype (closed the program)
  • PHP memory (don’t know how to change it)

I also have a php document in my wamp/www directory, is this a MySQL error? I don’t think I’ve seen this before the installation of WP.

$link = mysql_connect('hostname','dbuser','dbpassword'); 
if (!$link) { 
	die('Could not connect to MySQL: ' . mysql_error()); 
echo 'Connection OK'; mysql_close($link); 


With Windows firewall, what part are you having issues figuring out? Also, what version of Windows are you running?

Hi Mike,

I’m working on a Windows 7, it’s a PC in a network (work computer) and only the network administrator can turn off the firewall. If that is necessary to connect to the MySQL database, I can ask him to do it for me of course. But he took a few days off and he’ll be back next week on Tuesday…

On the Wampserver forum, someone says it’s working like it should, but the localhost can send an e-mail because there’s no working smtp. No posts (like the “Hello World”) or comments are created.

I can see the site title I entered with the install, so it should work. But I can’t login and I’m 100% sure my password is correct. Can I add a user and pass via phpMyAdmin? Or how can I login to my new WordPress?


Port 3306 is all that needs to be open in the firewall for database access; you don’t have to have the firewall completely disabled.

I am not quite sure I understand what you mean by it working properly but you still cannot log in. Can you clarify what is working now and what is not working now?

Have you checked your php error logs? Maybe something is causing a fatal error

You don’t need to open any ports if the web server and the database are on the same server/computer.

True, I guess I misunderstood when they said the firewall was one of the potential issues. I assumed they had it hosted on a separate machine. If it is on the same machine no worries!

Hey all,

I added an admin user as there were no existing users in my database. This worked like a charm! I can log in to the backend now!
Thanks everyone for your help though.