Visual Studio - Problem Building Install

Ive gotten myself into a tricky situation.

The last two weeks Ive been working on an application for a client, it was an shipment system which was a huge mess, with most of the code/design into a few files.

The first thing I did was refactor the application, so now everything is sorted out over library files, user controls and forms instead of being one big mess of interconnected code.

Then after I implemented the changes that we were supposed to do.

I faced the problem today when I tried to build the install files, it return these two error messages:
Could not create the file ‘C:\Users\****\AppData\Local\Temp\VSI3F28.tmp’ ‘Access is denied.’

Unrecoverable build error

The last time I build the install was around a week ago and then it worked, and I can still build the install if I load the original files, so that makes me pretty certain the problem is not located on the computer/software side.

This just leaves one option, and that is that the problem lies in a part of the application Ive updated the last week.

What I have found out is that it is only the install project and the “run as debug” that fails with this error.

If I try to build the other connected two projects I am successful.

Now for my question:

Have anyone else had this error happen before? And if how did you solve it?

Even if you have not had this happen, if you have any ideas/tips on how I can track and pinpoint where exactly the issue lies would be much appreciated.


Turns out the issue was not completely solved as I believed.

I have managed to build the install files, and I am able to run the debug mode. But it seems from time to time I still get the same error message, so its kind of a lottery every time I try to rebuild if it will be successful or not.

This leads me to believe there is a race condition somewhere in the code.

If anyone have an idea on how I can isolate the issue, please let me know. It would be nice to find out what exactly is causing the problem.


[I]The issue has been solved.

I am not sure what exactly it was that fixed the problem, what I did was go over all the project properties. There I went over all Build and Build Event settings (I was resetting them and then adding them back to what they should be for the build), then resetting the internal settings the application needed.

After I reset the Application Files and Prerequisites under Publish. Finally I cleaned the solution before rebuilding the solution. And this time it worked as it should, no problems at all.

Hopefully this can help anyone else getting into the same problem as well.[/I]