Video Upload

Looks like I might of been editing the wrong php.ini file, the one I’ve been editing is located here C:\wamp\bin\php\php5.3.9\php.ini, I just found this one and have just finished editing it, located here C:\wamp\bin\apache\Apache2.2.21\bin\php.ini, so I tested it with a larger video file and got the following results
‘upload’ =>
‘name’ => string ‘The Beatles - Help (1965).mp4’ (length=29)
‘type’ => string ‘video/mp4’ (length=9)
‘tmp_name’ => string ‘C:\wamp\ mp\phpB7AE.tmp’ (length=23)
‘error’ => int 0
‘size’ => int 19164828
but still no file uploaded and nothing echoed, at least thats some improvement, I guess the problem now, lies with either the move function and/or the target dir. The path of the upload page is, the path of the target dir is . The target path is set to this $target_path = “upload/”; is this incorrect?

The target path looks fine, however just try changing it to $target_path = “”; and see if it just uploads to the html directory. If that fails to work check your CHMOD permissions and make sure you are able to write to the upload folder.

Changing the target path to $target_path = “”; did nothing Codarz360, and you can’t CHMOD a windows directory, and as I can fwrite to the html directory and the upload directory inherits its permissions from there, I don’t think its a permission issue. The page loads very fast, which makes me think it hasn’t had time to move the file, and I still don’t get anything echoed just a blank page, no file name, no error saying it didn’t upload, absolutely nothing. Cheers

Throw in a bunch of echos. One at the very top, one in every branch of your IF’s, so you can see where the program is going.

If nothing STILL shows up, you’ve got a syntax error and display_errors is being stubborn and not showing you it.

Thanx StarLion I’ll give it a try, but I’m beginning to think that I can’t upload to a windows system on the same machine. Even though the array now shows C:\wamp\ emp\filename.tmp, I’ve had the temp directory open on my second monitor while I tried to upload and nothing is being written not even for a split second. Cheers

The first echo, at the top of the page, before the code, works but nothing else is working. Cheers