Vagrant invalid range of IP

root  pop-os  /etc  mkdir vbox
root  pop-os  /etc  cd vbox/
root  pop-os  /etc/vbox  nano networks.conf

* 2001::/64

I used this solution to solve the problem with Vagrant and then I run it again:

 root  pop-os  ../metasploitable3-workspace  curl -O && vagrant up

The error:

The IP address configured for the host-only network is not within the
allowed ranges. Please update the address used to be within the allowed
ranges and run the command again.

  Ranges:,, 2001::/64

Valid ranges can be modified in the /etc/vbox/networks.conf file. For
more information including valid format see:

I also tried the following as I saw somewhere but the same error.

* ::/0

I am following the repo:
to install metasploitable 3 for learning purposes. (why is this difficult I mean).
Packer - Vagrant - VirtualBox are installed.

So… what is in your networks.conf now?

* 2001::/64

But as I said
I tried this:
* ::/0

I tried this:

I tried this:

All giving me the error

So if you put


(which is the proper definition of the three Reserved Private Network spaces as defined in RFC1918 and asserted by IANA)

, save the file, reboot the computer to make sure the thing’s woken back up and reread its conf file, and run the line again, it still gives you the same error?

1 Like

Thank you so much. You saved my day.
Yesterday I tried all but not
I am going to write a good blog about this installation, omg.
Everyone needs good documentation.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.