Using phpdev - localhost not working

I’ve installed phpdev so that I can follow the tutorials in a book about php development with Dreamweaver MX. Everything seemed fine (the phpdev installation was fine) but when I type http://localhost/ into my browser nothing works. I also get an error http error 12029 when I test the url in dreamweaver. I looked in the readme files which said to change c:/windows/hosts file but my virus scanner seems to be using the IP no. for scanning email. Anybody got any ideas where I’ve gone wrong and how to fix it?
many thanks

what OS ? - when you type http://localhost - what error message do you get ? , do you get the same if you type [url=http://www.]http://www. ?

what I mean is do you get an apache generated error or just a normal 404 page not found ? if so is apache running ? - ctrl-alt-delete to see if apache.exe is in your process list & let us know.

I’m using Windows ME - I’m pretty sure I had apache running but will have to check that one. I just get a 404 page in the browser - it’s the same when I use www.127.0.01 or localhost. Does that make things clearer.
many thanks for the help

Right I’ve checked and I did have apache running. When I test the URL in dreamweaver I get the message - Dreamweaver cannot use the prefix you entered to display live data HTTP error 12029. Also when I just put http://localhost into my browser I get no error just that the page cannot be displayed. Any ideas?
Many thanks


You may have already figured this out or done this but if you go to C:\phpdev (wherever the installation is) and run the phpdev_start.bat file then it will open a couple of dos windows, do somet stuff and go back to one window. Thats how you start the web-server. It’ll automatically open a page to allow you to test if the Webservers working, PHP etc.

To shut down the server simply run the phpdev_stop.bat file.

Any more questions then i’ll be happy to answer them.

Phpdev is running fine and when that first starts up - localhost has the initial phpdev page on it. It is only when I start to set my site up in Dreamweaver that it all goes to pot. It just seems to be a problem with Dreamweaver and IE accessing localhost.
many thanks for the help

u have to put your site in the WWW directory coz thats where the localhost in phpdev redirects 2

also, if you want ppl to see it via using your ip as the url then put files in the public directory.

from what I understand from a German site I looked at (if I translated it right) it is a problem with my anti-virus software using http://localhost/ is there another IP no I can use like having two localhosts or something?
many thanks

You could just set Apache to listen on a different port, providing your anti-virus isn’t listening on all of them.

How do I do that? pretty much a newbie to this sort of stuff so step by step instruction would be a bonus!
many thanks

I’m not exactly familiar with the phpdev bundle, but somewhere in it’s installation directories there should be a httpd.conf file. This is the main configuration file for Apache. If you open that, and go and like do a search or find, and type in: “Listen”, you should come to a part which sets what port Apache is to listen to. Right now it’s on the default 80, so set it to something like 8080 say. Now restart Apache.

Now you access localhost as:
(Note: Before the port 80 was implied.)

thanks I’ll try that

A working solution:

I was looking for a solution for this problem that I experienced myself.

The text from the error Dreamweaver throws is allover the internet with no practical solution. The most I have found is – “well Dreamweaver needs to be configured” and stuff like that. I played quite a bit with this since I wanted to resolve it. I have webmaster and web development experience now 12 years but never worked with DW. I always used non WYSIWYG editors and I thought I will try the widely admired Dreamweaver. So I wanted to start on the right foot and figure out the problem.

This is what I did.

I was starting a new website on which I had perfectly well installed PHP and MySQL as with the dozens ones I installed before and I even wrote a few short scripts involving both PHP and MySQL to test the HTTP / PHP / MySQL / Apache stack is working fine.

This did not help Dreamweaver identify that there is a working website installed.

Then, though this was the site I wanted to connect with I tried direct DW to one of my existing sites - and that worked - it identified them. “OK, so what is the difference?”, I thought.
Well, one difference I could think of was that all other sides had a default page already set up - one that will return a valid HTML page to the browser if I typed just the website address ( )
even if I do not enter a page name. Of course in most cases on your web server that is set to be index.php, index.html or default.php etc. I mostly use index.php.

So I created as simple index.php - made sure it shows up on a browser and the tried to put the website address (without the page name, as initially instructed by DW) and everything worked.
So when you are at that stage of setting up a new site on DW, in addition to setting the website (which you probably did perfectly already) go ahead and add a default page (if PHP server technology a index.php) and test it responds to the website address. This should let the DW go through that stage perfectly.

Obviously Dreamweaver has no way to identify a healthy response from the website unless there is a page that returns valid HTML when the website address (without a pages name) is requested.

I guess if you are using a different technology - .NET or Cold Fusion you will need a default page like that in the respective technology or simply in html.

Happy webmastering!