Urls get appended with a hypen and number at the end like -2 (1 post)

While adding a new page with a title ‘2011’ the permalink for it gets generated with a hyphen and a number like ‘2001-2’.

I have tried deleting all previous entries(drafts/trash etc) which didnt help. Also I have noticed the same behaviour with any number being added as page title for example a title of ‘999999’ would generate a link like ‘999999-2’

And just to rule out any possibilities, I have also cleared all the custom rules in .htaccess and have just kept the core rule as follows
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Its an important and urgent project for us and we need to go live with the url like http://domain.com/parent/2011

Please advice how we can get over this issue.

It’s because the slug for ‘2011’ is already in use for the archive of the year. I don’t think you can get rid of it. Your next option is probably to append something to the slug yourself instead of ‘2’.