URL include

include "http://dot.kr/x-test/include.php";

I have the code above at http://dot.kr/x-test/include.php.
The result said “URL file-access is disabled in the server configuration.”
Can I make it abled by the server configuration?
Where should I configure it?
I like to make it a designated URL file-access is possible.

You should not want this and also, should not need.

Into your php.ini file
(again, it’s a bad practice to do this)

To make things well you should be able to create a small interface into your x-test/include.php file so it can get parameters and also respond somehow.
Something like a small API.

Another solution is to download the file via ftp and include the content into your code.
Not the best choice but better than enable URL require.

I tried using file_get_contents(…)

<?php echo file_get_contents('http://dot.kr/x-test/include.php');?>a

This is the result:

[B]Warning[/B]:  include() [[function.include](http://localhost/blog/function.include)]: URL file-access is disabled in the server configuration in [B]C:\\myAapm\\APM_Setup\\htdocs\\x-test\\include.php[/B] on line [B]2[/B]

[B]Warning[/B]:  include(http://dot.kr/x-test/include.php) [[function.include](http://localhost/blog/function.include)]: failed to open stream: no suitable wrapper could be found in [B]C:\\myAapm\\APM_Setup\\htdocs\\x-test\\include.php[/B] on line [B]2[/B]

[B]Warning[/B]:  include() [[function.include](http://localhost/blog/function.include)]: Failed opening 'http://dot.kr/x-test/include.php' for inclusion (include_path='.') in [B]C:\\myAapm\\APM_Setup\\htdocs\\x-test\\include.php[/B] on line [B]2[/B]

The URL file-access is disabled in the server configuration in the REMOTE SERVER and not your localhost server

This works fine:

<?php echo file_get_contents('http://google.co.uk');?>

I also tried a non-existent URL and it failed due to the Server Response being 404 - File Not Found