"Untrusted certificate error" on public wifi connection


#1

Just today I had this surprising problem with my Android phone i.e the Untrusted Certificate Error! I was seeing the untrusted certificate error on my Android phone at the time of web browsing when I had connected to available wifi belonging to a power distribution company. I tried browsing different websites even Facebook and Twitter but still I was seeing the same error that was saying “The site’s security certificate is not trusted!”.

Usually this error comes when the website’s security certificate is expired but that’s not possible with most trusted websites like FB and twitter and eh! did I forget Sitepoint in trying to post on the forums for the solution?

Many times I thought that this public agency might have identified a strange connection to their network or it’s a virus attack on my phone or it’s hacking attack. I thought somebody is trying to remotely control my phone and blocking me from doing things on my phone, and etc. etc.

I have tried googling only to find strange possible causes like incorrect date and time not making the list but connection to my own wifi works seamlessly.

I am stucked now and really need your expert advice. Thank you!


#2

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.