Unpacking a tar file under RedHa tLinux


I am trying to un pack a tar file under RH Linux, but keep getting Error message.

So I issue command:

tar xvfz backup_June10_2012.tar

and get this Error message instead:

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

and FYI, I have checked to make sure that this is a good tar file, here:

file backup_June10_2012.tar

backup_June10_2012.tar: GNU tar archive

Appreciate what suggestions you may have.


How are you trying to unpack it? Under Ubuntu, I usually just right-click and choose “extract here”. I know you say it’s a good file, but have you tried downloading it again, because a corrupt file seems to be the chief cause of such messages.


As you suggested I deleted and re-uploaded the tar file, but i get the same Error messages.
I also tried unpacking this tar file on another server and got same Error messages too!

So maybe the command I used to make the backup is/was not good!
What command do you suggest best for backing up a directory and all files and dirs under that dir in Linux Redhat?

FYI, I used this command:

tar -cvf backup_June10_2012.tar anoox.com/

[FONT=Verdana]Firstly, I seldom use the command line, so mine might not be the best advice, but I think you’re missing the “z” to gzip your tar, which would explain the error message stating that it’s not in gzip format when you come to unpack it. :slight_smile:

You might find some help here. (I know that’s the Ubuntu forum, but I’m sure tar is tar, whichever distro you’re using.)[/FONT]

If you extract using option z then it will expect a gzipped tar, but when you create it you aren’t gzipping. Omit the z