Unable to update modified CSS code in Wordpress 4.1

Hi guys, I’m having a problem updating css styles in wordpress. I installed wordpress 4.1. Now when I made some changes like the menus and the header it went smoothly and runs as what I want. Then I went to Appearance and select Editor. I made some changes with my styleshhet like the menu bg and the width. But everytime I update my code and view my site it doesn’t change anything. I tried to reinstall and deactivate all the plugins but seems no luck. I can’t get started. I need to publish my site asap. Please help. skinwhitening101-intl.com

What code have you added to what part of your website? What changes are you not seeing? Please be descriptive.

Also, are you using one of the WordPress themes?

So what I want to do is this
original code is
#access{ background:#fff; }
then I would like to change it to
#access{ background:#730486; }

then I click on Update File then Visit Site and no changes made. the Background color did not change. That’s what happen to all of my codes. I’m using twenty ten.

I am using Twenty Ten Theme.

Your styles.css file is showing this (not backgorund:#FFF like you state)

#access {
	background: #000;
	display: block;
	float: left;
	margin: 0 auto;
	width: 960px;

So I dunno…it’s not a specificity issue or anything with CSS. Something is wrong with the CMS itself.

Do you have any server caching in use in your server? Cloudfare or something similar?

Yes I have, And I am thinking that could be the problem. But I don’t know how to configure it. I have w3 total cache. But I already deactivate the plugin but aside from w3 cache I know my web host has also a DNS Cache thing I think.

Try and purge the cache. If you are unsure how to do this then get in contact with your host.

Purge and disable all server caching for now.

Sure I will do it now and let me see if there will be any changes. Hope this one will work. :grin:

Hi, I just disabled my wordpress caching and my host DNS Caching tool. I am now trying if there will be any changes in my site but it is still the same what it is before, I notice that my DNS Caching is set to 24 hours. Would it be possible that I need to wait about 24 hours before my code will take effect?

I don’t know about your own caching but on Cloudfare there is an option to purge your cache to get rid of what the server is storing. Is there any option for that? Ask your host to make sure.

This is what I have. i go to Cache Control Tool > Website Files and then options are WordPress Install 15 Minutes 1 Hour 4 Hours 24 Hours Don’t Cache and then I selected Don’t Cache then save changes. Under that is WordPress Cache the option is Turn it on and off. Then I turn it off. Log in to my wordpress do some changes with css, view my site and still no changes. No luck. hmm may be I’ll just wait tomorrow I think.

By the way my hosting server is iPage

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.