Unable to install angular quick start due to typings folder


I’m trying to install the Angular 2 packages to do the quick start tutorial but I can’t seem to create the packages to start the project . I believe it has something to do creating the typings folder.

Any help you can provide would be greatly appreciated:
Ubuntu server: 16:10
node v4.2.6
npm v3.5.2

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'run', 'typings', 'install' ]
2 info using npm@3.5.2
3 info using node@v4.2.6
4 verbose run-script [ 'pretypings', 'typings', 'posttypings' ]
5 info lifecycle angular2-quickstart@1.0.0~pretypings: angular2-quickstart@1.0.0
6 silly lifecycle angular2-quickstart@1.0.0~pretypings: no script for pretypings, continuing
7 info lifecycle angular2-quickstart@1.0.0~typings: angular2-quickstart@1.0.0
8 verbose lifecycle angular2-quickstart@1.0.0~typings: unsafe-perm in lifecycle true
9 verbose lifecycle angular2-quickstart@1.0.0~typings: PATH: /usr/share/npm/bin/node-gyp-bin:/var/www/html/testing/htdocs/angular/heroes/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
10 verbose lifecycle angular2-quickstart@1.0.0~typings: CWD: /var/www/html/testing/htdocs/angular/heroes
11 silly lifecycle angular2-quickstart@1.0.0~typings: Args: [ '-c', 'typings "install"' ]
12 info lifecycle angular2-quickstart@1.0.0~typings: Failed to exec typings script
13 verbose stack Error: angular2-quickstart@1.0.0 typings: `typings "install"`
13 verbose stack spawn ENOENT
13 verbose stack     at ChildProcess.<anonymous> (/usr/share/npm/lib/utils/spawn.js:17:16)
13 verbose stack     at emitTwo (events.js:87:13)
13 verbose stack     at ChildProcess.emit (events.js:172:7)
13 verbose stack     at maybeClose (internal/child_process.js:821:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
14 verbose pkgid angular2-quickstart@1.0.0
15 verbose cwd /var/www/html/testing/htdocs/angular/heroes
16 error Linux 4.4.0-21-generic
17 error argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "typings" "install"
18 error node v4.2.6
19 error npm  v3.5.2
20 error file sh
21 error code ELIFECYCLE
22 error errno ENOENT
23 error syscall spawn
24 error angular2-quickstart@1.0.0 typings: `typings "install"`
24 error spawn ENOENT
25 error Failed at the angular2-quickstart@1.0.0 typings script 'typings "install"'.
25 error Make sure you have the latest version of node.js and npm installed.
25 error If you do, this is most likely a problem with the angular2-quickstart package,
25 error not with npm itself.
25 error Tell the author that this fails on your system:
25 error     typings "install"
25 error You can get information on how to open an issue for this project with:
25 error     npm bugs angular2-quickstart
25 error Or if that isn't available, you can get their info via:
25 error     npm owner ls angular2-quickstart
25 error There is likely additional logging output above.
26 verbose exit [ 1, true ]

Hey @robin01, could you point us in the direction of the tutorial you’re following?

Is there a reason that things cannot install? The cli shows more useful info than strangely enough the log file.

If it timed out for example, it may be due to proxy settings for which some good advice is given at https://github.com/typings/typings/issues/581

Hi Fretburner,

the tutorial is right from Angular.io site, I’m going through there quick start tutorial:

I even tried sudo npm run typings install with no success.

I was able to create the project 2 weeks ago and decided to do the project over again to get a bit more understanding but for some reason this time i cant seem to create the project.

Hi Paul_Wilkins,

Not sure if it a time out issue but i could be wrong. 2 weeks ago i was able to create the project for the quick start tutorial on angular.io tutorial but for some reason I can’t seem to create the files this time round. Far as I can tell, most of the folders and files were created except for typings for example node_module module.

You can issue the command npm install over again and it will attempt to fill in any missing parts.

Maybe it’s worth trying with Angular 2 CLI

I’ve used it and it currently supports Angular 2 RC4. If you google then you can find a way to create RC5.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.