Good one. You are now going to create a new function just above the togglePlayButton one, called isPlaying(button)
That function will just return true/false, and from the if statement, we will use that function to check if it's okay to play.
This is a good time though to revisit the naming of the "playing" class. The purpose of it is to set how the play button looks after the initial image has been clicked.
The "playing" class is still there when it is playing and when it's paused, so another name like "active" is more appropriate, and certainly less confusing when we're working with the code.
What do you think? Shall we rename "playing" to "active", or to something else that you think is more appropriate?