Trouble installing Ember

Hey guys, I posted this thread on Ember’s forums but they seem to be a little dead - hope you don’t mind me posting here too. I’m trying to install ember-cli on linux, and the installation gets about halfway then suddenly stops.

nom@nomcodes:/var/www/html$ sudo npm install -g ember-cli@2.4
npm WARN deprecated lodash-node@2.4.1: This package has been discontinued in favor of lodash@^4.0.0.
npm WARN deprecated graceful-fs@3.0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible.
extract → gunzTarPerm     ▄ ╢███████████████████████████████████████████████████████████████████████████████████████████████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟
nom@nomcodes:/var/www/html$

Note that sometimes the final progress bar ends on extract:ember-cli-test-in. Of course, ember is unrecognized:

nom@nomcodes:/var/www/html$ ember -v
No command 'ember' found

I’m using Node v5.7.1, npm 3.6.0, and git 1.9. Any ideas?

Is there a reason you want to install that version 2.4?

npm install -g ember-cli

Those messages aren’t errors, they’re warnings. I see them too with the latest version but installs fine and the ember command works.

ember

You might have a $PATH issue, where executables installed with the global flag aren’t accessible from your shell. I don’t think it’s a problem with the ember-cli package itself. Check this from your terminal, linux might be different to osx so if these don’t work for you, you might need to do some googling.

npm config get prefix
echo $PATH

The first path is the path to node
The second is a list of directories that your shell will look through to find executables that you’re attempting to run, things like ember
So, the $PATH variable should contain the path to node and then your shell will be able to find and run ember.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.