Time function won't display correctly

Date not showing correctly on posts on this blog. Showing as January , Tuesday12 2010 instead of day first. Date format in Settings is set to: Date Format January 13, 2010

Also tried copying and pasting different meta times into singlepost.php but won’t work. Tried copying meta time from WP codex but won’t work either:

<?php the_time(‘l, F jS, Y’) ?>

Any ideas?

That’s what I thought. Here’s the code right from the singlepost.php:

<?php get_header(); ?>
<?php include (TEMPLATEPATH . ‘/sidebar1.php’); ?>
<div id=“content”>
<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
<div class=“content_container”>
<h3><a href=“<?php the_permalink() ?>” rel=“bookmark” title=“Permanent Link to <?php the_title_attribute(); ?>”><?php the_title(); ?></a> </h3>

<div class=“date”>
<?php the_time(‘l, F jS, Y’) ?>


<?php the_content(‘<div class=“more”> More</div>’); ?>
<div class=“comment_template”>
<?php comments_template(); ?>

<?php endwhile; endif; ?>


<?php get_footer(); ?>

Please define “won’t work”? That call to the_time produces “Tuesday, January 12th, 2010”.

See blog. It’s showing as: January , Wednesday13 2010 in FF. Not in yours?

That output can’t from that code. It doesn’t even have the same number of commas. Are you sure you’re editing the right files?

The page you linked is a category page, not a single post, so that’s the wrong file to edit to change it.

WordPress Template Hierarchy

You’re looking for category.php, or if that doesn’t exist, archive.php, or if that doesn’t exist, index.php.

Your single posts are displaying the desired date format.

You got it Dan. Thank you!!

So confusing…I was thinking since it was a post on the category page, I’d change the single.php file. I don’t think I would have figured out it was archive.php not even from the link you sent??

Thanks so much! Can I ask you another question about paid templates and customizing them or should I start another post?

I’d start another post as it’s a different topic.

Done. Thanks!