This is driving me nuts......mysql message

Hi, I’m sorry but I’m back and in trouble:):slight_smile:

I reported a problem a couple of weeks back but thought I had cured it.

I am new to mysql and am using a CobaltRaq4 Server running Apache webserver with PHP4 installed.

When I Telnet in and login to my newly created database I am unable to issue commands because I keep getting the message “ignoring query to other database” whenever I type a command.
I seemed to have cured the problem and had one session where I was able to create a table and add data to it but since then the problem has returned despite my logging on in exactly the same way.

The server dialogue is pasted below…can anyone help by offering a solution to this…thanks in anticipation.

Connection id: 28
Current database: netkwake

mysql> SHOW TABLES;
Ignoring query to other database
mysql> SHOW DATABASES;
Ignoring query to other database
mysql> CREATE DATABASE ukv;
Ignoring query to other database
mysql> USE test;
Database changed
mysql>
Connection id: 29
Current database: netkwake

mysql> SHOW TABLES;
Ignoring query to other database
mysql>

Please post the version of mysql you’re using, your command-line parameters, and your mysql user permissions. Make sure your command-line does not include the `-o’ flag.

I am replying to and revisiting this thread in the hopes that someone has a solution to this problem.

I am using MySQL 3.23.58 on Fedora Core 3 and have run into the same trouble using the terminal window. It began after we had a power outage that shut down the computer. It seems that this is the only problem area in the system. Even using root I cannot get much action from the database however PHP can still run queries, drop and make updates so it stands to reason only the terminal interface has been affected.

Here is a simple query and the responses:
mysql> use test
Database changed
mysql> show tables;
Ignoring query to other database
mysql>

Below is a the status \s of the server:

  • note that the database is blank even though we are using ‘test’
    ** also note “All updates ignored to this database”

mysql Ver 11.18 Distrib 3.23.58, for redhat-linux-gnu (i386)

Connection id: 27
Current database:
Current user: root@localhost

All updates ignored to this database
Current pager: stdout
Using outfile: ‘’
Server version: 3.23.58
Protocol version: 10
Connection: Localhost via UNIX socket
Client characterset: latin1
Server characterset: latin1
UNIX socket: /var/lib/mysql/mysql.sock
Uptime: 14 hours 35 min 24 sec

Threads: 1 Questions: 214 Slow queries: 0 Opens: 9 Flush tables: 1 Open tables: 3 Queries per second avg: 0.004


Has anyone got this one figured out?

Thanks,

are you using mysql -root or mysql -u root ?

ummmmmmm never mind :shifty:

Thanks for the quick and intuitive response. I logged in using -root and then used my up and down arrows instead of re-typing the commands. Doh!

How di you have that figured out so quickly?

:google: