The requested URL /cgi-bin/helloworld.cgi was not found on this server

Hello

I’m completely new here, but have read previous posts which have helped me out in the past. Been getting really confused by this one though and have not been able to find any help online as yet.

Basically, on my web server i put my files into the “httpdocs” folder then there is also a folder called “cgi-bin” which is on the same level as “httpdocs”. If i try to access http://www.welcome2-wales.com/cgi-bin/ then i get the following message:

Forbidden

You don't have permission to access /cgi-bin/ on this server.
Apache/2.0.51 (Fedora) Server at www.welcome2-wales.com Port 80

which i take to mean that the cgi-bin folder is active. then if i try to access a script that has been placed within the cgi-bin folder (e.g. http://www.welcome2-wales.com/cgi-bin/helloworld.cgi) it won’t let me, giving the following message:

Not Found

The requested URL /cgi-bin/helloworld.cgi was not found on this server.
Apache/2.0.51 (Fedora) Server at www.welcome2-wales.com Port 80

Any ideas why this would be? I would really appreciate it if anyone could help this newbie out.

Many thanks in advance - Gareth

readers of this thread may want to read this first so they don’t waste time posting duplicate suggestions:

http://www.codingforums.com/showthread.php?t=88945

sorry, not getting any response on that forum, plus the message was kinda hijacked by someone else

are you sure the script is named:

helloworld.cgi

all lower case letters followed by .cgi

heya,

yeh, just checked it again, but its the same with the formmail.pl script that i put there, it just doesnt seem to be able to find it.

well, I don’t know what to say. The cgi-bin appears to be there:

http://www.welcome2-wales.com/cgi-bin/

that is typical that access directly to the cgi-bin if forbidden. Are you sure there is no cgi-bin below the httpdocs folder? That is where it genarally is, not at the same level, although maybe that is OK depending on the server setup.

yeh, i thought it was weird it was obove httpdocs as well, but it is.

its hosted with 1&1 but they are being hopeless with support.

i’m completely stuck.

if you have FTP access and want to PM me your FTP login info I will take a look.

You can change your login information after I let you know if I was able to help or not. If you would rahter not I understand but I am out of ideas at this point. I’ll check my PM’s in a little while.

you’ve got mail.

thanks for your help - much appreciated - you’re a star