The CSS Stylesheet doesn't seem to work Is it me or the web page provider?

My pages are currently not showing correctly. is the easiset one

The nspector shows the CSS as expected but one of it seems to work.

Have I inadvertently done something or is the host company?

I have tried on two computers with three browsers and my mobile phone

What specifically is different about how the page displays and how you are expecting it to display?

The drop down menu isn’t there, the menu items from it are all showing at the bottom

Line 47

.padding191112 {padding-left:25%; 

What is missing?

1 Like

Hi there certificates,

I don’t know if this will cure all of your problems but
on line #47 of your “testcss.css” file you have this…

.padding191112 {padding-left:25%;

…which, as you may observe, is missing an important
closing curly bracket. :wonky:


Thanks for that. I have corrected it, but the host has now said that it down to them and will take 24 hours to resolve. I have of course added th ebracket

I bet they say that to everyone. :biggrin:

At least I know it’s not me!

Are you suggesting that your host deleted your bracket? :shifty:


Hi there certificates,

it is now three hours since you stated that
you had added the missing curly bracket.

A quick check of your site reveals that this
assertion of yours is untrue. :unhappy:

Apart from the fact that your navigation is
reliant upon javascript for it’s functionality,
the page will render perfectly when it is
actually replaced. :rolleyes:

Why you should believe that your problem
is in strange way caused by you host is, to
put it mildly, beyond my comprehension. :eek:



If it is beyond your comprehension, perhaps you aren’t imaginative enough,

Here is a transcript of my "chat " with them. However the page is now back in order, Thanks for your interest though

Antony Lambert (14/01/2017 11:06:02):
My web pages do not appear to be showing correctly. The CSS stylesheets are not being read at all

Daniel (14/01/2017 11:09:03):
Good morning! Welcome to 123-reg Live Chat. My name is Daniel and I will be assisting you today.

Antony Lambert (14/01/2017 11:09:38):

Antony Lambert (14/01/2017 11:10:57):
The web page is ad there are no drop down menus showing for one thing

Daniel (14/01/2017 11:11:38):
Please allow me a few moments to check your account, Antony.

Antony Lambert (14/01/2017 11:12:05):

Daniel (14/01/2017 11:16:56):
Thanks for waiting.

Antony Lambert (14/01/2017 11:17:14):

Daniel (14/01/2017 11:18:36):
The domain is incorrectly pointing to the 123-reg hosting package IP address and to an external IP address as well.

Antony Lambert (14/01/2017 11:19:11):
Can you resolve it then please

Daniel (14/01/2017 11:20:32):
Is this the website that should be displayed?

Antony Lambert (14/01/2017 11:21:06):
Yes that is one of them, but they all start with

Daniel (14/01/2017 11:22:26):
Please bear with me a few more moments.

Antony Lambert (14/01/2017 11:22:39):

Daniel (14/01/2017 11:24:28):
I have now removed the DNS records pointing to the IP address Please allow up to 24 hours for the changes to occur.

Antony Lambert (14/01/2017 11:25:27):
Will that work for all the pages?

Daniel (14/01/2017 11:26:02):
The DNS changes apply to the domain and to the website. All pages should work as expected after the propagation process.

Antony Lambert (14/01/2017 11:26:30):
OK Thanks. Do you know why it happened? Was it something I did?

Daniel (14/01/2017 11:27:34):
Most probably the IP address was from a previous SSL certificate installed on the domain.

Daniel (14/01/2017 11:27:46):
However, if you are still encountering issues please contact us once more and we will try to further assist.

Antony Lambert (14/01/2017 11:28:35):
I will come back tomorrow if it doesn’t work. You said 24 hours. It isn’t instant because I have tried reloading the pages

Daniel (14/01/2017 11:29:24):
The DNS propagation process takes up to 24 hours.

Antony Lambert (14/01/2017 11:30:04):
OK. Let’s see by tomorrow. If no luck I shall chat agin. Thanks for the help

No I meant it wasn’t me who had caused it to show in correctly

The events were slightly different here.
At first I was quite baffled by the problem and why most of the css (but not all) was being ignored.
To determine whether the problem was related to your host, I made a local copy of your page on my own computer, I also made a local copy of the css file.
I edit the absolute path to your css in the head to point to my local copy.
The result was that the exact same problem with the menu styling existed.
This eliminated the idea that your host was at fault.
However in my editor, a validation error flagged at line 47.
On examining line 47 I notice the absence of a closing bracket.
After adding the missing bracket and refreshing the browser, the menu appeared as expected.
At around the same time @coothead came to the exact same conclusion.

Admittedly my imagination does seem to be struggling here. :wonky:


All I can say is that you are the guys with the experience. It seems
strange that my host would say there’s a problem if there weren’t and why would it take all that time for the sheet to work properly again.if there weren’t a problem.

Has it started working again?

Yes thanks it has been working for about 4 hours now

Did you add the missing curly brace?

Yes I have done that but it took about three hours from doing that until the pages worked fully again

It was working at the time of my last post, but it seems it wasn’t when @coothead last looked.
I’m not sure if the OP corrected it before then.
I have no doubt that the culprit was the missing bracket, just a common everyday coding typo.
Not sure what that stuff with the host was about, possibly a caching issue causing the old, invalid version to show up still.

I did correct it before then. I corrected it at lunchtime and it took till almost tea tome till the page worked again.I don’t see why the host would tell me there was a problem if there wasn’t