Switching Applications & Themes

I added a forum under my main web application, and the forum is itself configured as an ‘application directory’ in IIS. My problem is that when I navigate from my forum back to my parent application, it seems like the Theme for my parent application isn’t applied.

You can see it if you visit the forum, then click on the ‘My Sheet’ button at the top. If I navigate to the home page through the button, the theme is applied, but linking to any other pages seems to result in no styles being applied.

I’m not sure what you’re asking. While in the forum folder (and because the /forum folder is marked as an ‘application’ in IIS) my understanding was the ASP.net engine has no knowledge of the themes defined in my parent application. When I re-enter my main application (through clicking on the ‘My Sheets’ link) I would think that the ASP.net engine would re-discover that I’m back in a different ‘application’ and thus it needs to re-load the appropriate stylesheets.

If I enter the ‘Manage Sheets’ page directly without clicking through the forum (sorry this page is only viewable to registered users), the theme is applied correctly, it is only by clicking through the forum that the problem occurs. In both cases I’m simply entering the page through a link so I’m not sure that there could be an invalid css reference.

My guess is the path is wrong.
From the forum folder

<link type="text/css" href="App_Themes/CSWR/css/combinedCss.axd?key=##########" rel="stylesheet" />

the App_Themes folder is being found OK. But from the main folder

<link href="App_Themes/Football/CheatSheets/CheatSheets.css" type="text/css" rel="stylesheet" />

the App_Themes folder isn’t?